Archer C6 V2 Slow Upload Speed

Hi everyone. Hope anyone can help me as I lost an entire day trying to figure it out for no avail.
I installed latest stable build for Archer C6 v2 US - after much struggle I was able to set it to bridge (I think).
I have a technicolor isp router FGA 2232 that i can't get rid off and the Archer.
The problem is that i have 250Mbps download/150 upload but with the open-wrt i just can get half of that, even the FGA modem gives me those numbers, but the archer with open-wrt keeps around 60Mbps tops, in the same channels, through 5ghz connection.
They are connected through a gigabit port.
I tried upgrading to snapshot build, seemed to be a little better, but that's all.
Any info would be highly appreciated.
I'm considering going back to stock (actually tried, but couldn't get it to connect to tftp32/64).

You can try the SolarWinds software mentioned in the Tp-Link Archer C6 V2 Revert to Stock Firmware [Guide]

That router only has a Qualcomm Atheros QCA9563 for SoC, not exactly high performance. Others familiar with that SoC may comment what the download and upload performance should be.

This is my speedtests. As you can see wireless is a lot slower...

Thank you for your replies. Stock firmware I was getting the full Bandwidth 250 download and 150 upload, I decided to try open-wrt because i was getting random and frequent ping oscilation.
So I don't think It is limited hardware wise to get 60 Mbps only.

Thank you. Tried that one too, It was no different. The server log doesnt show any connection attempt.

Did you disable the firewall on the device running the TFTP server while attempting (i.e. the Windows Firewall)? :wink:

Yes I did.
The full steps - set ip to in my ethernet card, set it to 100mbps full duplex; connected to port 1 (not wan), tried,,, it was no different.
Set permissions windows firewall - nothing; disable the entire firewall nothing.
Tried both solarwind and tftp32/64 versions, nothing. No signal whatsoever that they are trying to connect.
Everytime I turned off the Archer C6, held the reset button and turned it on. A lock led turn on, and thats it. It just boots.
I don't have a switch device to try with it connected.