Archer C6 V2 EU - can't install OpenWRT

TLDR; router downloads the firmware via TFTP but then boots back to stock firmware


I decided to replace my ISP-provided TL-WR841ND (used only as access point) with a new router, because the old one started rebooting on larger downloads (strange I know, what can you do...).

Uploading the openwrt firmware through interface does not work, because the stock firmware is too new.

TFTP server is installed on my laptop (connected through old router wifi), firmware ( downloaded and renamed to ArcherC6v2_tp_recovery.bin, added IP address to wifi interface.

Archer C6 WAN port is connected through old router LAN1 (can't set 100mbps FD, swconfig does not allow it), but everything seems to work.

I held the reset button, powered on the router, wait for the WPS light and release the reset button.

TFTP server shows the request for the firmware, tcpdump shows the firmware being sent, then I wait...

after a minute lights on the router light up just like normal and I can connect to it like normal and it still has the factory firmware.

What can I do?

P.S.: I also tried with firmware from this post: 19.07 build for Archer C6 v2 but it acts the same.

I managed to install OpenWRT on the router in my office.
The router WAN port was connected to a mikrotik router. Didn't even have to set the speed and duplex.

I have no idea what was the issue at home as TFTP seemed to work, but I'm happy it works now :slight_smile:

maybe you have an electrical problem at home, that would explain the strange behavior of your old router and the C7.

I would test with an UPS or something

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.