Archer C6 on 22.03.2 crashes every ~3 days

@Nihilokrat thank you for your reply. I have still TP-link original software and when I try to install snapshot openwrt-ramips-mt7621-tplink_archer-a6-v3-squashfs-factory on my Archer A6 ver 3.20 as you have described then I get following error message :frowning:

Not sure, I suppose you haven't customized the packages, right? Have you tried the 22.03.3 stable version instead of snapshot? Please consider opening a seperate thread, too, since your issue is unrelated to the topic.

1 Like

Yes, I have tried. Same issue :frowning:

I would not do this. From a quick search of the commit history I found

Basically it looks like the 7613 firmware is in the 7663 kernel module and that the 7615 driver is used to control it. Removing any of those will therefore break 5GHz wireless and also possibly brick your router.

1 Like

I’m now at 4 days uptime having disabled HW acceleration. Will keep you posted…


Now at 6 days, which is pretty much a tie with my previous longest uptime. It looks a lot like HW acceleration is the unstable component triggering the fail/reboot. I don't know whether it's also what causes the reboot loop, or if the cause of the looping might be the same as the bug fixed here

Are there any OpenWRT developers here who might know more?

1 Like

Can you confirm which settings you ticked/unticked? Last weekend it happened again to me twice in the same day, and it's just happened again after about 5 days uptime for me.


I disabled HW acceleration in Network > Firewall

I had been using it to help performance, but it appears to have been the source of my instability.

1 Like

thanks - I will give this a go. I had both boxed unticked so will give SFO a go this week...

Note that I am on “stable” release 22.03.3

MT7613 is a badly supported radio unfortunately. I have an EAP235-Wall that uses it, saw lots of issues with it on OpenWrt. MT7615 or MT7915 radios are far more stable.

Things might be different now, but before 22.03 final at least the radio would hang frequently.

@Borromini any possibility that we can compile closed drivers? i'm trying hard but it just wont compile.

Unfortunately, even with software offloading I didn’t get 24 hours out of it. Just rebooted again. I’m tempted to swap this out for something else and would be happy to send it on to someone who would like to do some serial debugging but I’d really just like a stable router for more than a week!

just to be sure, can you try with 5ghz disabled?

I have no experience with the proprietary ones, nor any interest.

I have just now disabled this as a test, but it really hinders performance in my area. My tablet has gone from 70mbps on the 5ghz to 1mbps on 2.4ghz. I will give this a test for a bit but not sure I’ll be able to sustain speeds like that as streaming is the primary function of this iPad :rofl:

really, i can get 125 mbps on 2.4ghz closed drivers

Looks like I was being a bit dramatic, I just did another test and now I’m hovering around 10-20 mbps (on the 5ghz band I could get 130 from same spot … I’ve got a 350 mbit hookup to the internet) but not as bad. I’m in a fairly congested area, I can see about 30 SSIDs from my laptop

Was this with 22.03.3, or with master? I’m over a week now with no sign of issues.

I’m on master but will try 22.03.3 just to establish a baseline. You have 5Ghz enabled as well?