Archer C2600 v1.0 - LEDE support status

Hi there LEDE community. I have recently just purchased a Archer C2600 v1.0 and i am pretty keen to try out LEDE on it. I am just curious what is the current state of support for this particular router. I have been looking through the forums and am just a little unsure if the current release of LEDE i found here has any known issues with this router i would benefit from knowing about before i get started.

From what i have read so far, is that i am better off putting LEDE rather than OpenWRT on it as it has had more support. I also have read about some wifi issues, but i am unsure if they concern the C2600 v1.0 or not. Any advice / pointers / suggested reading would be appreciated as this is my first custom firmware adventure. Thank you in advance. :slight_smile:

1 Like

Also a few other small questions..

Does this build come with LuCI installed or do i need to install it after flashing the router?

I will need to connect to pppoe to get an internet connection after the flash, is the configuration the same as OpenWRT? Eg:

uci set network.wan.proto=pppoe
uci set network.wan.username=''
uci set network.wan.password='yourpassword'
uci commit network
ifup wan

And finally, are there any differences to keep in mind between the v1.0 and v1.1 versions of this router?

Thanks for your time to whoever chooses to read and answer any of my questions! :slight_smile:

I have a v1.1 that still has the reboot issue. Besides problems with USB3-devices (ditn't test with USB2 so far) it is pretty stable.
A v1.0 should be at least that stable.
Luci is not installed bij default. Wireless is off.


Ah okay great. im just reading through the issues thread.

Curious, what are the USB3 issues? Also do you know if network printer will work connected to the usb port on the router?

USB3 problems seems to be a user-problem :blush:.
I just connected a USB3 stick and HDD, and there is no problem.
I can not tell you if a printer is working.

Is there any firmware release as yet which comes with luci already installed?

Only unofficial builds, like mine:

1 Like

Is there a thread describing your build? Is it vanilla or packed with goodies?

Thanks so much for all your replies.. i have another question, would there be much of a difference between an official LEDE release which apparently is expected in early 2017, to whatever the dev snapshot is upto at the moment?

oh and also, if im installing the factoy release, after i flash with that do i need to then do the sysupgrade? or are they the same result from either one and it just depends on whether u are flashing from custom or factory firmware initially?

See manifest file:

1 Like

Thank you for this. That link is now dead and I guess I'm too newbish to find latest update for c2600 in your directory tree? Can you tell me where to look?

Also, the wireless regdb has been updated just a few days ago for my country, would it be too much trouble for you to include this in next build?


1 Like

Thank you, just upgraded, works great :slight_smile:

Thank you, switching to this got me over my upgrade anxiety, so I tried going to 17.0.1 official, and so I got to learn what packages I need to add. But I have one problem - when I reboot from the interface, the router just goes dead - no lights flashing or lit, every time. If I then pull the power and reconnect, it comes up fine.

Do you happen to have any suggestions on how to fix this?


You problably have a version 1.1 instead of a version 1.0.
Version 1.1 needs a patch that is not in Lede v17.01.0.

1 Like

Thank you

It is C2600 capable of 1Gb speeds?
I ask because i have this router and do not pass the 600Mbps speed test!

Try stable LEDE 17.01.2.

On LEDE 17.01.2, I have setup my C2600 in wireless client/bridge mode without rebroadcasting another SSID. I am able to get it connected on 4 streams according to Luci but am not able to get transfer speed higher than 250mbps in either direction (RX and TX). It looks like either only 1 out of 4 streams are transmitting or there is a throughput limitation in the C2600. I am able to get 700mbps with a 3 stream client to the same AP so the issue is not from the AP. Any idea on how to fix this?