626 (edited by RedVortex 2016-07-16 19:52:58)

Re: Support for TP-Link Archer C2600

jmomo wrote:

Hey RedVortex, based on that Putty screenshot, I'm guessing that you are using the wrong character set. Your host is UTF8 and your putty is configured for something else.

https://serverfault.com/questions/47592 … characters

Haha, I'm so used to this misconfiguration that prevents line drawing to not display properly that I don't even notice it anymore.

In my case, I was running my build server in a LXC which had not default set and since all my terminals are usually UTF-8 this one didn't work, I had to switch it to ISO-8859-1. wink

Anyways, here's a better screenshot

https://snag.gy/dgIx7c.jpg

Re: Support for TP-Link Archer C2600

airwoflowrt wrote:
Videopac wrote:

I just noticed that my 2,4GHz connections are 54Mbit/s max. Still using Heinz r787 build.

Will take a look at my setup when I get home, but I definitely saw 84Mb/s for my laptop connected over 2.4Ghz last night.

I do get over 54M/bit on 2.4Ghz but not a lot over 104 mind.

I also have an issue with an Android 6.0 device which will drop wifi for about 5-10 seconds and then reconnects. Does this every 3-5 minutes or so. Anyone else with similar issues?

Re: Support for TP-Link Archer C2600

I am thinking of buying this router. From what I have been reading in this thread, Heinz build is the most stable. Unfortunately, it does not have a large range of packages as in the trunk. If I go with this build, can I still use packages from https://downloads.openwrt.org/snapshots … packages/?

Thanks.

629 (edited by FifiTheReal 2016-07-17 08:54:10)

Re: Support for TP-Link Archer C2600

Dear Members,

I have installed Heinz's firmware r787 my friend's C2600 v1.1. Lede is running fine but not working wifi's led (no target in /sys/class/leds/) therefore we would like restore the factory firmware.

I probed debricking method from https://wiki.openwrt.org/toh/tp-link/tp … r_c2600_v1 but not working.

My steps:
1.) I downloaded tp-link fw C2600-UN-up-ver1-1-2-P1[20150924-rel66045].bin and rename ArcherC2600_1.0_tp_recovery.bin.
2.) Connect my notebook to router LAN1 port.
3.) Router power off
4.) I set my notebook IP and stop firewall:

root@blackbook:~# ifconfig 
eth0      Link encap:Ethernet  HWaddr f0:de:f1:39:70:75  
          inet addr:192.168.0.66  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::f2de:f1ff:fe39:7075/64 Scope:Link
          inet6 addr: fd71:ecb:f7ce:0:f2de:f1ff:fe39:7075/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:40305 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18557 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:55912557 (53.3 MiB)  TX bytes:2007724 (1.9 MiB)
          Interrupt:20 Memory:f2500000-f2520000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1932 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1932 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:183371 (179.0 KiB)  TX bytes:183371 (179.0 KiB)

root@blackbook:~# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination 

   
5.) I start ping the router:     

ping 192.168.0.1


6.) Press and hold reset button router and power on
7.) When i see this:
     

From 192.168.0.66 icmp_seq=2000 Destination Host Unreachable
From 192.168.0.66 icmp_seq=2001 Destination Host Unreachable
64 bytes from 192.168.0.1: icmp_seq=2002 ttl=64 time=0.558 ms
64 bytes from 192.168.0.1: icmp_seq=2003 ttl=64 time=0.132 ms
64 bytes from 192.168.0.1: icmp_seq=2004 ttl=64 time=0.121 ms
64 bytes from 192.168.0.1: icmp_seq=2005 ttl=64 time=0.174 ms
64 bytes from 192.168.0.1: icmp_seq=2006 ttl=64 time=0.180 ms

i start this command in other terminal:

atftp --trace --option "timeout 1" --option "mode octet" --put --local-file ArcherC2600_1.0_tp_recovery.bin 192.168.0.1

and release the reset button.

Result:

Trace mode on.
Option timeout = 1
Option mode = octet
sent WRQ <file: ArcherC2600_1.0_tp_recovery.bin, mode: octet <timeout: 1>>
timeout: retrying...
sent WRQ <file: ArcherC2600_1.0_tp_recovery.bin, mode: octet <timeout: 1>>
timeout: retrying...
sent WRQ <file: ArcherC2600_1.0_tp_recovery.bin, mode: octet <timeout: 1>>
timeout: retrying...
sent WRQ <file: ArcherC2600_1.0_tp_recovery.bin, mode: octet <timeout: 1>>
timeout: retrying...
sent WRQ <file: ArcherC2600_1.0_tp_recovery.bin, mode: octet <timeout: 1>>
timeout: retrying...
sent WRQ <file: ArcherC2600_1.0_tp_recovery.bin, mode: octet <timeout: 1>>
timeout: retrying...
tftp: aborting

and ledge is booting fine.

I tried atftp instead of tftp and changed LAN1 port to other but any result. Always lede is booting. Where is the mistake?

Thank you in advance for your response!

Edit: I probed tftp start before router power on whit reset's pressing but any result.

630

Re: Support for TP-Link Archer C2600

@FifiTheReal to use recovery mode You must have tftp server, not client. Try TFTPD and share file ArcherC2600_1.0_tp_recovery.bin on root directory.

Currently Wireless leds in C2600 are not supported in LEDE/OpenWrt, but wireless work corectly.

Re: Support for TP-Link Archer C2600

Heinz wrote:

@FifiTheReal to use recovery mode You must have tftp server, not client. Try TFTPD and share file ArcherC2600_1.0_tp_recovery.bin on root directory.

Oh, my big mistake ... Thank you very much! Factory firmware is running.

Heinz wrote:

Currently Wireless leds in C2600 are not supported in LEDE/OpenWrt, but wireless work corectly.

We tested wifi and fine but my friend would like see led indicators ... and i can't configured dropbear with public-key authentication.

I copied from friend's old openwrt router's

/etc/config/dropbear
/etc/dropbear/authorized_keys
/etc/dropbear/dropbear_dss_host_key.pub
/etc/dropbear/dropbear_dss_host_key
and /etc/dropbear/dropbear_rsa_host_key

files to c2600.  Checked permissions and dropbear restart. When i ssh to c2600 from my notebook i see this:
Permission denied (publickey). When i changed option from PasswordAuth 'off' to PasswordAuth 'on' i can logged in with password.

If i ssh to old router from my notebook with public-key everyting is ok.

Re: Support for TP-Link Archer C2600

This should fix some or all of the wireless issues in LEDE trunk btw
https://git.lede-project.org/?p=source. … e372d5bc53

Re: Support for TP-Link Archer C2600

FifiTheReal wrote:

We tested wifi and fine but my friend would like see led indicators ... and i can't configured dropbear with public-key authentication.

I copied from friend's old openwrt router's

/etc/config/dropbear
/etc/dropbear/authorized_keys
/etc/dropbear/dropbear_dss_host_key.pub
/etc/dropbear/dropbear_dss_host_key
and /etc/dropbear/dropbear_rsa_host_key

files to c2600.  Checked permissions and dropbear restart. When i ssh to c2600 from my notebook i see this:
Permission denied (publickey). When i changed option from PasswordAuth 'off' to PasswordAuth 'on' i can logged in with password.

If i ssh to old router from my notebook with public-key everyting is ok.

I tried dropbear using public key auth with Heinz's version and it works very well.

For public key auth, the only thing you need to do is add your public key to authorized_keys. You do not (and should not) put/replace anything else in /etc/dropbear.

Your dropbear /etc/dropbear folder will end up looking like this (make sure the permissions are like this as well on the files

root@lede:/etc/dropbear# ls -al
drwx------    1 root     root             0 Jul 17 10:35 .
drwxrwxr-x    1 root     root             0 Jun 22 13:35 ..
-rw-r--r--    1 root     root           225 Jul 17 10:35 authorized_keys
-rw-------    1 root     root           805 Jun 22 13:32 dropbear_rsa_host_key

The file dropbear_rsa_host_key belong to this router's dropbear.

Note: I am using RSA for my keys, not DSA (DSS=DSA) and I think that, by default dropbear doesn't use DSA either but you seem to want to use DSA.

If you need to enable DSA, you have to change a few things to make this work. Unless you really need DSA for some reason, I suggest you use RSA.

Re: Support for TP-Link Archer C2600

bendavid wrote:

This should fix some or all of the wireless issues in LEDE trunk btw
https://git.lede-project.org/?p=source. … e372d5bc53

I'm starting another build to test this patch. Thx for watching the commits :-)

Re: Support for TP-Link Archer C2600

RedVortex wrote:

If you need to enable DSA, you have to change a few things to make this work. Unless you really need DSA for some reason, I suggest you use RSA.

My notebook:

fifi@blackbook:~$ cat /home/fifi/.ssh/id_dsa.pub > authorized_keys
fifi@blackbook:~$ scp -P 22 authorized_keys root@192.168.1.1:/etc/dropbear/.
root@192.168.1.1's password: 
authorized_keys                                                                                      100%  603     0.6KB/s   00:00 

   

Router:

root@LEDE-Home-TP-Link:/etc/dropbear# ls -l
-rw-r--r--    1 root     root           603 Jul 17 19:25 authorized_keys
-rw-------    1 root     root           805 Jun 22 19:32 dropbear_rsa_host_key
root@LEDE-Home-TP-Link:/etc/dropbear# cat /etc/config/dropbear
config dropbear
    option PasswordAuth 'off'
    option RootPasswordAuth 'on'
    option Port         '22'
#    option BannerFile   '/etc/banner'
root@LEDE-Home-TP-Link:/etc/dropbear# /etc/init.d/dropbear restart

Notebook:

fifi@blackbook:~$ ssh -p 22 root@192.168.1.1
Permission denied (publickey).

Notebook verbose:

fifi@blackbook:~$ ssh -v -p 22 root@192.168.1.1
OpenSSH_6.7p1 Debian-5+deb8u2, OpenSSL 1.0.1t  3 May 2016
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: Applying options for *
debug1: Connecting to 192.168.1.1 [192.168.1.1] port 22.
debug1: Connection established.
debug1: key_load_public: No such file or directory
debug1: identity file /home/fifi/.ssh/id_rsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/fifi/.ssh/id_rsa-cert type -1
debug1: identity file /home/fifi/.ssh/id_dsa type 2
debug1: key_load_public: No such file or directory
debug1: identity file /home/fifi/.ssh/id_dsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/fifi/.ssh/id_ecdsa type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/fifi/.ssh/id_ecdsa-cert type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/fifi/.ssh/id_ed25519 type -1
debug1: key_load_public: No such file or directory
debug1: identity file /home/fifi/.ssh/id_ed25519-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.7p1 Debian-5+deb8u2
debug1: Remote protocol version 2.0, remote software version dropbear_2016.73
debug1: no match: dropbear_2016.73
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-sha1 none
debug1: kex: client->server aes128-ctr hmac-sha1 none
debug1: sending SSH2_MSG_KEX_ECDH_INIT
debug1: expecting SSH2_MSG_KEX_ECDH_REPLY
debug1: Server host key: RSA e7:de:e3:34:ba:f2:60:81:77:90:14:9e:cd:78:bf:34
debug1: Host '192.168.1.1' is known and matches the RSA host key.
debug1: Found key in /home/fifi/.ssh/known_hosts:1
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Trying private key: /home/fifi/.ssh/id_rsa
debug1: Offering DSA public key: /home/fifi/.ssh/id_dsa
debug1: Authentications that can continue: publickey
debug1: Trying private key: /home/fifi/.ssh/id_ecdsa
debug1: Trying private key: /home/fifi/.ssh/id_ed25519
debug1: No more authentication methods to try.
Permission denied (publickey).

My public keys are dsa and other router is working out of box:

fifi@silent:~$ ssh -p 20022 root@openwrt
Enter passphrase for key '/home/fifi/.ssh/id_dsa': 

BusyBox v1.19.4 (2013-03-14 11:28:31 UTC) built-in shell (ash)
Enter 'help' for a list of built-in commands.

  _______                     ________        __
 |       |.-----.-----.-----.|  |  |  |.----.|  |_
 |   -   ||  _  |  -__|     ||  |  |  ||   _||   _|
 |_______||   __|_____|__|__||________||__|  |____|
          |__| W I R E L E S S   F R E E D O M
 -----------------------------------------------------
 ATTITUDE ADJUSTMENT (12.09, r36088)
 -----------------------------------------------------
  * 1/4 oz Vodka      Pour all ingredients into mixing
  * 1/4 oz Gin        tin with ice, strain into glass.
  * 1/4 oz Amaretto
  * 1/4 oz Triple sec
  * 1/4 oz Peach schnapps
  * 1/4 oz Sour mix
  * 1 splash Cranberry juice
 -----------------------------------------------------
root@OpenWrt-Home-TP-Link:~# cat /etc/dropbear/authorized_keys | cut -d" " -f1
#
ssh-dss
#
ssh-dss
#
ssh-dss
#
ssh-dss
#
ssh-dss
root@OpenWrt-Home-TP-Link:~# opkg list | grep dropbear
dropbear - 2011.54-2

I forced reinstall dropbear but anything change.
I don't want to replace all the keys. What can i do?

Re: Support for TP-Link Archer C2600

RedVortex wrote:
bendavid wrote:

This should fix some or all of the wireless issues in LEDE trunk btw
https://git.lede-project.org/?p=source. … e372d5bc53

I'm starting another build to test this patch. Thx for watching the commits :-)

I finished my build (r1009, it includes a few other commits that came after the patch above, the one in the LEDE repos is 1006)

Indeed, this build is working well. No more wireless errors, awesome ! :-)

637 (edited by RedVortex 2016-07-17 19:15:28)

Re: Support for TP-Link Archer C2600

FifiTheReal wrote:
RedVortex wrote:

If you need to enable DSA, you have to change a few things to make this work. Unless you really need DSA for some reason, I suggest you use RSA.

I forced reinstall dropbear but anything change.
I don't want to replace all the keys. What can i do?

Like I said, dropbear in our current builds doesn't seem to support DSA (DSS). You need to create yourself RSA keys in your notebook and put the RSA public key in the authorized_keys of your router. Then, when you connect to the router you will need to use your RSA key

to generate a rsa key in your notebook (make sure you don't already have one or this will overwrite it...

ssh-keygen -t rsa

Then copy the content of

~/.ssh/id_rsa.pub

from your notebook to the authorized_keys file in /etc/dropbear/ in your router

(you don't need to restart dropbear, this file is read every time you connect to your router using dropbear)

then from your notebook connect to your router.

ssh root@192.168.1.1

If it doesn't work, it means your ssh client is using the non-RSA key by default and you'll need to force it to use the RSA key you have just created like this (make sure to put the private key here, not the public one)

ssh -i ~/.ssh/id_rsa root@192.168.1.1

I've just tested this and it works.

I do not know why dropbear doesn't also support DSA (DSS) by default but like I said, you are better off with RSA than DSA in my opinion...

638 (edited by airwoflowrt 2016-07-18 01:47:04)

Re: Support for TP-Link Archer C2600

RedVortex wrote:
RedVortex wrote:
bendavid wrote:

This should fix some or all of the wireless issues in LEDE trunk btw
https://git.lede-project.org/?p=source. … e372d5bc53

I'm starting another build to test this patch. Thx for watching the commits :-)

I finished my build (r1009, it includes a few other commits that came after the patch above, the one in the LEDE repos is 1006)

Indeed, this build is working well. No more wireless errors, awesome ! :-)

Nice! You don't have an Android 6.x device to test it against do you? Am running r787 with VLAN'd wifi SSIDs and roaming across multiple devices. The only problem for me is the dropping of connectivity issue every couple of minutes or so.

P.

639 (edited by RedVortex 2016-07-18 02:19:32)

Re: Support for TP-Link Archer C2600

airwoflowrt wrote:

Nice! You don't have an Android 6.x device to test it against do you? Am running r787 with VLAN'd wifi SSIDs and roaming across multiple devices. The only problem for me is the dropping of connectivity issue every couple of minutes or so.

P.

No but it seems like LEDE just finished a new build that should be the same as mine (r1009)

https://downloads.lede-project.org/snap … x/generic/

It's a bit larger than mine actually, I'm not too sure why... but still, it should include all the latest patches that fix the wireless issues.

If you want my build, let me know, I can make it available as well. Mine is the very basic image + Luci (not ssl), I really do wonder why LEDE's build is larger, especially considering it doesn't include Luci...

640 (edited by RedVortex 2016-07-18 04:07:03)

Re: Support for TP-Link Archer C2600

For this firmware to be perfect, I think it is still missing 2 things...

Important: Find out why reboot on v1.1 (some ppl say it works on v1.0, we still need a real answer on this one) doesn't work but just hangs. Regarding this, I've also tried a reboot using sysrq and it doesn't work either so I guess it may just be that the instructions to reboot the CPU or something aren't compatible with this router or something considering that sysrq bypasses everything and just reboots. I've also tried configuring auto-reboot on kernel panic and then generate a kernel panic but again, it never rebooted by itself.

Less important but still useful: wireless LEDs aren't working.

I'm curious, has anyone ever tried all the buttons as well to see if they work ?

641 (edited by TeutonJon78 2016-07-18 07:59:37)

Re: Support for TP-Link Archer C2600

RedVortex wrote:

It's a bit larger than mine actually, I'm not too sure why... but still, it should include all the latest patches that fix the wireless issues.

...

If you want my build, let me know, I can make it available as well. Mine is the very basic image + Luci (not ssl), I really do wonder why LEDE's build is larger, especially considering it doesn't include Luci...

If you custom selected the packages, the size difference would be from the included firmware. Since DEVICE_PACKAGES currently isn't working, any IPQ806x build gets the firmwares for all 3 of the QCA9xxx modems. It bumped the size up a bit when they did that change.

You can check your /etc/firmware directory to see which firmware were included on your build. Supposedly when they get the new Image Builder code fixed, it can go back to just the correct version of firmware.

They were also talking about turning Luci on in the default builds as well, since there hasn't been a release yet.

Archer C2600 (v1.0, LEDE 17.01.2 over 1.1.8 stock base) -- Dev Files / LEDE Trunk Known Issues

Re: Support for TP-Link Archer C2600

RedVortex wrote:

I do not know why dropbear doesn't also support DSA (DSS) by default but like I said, you are better off with RSA than DSA in my opinion...

I have read and really would have been better to choose the DSA algorithm instead of  RSA. I think I will change my keys ...

Re: Support for TP-Link Archer C2600

Waiting several months
Installed after latest patches from bendavid :-)

Works!

BusyBox v1.24.2 () built-in shell (ash)

     _________
    /        /\      _    ___ ___  ___
   /  LE    /  \    | |  | __|   \| __|
  /    DE  /    \   | |__| _|| |) | _|
/________/  LE  \  |____|___|___/|___|                      lede-project.org
\        \   DE /
  \    LE  \    /  -----------------------------------------------------------
   \  DE    \  /    Reboot (HEAD, r1011)
    \________\/    -----------------------------------------------------------

Re: Support for TP-Link Archer C2600

The last few changes from me are just performance optimizations (compilers flags).  The thing that really makes the difference is the last ath10k patch.

Re: Support for TP-Link Archer C2600

bendavid wrote:

The last few changes from me are just performance optimizations (compilers flags).  The thing that really makes the difference is the last ath10k patch.

Works flawlessly, proper MAC adressess, 30dBm on US, WDS not disconnecting

warnings in logs:
Tue Jul 19 08:42:12 2016 kern.warn kernel: [50181.224268] ath10k_pci 0001:01:00.0: Unknown eventid: 36903
Tue Jul 19 08:43:40 2016 kern.warn kernel: [50269.246642] ath10k_pci 0001:01:00.0: Unknown eventid: 36903

and new kernel errors:

Tue Jul 19 08:40:19 2016 kern.err kernel: [50068.518547] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50068.558356] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50068.661133] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50068.689694] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50068.995481] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50068.997816] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50069.010469] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50069.011350] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50069.062152] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
Tue Jul 19 08:40:19 2016 kern.err kernel: [50069.063701] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080

646 (edited by TeutonJon78 2016-07-19 08:55:12)

Re: Support for TP-Link Archer C2600

matheos wrote:

Tue Jul 19 08:43:40 2016 kern.warn kernel: [50269.246642] ath10k_pci 0001:01:00.0: Unknown eventid: 36903
...
Tue Jul 19 08:40:19 2016 kern.err kernel: [50068.518547] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080

Those warnings were there before as well (the unexpected irq). There were some unknown event id's before as well, not sure if the same.

Archer C2600 (v1.0, LEDE 17.01.2 over 1.1.8 stock base) -- Dev Files / LEDE Trunk Known Issues

Re: Support for TP-Link Archer C2600

The spi unexpected irq messages have been there since the update to 4.4-series kernels.

Re: Support for TP-Link Archer C2600

Glad to see that things are moving forward smile

649 (edited by TeutonJon78 2017-04-20 04:36:18)

Re: Support for TP-Link Archer C2600

Outstanding issues list with trunk: (updated 2016-11-08)

Diagnosed but not patched yet:

Fixed:

Archer C2600 (v1.0, LEDE 17.01.2 over 1.1.8 stock base) -- Dev Files / LEDE Trunk Known Issues

650 (edited by RedVortex 2016-07-19 18:29:47)

Re: Support for TP-Link Archer C2600

TeutonJon78 wrote:

So, is this the outstanding issues list then?

1) wireless LED doesn't work
2) some unexpected IRQ/events
3) reboot sometimes doesn't work (button? command line?)
4) sysupgrade with keeping settings doesn't work
5) all of the QCA firmware are included (won't be fixed until the DEVICE_PACKAGES is working correctly) -- no issue other than wasted space


I would say that #2 is now less frequent or almost non-existent with the latest firmware, not sure if others are seeing the same improvement regarding those ?
#3 is not intermittent. It never works, at least on my router which is a v1.1, not sure about v1.0
I totally forgot about #4 but yes, it is still an issue on my v1.1 router

I also saw a lot of hostap logs. Maybe it shouldn't be that verbose or maybe it is just my build ? Anyways, that's all I have continuously in my system logs, nothing else at first glance.

Tue Jul 19 13:08:37 2016 daemon.info hostapd: wlan1: STA 18:b4:30:23:e5:57 IEEE 802.11: authenticated
Tue Jul 19 13:08:37 2016 daemon.info hostapd: wlan1: STA 18:b4:30:23:e5:57 IEEE 802.11: associated (aid 2)
Tue Jul 19 13:08:37 2016 daemon.info hostapd: wlan1: STA 18:b4:30:23:e5:57 WPA: pairwise key handshake completed (RSN)
Tue Jul 19 13:11:47 2016 daemon.info hostapd: wlan1: STA ec:1a:59:e1:b8:05 WPA: group key handshake completed (RSN)
Tue Jul 19 13:11:47 2016 daemon.info hostapd: wlan0: STA b8:78:2e:26:db:55 WPA: group key handshake completed (RSN)
Tue Jul 19 13:11:55 2016 daemon.info hostapd: wlan1: STA 18:b4:30:23:e5:57 IEEE 802.11: deauthenticated due to local deauth request
Tue Jul 19 13:14:19 2016 daemon.info hostapd: wlan0: STA c0:63:94:5a:d0:a7 IEEE 802.11: authenticated
Tue Jul 19 13:14:19 2016 daemon.info hostapd: wlan0: STA c0:63:94:5a:d0:a7 IEEE 802.11: associated (aid 2)
Tue Jul 19 13:14:19 2016 daemon.info hostapd: wlan0: STA c0:63:94:5a:d0:a7 WPA: pairwise key handshake completed (RSN)

I haven't got any messages in the kernel log after the following below, even after a few days...

[   21.030183] IPv6: ADDRCONF(NETDEV_CHANGE): wlan1: link becomes ready
[   21.030279] br-lan: port 2(wlan1) entered forwarding state
[   21.035704] br-lan: port 2(wlan1) entered forwarding state
[   22.632017] br-lan: port 3(wlan0) entered forwarding state
[   23.032004] br-lan: port 2(wlan1) entered forwarding state
[ 3416.613623] spi_qup_qup_irq: 46 callbacks suppressed
[ 3416.613657] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
[ 3416.618417] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
[ 3416.658700] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
[ 3416.837837] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
[ 3416.838632] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080
[ 3416.857288] spi_qup 1a280000.spi: unexpected irq 00000000 00000000 00000080

Besides the heavy logging for hostap, I would say that your list is pretty much it. I haven't encountered and can't think of anything else on my side.