Archer C* - get an WAN IP after power loss


as i know its a old problem without a solution?

Im on a archer c7 behind a cablemodem (Cisco EPC3212) at a german carrier.

My archer reboots every week via cron - thats OK.

4 weeks ago i have to check something and for that i have to take my archer c7 off (power off, other location)....dosent care for what. After my trys i put my archer back on the cablemodem and boot it. Nothing, at no time. Whatever i try it dosent work. 2 afterrnoons gone. Try to boot modem first, than archer...then put the cable in and all of the stuff you can find. NOTHING helps. The system did not get an WAN-IP from my modem

Last solution: Flash back to stock-firmware (good idea to have one on my NAS). After this, immediate, i get my WAN IP and everything is fine. Flashing back to LEDE, Reboots are OK. Did not lose it if i dont take my router from power source.

It scares my because its irritating and i dont like to flash stock and LEDE if i loose power for whatever reason.


Throughout the years that I've owned C7v2, we've had a few storms in the area, as well as a few planned power shutdowns for maintenance.

Anyways, there were probably 4 or 5 unplanned power shutdowns altogether and once my Archer C7 was reset back to defaults after the sudden power loss. I believe I was running a custom image on it at the time, but I can't recall if it was reset to custom settings or the OpenWrt defaults.

I do remember that I didn't have to go back to stock to recover the router.

For me, each time I reboot my Archer C7 or on power outage, I have to unplug the Wan cable, wait a little, then plug it back in, otherwise it cannot get an IP from the cable modem (Videotron in Canada).

But I never had to change the firmware to get it back on tracks. Could your problem be linked to MAC address cloning?

There is nothing what looks like help in my trys. Reset to default, flash an older version. Trust me, i try all the stuff i can found via handy or direct connected Laptop/Computer. All of the get an IP immediate after pluging the cable in. The archer dosent care ;). Only the default-stock image bring him back to his job as a router :smiley:

The modem only gives out 1 IP. After that, you have to reboot the modem. If you, for example, connected your Laptop, then your laptop is registered and if you afterwards plug in the router it doesn't get an ip adress. So beware of that. Also, next time this happens, try manually setting a mac adress for the wan port.


as i sad. I try a tons of things to get an ip.

try manually setting a mac adress for the wan port.
They issent hard coded?

I'm not sure to understand you well, but if you are asking if the MAC address of the WAN port is hard-coded, then yes it is usually in the ART section of the flash.

However you can use the functionality of "MAC Address Cloning - option macaddr" which will provide the MAC address you specify as WAN instead of the one hard-coded in the ART section. You can also change this from Luci:


i guess its the time where is is difficult to me to write the right word and understand some things.

try manually setting a mac adress for the wan port.

Im not sure why i should do that because there is a mac address and they should be active.


I have an Archer C7 v2. A while back, when I was still using OpenWrt 15.05, I had wifi issues which frequently forced me to poweroff the router the hard way, i.e. pull the plug or simply press the power button on the device without halting the system first. In all those instances where I did that, I never had an issue with the device coming up again an receiving a WAN IP from my cable gateway (which was a Cisco EPG3208G back then). So, the issue that is being described here, seems rather odd to me. I wouldn't say there's a general issue with that on the Archer C7.

I've tested dozens of cascaded scenarios and the LEDE 17.01 builds (RC1/RC2 and Final) for the C7 have all worked perfectly in terms of the WAN obtaining an IP via DHCP from an upstream ISP router, or via PPPoE with a DSL bridge modem.
Power cycling always manages to get an IP if the upstream DHCP server is listening and has slots available.

I think what JamesT42 mentioned is correct, you need to reboot the cable modem first, then connect the C7.

I DO THAT 10 TIMES OR MORE....just once again

What your syslog is saying about this? There should be something there, right?

I dont have it anymore. If i have the time to reproduce this i will gather a log.
The problem at this time was that im on duty and i dont have the time for a long testing period and gathering all the stuff.

Im not so professional, but i did not see anything where to know whats happend. As i remember the WAN port did not go reason. Another problem is - i have no internet, so if i get a log....another user ask about any other log :D. Or is there a command to get all relevant logs at once? Im not a complete noob, working as a admin but not for networking stuff. So i did not know a lot of that.


It seems I'm encountering this issue as well, and I suspect it's something that has to do with the upstream fibre "modem". Every time the router is rebooted, I have to power cycle the modem as well.


Note: "Modem" is probably not the right word but anyway...

I just test it today with the latest dev-build. It works now for me.
I have a new router (Synology RT2600ac) and now i have the time to test around with that issue. But it never happend today.

Just want to make sure, it didn't work for you on 17.01 but it works now on the latest dev-build?


Im not sure which version i had in Januar. Now, with the latest version, it works - thats right.

1 Like