Archer C7 V2 Has No Internet as Main Router


I installed 17.01.4 and r00t's community build on an Archer C7 V2 (Canadian ver), everything else appears to work, except the internet.

The Archer does have internet as a dumb AP behind another main router.

However, if this same Archer is used as the main router, then I don't get any internet.

WiFi, luci, LAN, SSH all work, but no internet even via Ethernet.

WAN protocol is set to be "DHCP client", as it's only behind a cable modem ( But it cannot obtain an IP from the ISP.

Using nearly identical settings, an RT-N66U has internet with no problem. The only difference I can notice is that RT-N66U and this Archer have different names for interfaces. In RT-N66U the WAN is on "Ethernet adapter (eth0)", whereas on Archer the WAN is on "Ethernet switch (eth0)".

Here's config of the Archer:

cat /etc/config/network

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr ''
option netmask ''

config globals 'globals'
option ula_prefix 'fd8e:ef75:3706::/48'

config interface 'lan'
option type 'bridge'
option ifname 'eth1'
option proto 'static'
option netmask ''
option ip6assign '60'
option ipaddr ''

config interface 'wan'
option proto 'dhcp'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option ifname 'eth0'

config interface 'wan6'
option proto 'dhcpv6'
option reqaddress 'try'
option reqprefix 'auto'
option _orig_ifname 'eth0'
option _orig_bridge 'false'
option ifname 'eth0'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '2 3 4 5 0'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '1 6'

Edit: the following picture is wrong, as @mk24 has pointed out, I took the snapshot after I physically disconnected the WAN. Please see the correct one in 2nd reply.

Please help. Thanks!

In the last image I see "no link" on the WAN port, as if the cable modem is not connected, or plugged into the wrong port.

For some models the switch ports are mixed up vs. the labels on the hardware, and you need to do a little exploring.

Silly me, I took the screenshot after I physically disconnected WAN, please see this one:

The whole "no internet" thing still happens when WAN is physically connected to the cable modem.

As you pointed out, the interface label might be mixed up, and in @r00t's community build, I saw more interfaces than LEDE vanilla build. I had tried eth0 and eth1 for WAN, neither worked though.

The wan and lan interface are in the same ip range ( Are you sure that the cable modem has the IP

1 Like

Also, sometimes to get an IP it requires a cable-modem full reset because the WAN MAC from your previous device is associated and won't renew IPs to other MACs.

You could rule that out by cloning the WAN MAC from your working router to your LEDE router and see if you can get an IP after that.

Check if disconnecting the WAN ethernet and then reconnecting it after a few seconds helps.

In my case it does.

In my case, I can blame several things:

  1. Stupidity on the part of the Arris cable modem for strictly listening to the first MAC address received.
  2. The source MAC address of OpenWRT's failsafe packet on the WAN port does not match the WAN port's final MAC after failsafe wait, and boot completes.

The source MAC on the failsafe packet is the LAN switch's MAC.

So, my fix (after hours of debugging) was to manually override the WAN's MAC to match the LAN MAC.
Which mean the LAN MAC needs changing to something else as well.