Archer A7v5 firmware needs to be named C7v5

As ridiculous as it sounds, after 7 hours of non-stop hacking, I noticed that the request for firmware from the TFTP server was for a file 'ArcherC7v5_tp_recovery.bin' and not 'ArcherA7v5_tp_recovery.bin'
For the record, I was trying to flash back to factory/TP firmware from a DD-WRT install. DD-WRT does not have OpenConnect available, which I require to connect to my employer's VPN. Once I saw this, I just tried the OpenWRT firmware.
Process that finally worked:
Server OS: Debian
Server software: atftpd (move init.d script to prevent running from init.d)
USE A MACHINE WITH AN ACTUAL RJ-45 port. usb->ethernet is wonky.
server IP netmask
Oh, use ifconfig:
sudo ifconfig (get wired NIC name)
sudo ifconfig netmask
I also set NetworkManager to the same IP before disabling (just switch it off in software, both wired and wireless if you have both) for good measure
atftpd command string: atftpd --verbose 6 --logfile /var/log/syslog --daemon /tftpboot
Place an Openwrt Archer A7v5 firmware renamed to 'ArcherC7v5_tp_recovery.bin' in /tftpboot
Push in reset pinhole, hold, turn off power, wait a second or two, turn back on power continuing to hold the reset pin for a few more seconds. Syslog (#tail -f /var/log/syslog) should pretty soon show a send message or somesuch to Just chill out for a minute or three. You will know it took when all of the lights across the router light up at the same time.
If you are using Windows, use the same IP settings (ncpa.cpl -> disable IPv6 and set IPv4 as above) older tfptd32 from the authors site in France. The bitbucket version shows up as malware in both Firefox and Chrome.
When all is said and done, revert your network settings and you should have a functioning OpenWRT router at

That should be a known fact.

That is fine, but all of the documentation talks about renaming the OpenWRT .bin to ArcherA7v5 for an Archer A7v5 router (in this case an AC1750)

omg.. where was that file/link at 1:00 PM today? That would have saved me at least 5 hours. Sheesh.

If you want to that network manger does not interfere use nmcli dev set <device> managed no. You Want to prevent NM to fiddle with the device in the middle of operation. When you are done Reenable with yes.

Thanks much _bernd. Much appreciated.

Which documentation exactly are you talking about?
Just asking, because the Archer A7 v5 devicepage describes the TFTP installation process including the renaming to C7v5.

BTW: If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

Hi, does the Archer A7 support mesh?