Alfa AWUS036ACM (mt7612u) stops working under heavy load in RPi 4

I have OpenWrt 22.03.5 fresh install in Raspberry Pi 4 (4Gb). Alfa AWUS036ACM stops working when I load WIFI heavily with iperf3. Usually it takes few minutes when problem starts. Speed should be something over 400 Mbits/sec. At lower speeds its more stable. Unplugging Alfa doesn't help to re-establish wifi. I have to reboot OpenWrt. In my normal use it usually works a day or two. Needs few reboots in week. When this problem starts, OpenWrt works normally. Only that Alfa wifi doesn't work. I can use LAN and RPi's own wifi without problems.

Log says: kern.err kernel: [ 304.423350] mt76x2u 2-1:1.0: error: mt76x02u_mcu_wait_resp failed with -110

cat /sys/module/mt76_usb/parameters/disable_usb_sg


Any suggestions? Do I have faulty device or what's going on?

With constellations like this, I wouldn't rule out power delivery issues (from the RPi4 host USB bus) or overheating of the WLAN card (tiny plastic case, poor ventilation, 802.11ac/ax chipsets typically running hot) either, without actual hardware problems. While the RPi4 can be a very capable wired-only router, it (and USB WLAN in general) simply isn't suited for 24/7 WLAN operations in AP mode.

Obviously you might also experience driver/ firmware issues, something typically not validated by the vendor- and driver developers for USB WLAN chipsets (as no one sensible would use them in that capacity).

1 Like

Thanks for your reply. I forgot to mention, I tried powered usb hub (Anker A7515) before with same results, because I was suspecting some power issue.

I find pretty similar issue (but for me reinserting Alfa doesn't help. Only rebooting OpenWrt works):

I tried vcgencmd get_throttled after Alfa stopped working and it shows throttled=0x0.
According to that discussion: "0x0 from get_throttled means your Pi has not throttled since last boot, so consequently indicates your power is fine."

Maybe that can be overheating issue. That's weird because this device is considered reliable.

Some info from lsusb:

root@OpenWrt:~# lsusb -v | grep -e 'MaxPower' -e 'Bus [0-9]'
Bus 002 Device 003: ID 2357:0601 TP-LINK USB 10/100/1000 LAN
MaxPower 256mA
MaxPower 256mA
Bus 001 Device 002: ID 2109:3431 USB2.0 Hub
MaxPower 100mA
Bus 001 Device 001: ID 1d6b:0002 Linux 5.10.176 xhci-hcd xHCI Host Controller
MaxPower 0mA
Bus 002 Device 002: ID 0e8d:7612 MediaTek Inc. Wireless
MaxPower 400mA
Bus 002 Device 001: ID 1d6b:0003 Linux 5.10.176 xhci-hcd xHCI Host Controller
MaxPower 0mA


I tried to decrease maximum transmit power from maximum 20 dBm (100 mW) in steps of 1 dBm to 15 dBm (31 mW). iperf3 speed dropped to 0 after few minutes. Then I tried to decrease power to 0 dBm (1 mW). Same results. Only difference was WIFI didn't work at my balcony (about 10 m and concrete wall between) anymore. At 15 dBm it was working at balcony.

Usually time what it takes to drop speed to 0 is something between 2 and 10 minutes. Sometimes it takes little bit longer.

Alfa is now working as AP. I dropped operating frequency width from 80 MHz to 40 MHz. This workaround costs speed, but at least it's stable. For normal use it's okay, because my internet speed is only 100 MB/s. I didn't make load tests with iperf3, but I will, when I have time. Uptime for OpenWRT at now is over 16 days. No problems with WIFI.

Thank you @Alfamale for testing and reporting about Alfa AWUS036ACM. Same as you I want to try to use my Raspberry Pi 4 as a router and Alfa AWUS036ACM seems like one of the best USB wifi adapters I can get.

Are you still happy with it? Or would you get something else for Rpi4?

Thank you.

@Alfamale - Did you get this working?

I have the same setup - except - The Alpha Card AWUS036AXM just doesn't come online when it boots. I have to log in to the Web Ui, go to wireless and click "Restart" next to the Wifi Card in the list... Then everything works fine. Any thoughts?

I do not own Alfa AWUS036AXM, but I do own some other MT7612U and found similar problem on RPi 4B.

You can check out my tests here:

So apparently the RPi 4B USB driver in kernel 5.15 LTS has random issue with USB devices, I checked with Raspberry Pi forum and confirmed that users with RPi OS kernel 5.15.x have issues with some USB SATA converter, and/or WiFi, etc....OpenWrt 23.05.x is exactly using this 5.15 LTS

Then I tried using Snapshot (kernel 6.1) OpenWrt and that issue seems to be vanished.

Thanks - I will add this dongle to the list.
I read a couple forum posts that talk about a sctript called
This package is designed to stop devices from being registered as a different device. Theory being that a modem or dongle shows up to the OS as CD-Rom or somethin (not sure how to check if that is happening to me). This script somehow tells the OS that it is what it is - so to speak

This is "multi-state" device that requires USB modeswitch to make it working, the usual one is "single-state" which doesn't need it.

But I think you still need to configure it to allow OS to recognize the device.

My 2 x COMFAST MT7612U still haven't tested yet (both are multi-state), however they are good once being switched to proper state.

1 Like

Oh just tested with my Pi 4B (I have 2), with multiple MT7612U (I tested 2 already)
Both exhibiting similar crashes when I was trying to do speedtest.

Both MT7612U USB WiFi work perfectly on either old Raspberry Pi 3B, or NanoPi R4S (on my R4S + COMFAST WU-782ACv2 I can reach ~540Mbps with test!), so it looks like really the problem of RPi 4B

Do you know how to setup usb modeswitch for this device... The general guide is a little confusing, and I don't know where to find the details that are needed to edit the Json file. Thanks

I didn't even need to edit a single config, I installed the package + driver module for the dongle, then plug & play!

Finally I had some breakthroughs on using RPi 4B with my USB3 MT7612U WiFi, I created another post for sharing/discussion: