Adding support to Comfast CF-EW75

@reydeyes I just found on YouTube the video below where it looks like someone installed YunCore A782 OpenWrt firmware on a Comfast CF-EW75:

The video is in some language I cannot understand, but it is possible to see this image from the video:

While I do not own this device (yet), if you manage to understand the video instructions and if you are brave enough you can give it a try (at your own risk, of course!). Please notice that the video may be using some custom OpenWrt build, so it is really important to first have someone transcribing the instructions to English.

If you are successful please share your steps to install the firmware and testing results. If everything is OK, we can ask devs (@pepe2k) to update the YunCore A782 builds to add Comfast CF-EW75 as a supported device.

1 Like

boss pwd kahit stock firmware ng cf-ew75 lang kc na flash ko un openwrt d rin nag work\

1 Like

Hi actually, that was me in that video. I'm a filipino and i can guide you how i did it. I just used the recovery boot of the device to install the openwrt firmware. I hope you will add support for this device soon.

1 Like

What i did here is that, i just compare all the the specs and the memory of the said devices. There is a catalog of comfast devices i found in the internet.

And the said openwrt firmware i just look at the memory and the cpu of the device and they are in match that is why it works. But the configuration and optimization of this firmware is not yet achieved. And also the leds are not working.

I hope soon the devs will make a firmware for CF EW-75. :pray::relaxed:

1 Like

According to the document you shared above, CF-EW75 has the following chipsets:

  • RAM: 128MB (the above catalog seems to have the wrong spec)
  • FLASH: 16MB
  • QCA9563: Wifi 2.4Ghz 2x2
  • QCA9866: Wifi 5Ghz 2x3
  • AR8033- Gigabit Ethernet (wrong - at least in my device it is a MotorComm YT8531SC - see internal pictures in the post below).

So, looking at these specs, CF-EW75 seems to be closer to YunCore XD4200:;a=commit;h=e5d4c0966736287c7ade29c5ccaf6f1ad841b7db

1 Like

So, this is possible for the dev to make CF-EW75 its OpenWRT firmware. I have the device here. to make it a test subject. So tell us what the devs need so that we can make this happen. @pepe2k

I already backup the original firmware of this device for its recovery.

Pictures confirming the chipsets and the bootlog from UART are helpful.

I just purchased one of this, when I have tiime I will take it apart and share pictures.

By the way, how did you backup the original firmware? Can you share it please?

1 Like

I will document it maybe tomorrow I will spare some time doing videos and logging.
and for the original firmware, I will also add how to back it up.

1 Like

Below are the internal photos. Confirmed chipsets:

  • QCA9563-AL3A: SoC + WLAN 2.4 Ghz 2x2
  • QCA9886: WLAN 5Ghz 2x2
  • Nanya NT5TU64M16HG-AC: 128MB DRAM DDR2
  • Macronix 25L12833F: 16Mb Flash (on the backside of the PCB)
  • MotorComm YT8531SC: Gigabit Ethernet

1 Like

And here are the partitions from the factory firmware:

[    0.344661] 4 ofpart partitions found on MTD device spi0.0
[    0.350338] Creating 4 MTD partitions on "spi0.0":
[    0.355285] 0x000000000000-0x000000040000 : "u-boot"
[    0.361792] 0x000000040000-0x000000050000 : "u-boot-env"
[    0.368758] 0x000000050000-0x000000ff0000 : "firmware"
[    0.417957] 2 uimage-fw partitions found on MTD device firmware
[    0.424082] 0x000000050000-0x0000001a0000 : "kernel"
[    0.430409] 0x0000001a0000-0x000000ff0000 : "rootfs"
[    0.437015] mtd: device 4 (rootfs) set to be root filesystem
[    0.442947] 1 squashfs-split partitions found on MTD device rootfs
[    0.449384] 0x000000820000-0x000000ff0000 : "rootfs_data"
[    0.456468] 0x000000ff0000-0x000001000000 : "art"

Below is the full boot log. The initial part is corrupted, so u-boot log is not fully readable. It looks like UART is correctly initialized only after ttry console is enabled.

Also after boot is complete, it requires a login and password to access console via UART. I tried the default ones (used in the web interface) and it did not work. If anyone knows how the used/password Comfast uses in their UART console please share here.

1 Like

Be aware that support for this PHY has just now being submitted for upstream review this month and is not present in any released linux version (including net-next), yet.


I noticed that there are two versions of this device so maybe this is the difference

1 Like

In case of failed attempts or bricked device, here is the device's stock firmware.

Steps on how to upload the firmware:

  1. You need to set the static IP address on your PC which is "" - this specific IP is for the recovery to be detected by the device. make sure you connect the LAN to your PC. and prepare your CMD to ping the "" so that you will notice the response when the web recovery is ready to access.
    NOTE: Sometimes you need to switch browsers to access it. chrome is very picky when it comes to accessing IP.

  2. You need to press the reset button and insert the POE to power the device and wait for 3-4 blinks to halt the device for recovery. And then you'll notice that it will flash a bit and then you can now try to access the web to be sure.

  3. You will now be able to upload the firmware that you want.

The password of the stock firmware is


1 Like

@dsouza Here is the video on how to get the password of the device. just follow the video. this is where I get the root password of the device when I try to install the OpenWRT.

1 Like

@dsouza I just remember the password for the admin it is "pogs1233" after you upload the firmware you can try that password. also, the root password would be also "openwrt" I think I had already set the password of this firmware you can try it out I hope it helps.

I cannot get my ew75 now because I already deployed my AP to my business. i will wait for the OpenWRT firmware to be released and try it out.

1 Like

is that the password for ssh? or it is just for http

I tried to install YunCore A782 on my CF-EW75, but it did not boot. I believe this might be due to the fact that mine is CF-EW75v2.

Since I had managed to backup stock firmware via SSH , I quickly restored it back to factory firmware using the firmware recovery mode (power on with reset button pressed).

But factory firmware is really bad (it is based on LEDE 17). At least I was not able to maintain a stable connection of a MacBook Air M1 with the 5Ghz radio. So basically I just threw away my money with this device.

For now I will keep it and hopefully it will get OpenWrt support sometime in the future.

1 Like

yes this devices are really bad, i have 3 devices and one is ath9k, and that is the worst device ath9k i have.
just bad devices

1 Like

BTW, if anyone wants to change the SSH password, the following procedure (from this post) works with this device:

The stock firmware has an SSH daemon but the root password is not known, and does not match the web GUI's password. However, the following procedure allows setting it to a known one and gaining SSH access to the device.

  1. Using the stock web GUI, under System β†’ Tools β†’ Export Settings, download a backup of the configuration to your computer

  2. The generated file, called bakup.file [sic], is actually a tar.gz file containing the etc folder and some configuration files

  3. Extract the backup and edit the etc/shadow file

  4. Replace the first line of etc/shadow by root:$1$pjKB26GF$T9mfHI/C6JGX9rQ8CYDPl/:18270:0:99999:7::: to set root password to β€œopenwrt”

  5. Repack the modified etc directory as a tar.gz. file, and rename it to bakup.file

  6. Using the stock web GUI, use System β†’ Tools β†’ Import Settings to upload the modified backup

  7. The device will reboot and the password will be openwrt

Http. The ssh password is "openwrt"