Adding OpenWrt support for Xiaomi "Redmi Router AX6S"/"Xiaomi Router AX3200"

Hi, i'm stuck on the "Enable netmode 4" step, i use the by jmceleney but it only says netmode is 2:

python -p **** -H
Serial Number: ****
netmode is 2. Attempting to set netmode to 4
b'\x10\x01\x06u\x00\... ...x00\x00\x00\x00\x00{"hidden_2g":"0","hidden_5g":"0","disabled_2g":"0","disabled_5g":"0","ax_2g":"1","ax_5g":"1","txpwr_2g":"max","txpwr_5g":"max","ch_2g":"0","ch_5g":"0","bw_2g":"0","bw_5g":"0","txbf_2g":"3","txbf_5g":"3","support160":"0","web_passwd":"a4dbbdd4ba9fec76a975b933c9bcc65239d0dcda","mesh_version":"2","cap_mode":"ap","cap_ip":"","vendorinfo":"miwifi-RB01-1.0.83-100","timezone":" \' ; mtd erase crash ; ","lang":"**","CountryCode":"**","server_S":"","server_APP":"","server_API":"","server_STUN":"","server_BROKER":""}\x00'
Waiting to check result
Netmode is 2
telnet password: ****

i'm doing something wrong?

PD: with says:


whit this setup if i try to open a telnet terminal it says "Network error: Connection refused"

FINAL PD: I install 1.0.71 firmware with this tutorial

Xiaomi Mi Router 4A Gigabit Edition (R4AG/R4A Gigabit) -- fully supported and flashable with OpenWRTInvasion - #747 by Zorro

Then i was able to set netmode 4 with by jmceleney, but telnet still not working for me on windows, so i tried using linux and it work.

I wrote the "commands to prepare device for OpenWrt flashing" and all work but the part of the http.server with python don't work for me because i have a vpn on linux and it set the server to and idk how disable it LOL, so i tried to follow the steps of this video

I retry to use windows telnet and it work(idk if this make sense but i think this can be result of the "commands to prepare device for OpenWrt flashing"), so i was able to put the factory.bin directly in AX3200 with the WinSCP interface, i enter in tmp folder with cd /tmp on PuTTY telnet and flash the factory.bin, after this my telnet on windows stop working again so i wrote

nvram set flag_ota_reboot=1
nvram commit

on the telnet terminal on linux

and all work :))))) now i have openwrt on my AX3200