Adding OpenWrt support for ARUBA AP-315

hello,
I purchased this ARUBA APIN0315 MODEL JW797A

I also purchased Console cable for this Aruba

Can we install openwrt on this?

Following is what I can do with this Aruba

  • I can open it
  • I can solder wires on the mainboard
  • I can remove IC from it and put them back if needed

Thankyou so much
Looking forward for positive outcome.

According to various Wiki this is
CPU: Qualcomm IPQ8064
Flash: 128MB
RAM: 128MB
BT: TI CC2540

Looking at the Internal Photos provided with FCC documents I assume that the 2x10 pads on the side of the board are ARM JTAG pins and I would suspect a serial console at the 4-pin header or the 5 pads near it.

Maybe folks more familiar with IPQ806x can help you out with the details, I haven't worked with that platform myself. @Ansuel maybe?

The circle on the left... Looks like a serial header si already soldered and present on the other side
From top to bottom probably classic GND 3.3 tx Rx
Would be worth to test voltage level and gnd connection

hi thanks for replying,
The Aruba AP I bought didnt come with external AC/DC power supply bar/adapter.
I guess I need that to perform the testing you asked to do?
BR

A standard power source will make your porting considerably easier, in most cases these are rather standardized PSUs, so you might already find one in your E-Waste pile (PoE devices might require 48/ 54 VDC, which is less common - more expensive. but if yours is bog standard 12V/ 3-5A, it would be easy).

for the gnd test you don't need power but if it does have a power plug then it's for sure 12v 2A

i did measurements with correct DC power 12v 1.5A supply while the Aruba was blinking green light.

@Ansuel @daniel

what about the populated 4-pin header on the other side, located just left of the 5 points you were measuring now when looking at the picture.


Here

very nice, so i'd start with that one. connect GND to GND of your 3.3V TTL serial adapter and then you have 3 options where to connect the RX of the serial adapter to, ie. where you expect TX of the board.
I'd try all 3 options starting with the one next to the GND pin.
Each time connect the board, then power on and setup serial console with 115200 baud, 8N1.
Most likely you will be able to see Linux booting on one of those pins, which then leaves you with only two options to find the RX of the board by connecting it to the TX of the serial adapter.

Never seen this Aruba cable -- USB A to microUSB, but a tag saying it's a 3.3V TTL Serial Cable (which would be what we need, yes!) Is there a microUSB socket anywhere on this device?

The PL2303 adapter in the other picture looks like it is 5V level, so you can not use it. You need 3.3V level adapter or something where you can set the voltage level with a switch or jumper. If you are not sure, use your multimeter to measure the VCC level of your adapter -- even though we will not connect the VCC, it gives you a good hint about the what the signal level will be.

1 Like

Any of them will do as long as they are 3.3V.

The important thing here is not the voltage on the red wire -- you are not going to connect that! Actually you will fry the board if you do so, so really don't!
Rather, what matters is the signal level of RX and TX. And that usually matches the voltage of a VCC which comes along with RX, TX and GND, as in that way it can be used as a reference voltage e.g. for MAX232 level shifter.

i measured ground and Rx and the voltage is 0.65V and then ground and Tx is also 0.65V on multimeter.

I am trying to understand this

" Most likely you will be able to see Linux booting on one of those pins, "

where will I see? in Putty?

Exactly, in puTTY or any other serial terminal of your choice.

connecting the RX of the adapter to the board won't harm and is worth a try. connecting the TX of the adapter can fry the SoC if the voltage level is too high. A multimeter is too slow and hence not good enough to measure this, you need oscilloscope to be sure -- with that it's easy to see the if there are any peaks above 3.3V on the TX while sending data.

this is what I did,

installed TTL drivers in computer and made sure it showed up in device manager

Started putty and selected 'serial' and entered com5 for ttl and then entered 115200 and then i clicked Open

connected black wire of ttl to groud of aruba

connected white RX wire to aruba pin next to ground

turned on aruba AP

Aruba keeps blinking green light and nothing on the Putty. :frowning:

i tried all remaining 3 pins after ground and powered ON aruba but same. Nothing on putty and aruba keeps blinking green led right away as soon as I power it on.

looks like its in INSTANT ON mode

:frowning:

So it's highly likely your serial adapter is 5V level and hence doesn't detect the 3.3V level signals sent by the SoC. Please try with an adapter which has 3.3V signal level.

The WitMotion looks a bit too crappy, 3.3-5V but no switch to actually select the signal level, however this is going to work...
The Robojax looks good.

i'm impressed by how much the market is filled with bloated ttl converter...

1 Like