Add support for TP-Link RE450 v3

Just got a v3 too, I'll simply try to flash 19.07.1 ...

Could you please let us know if it works, I'm having a V3 also after replacement

Still fighting with tftp, my macOS tftp doesn't log, so I don't know how to name the file!

Are you flashing from the OEM firmware from TP-Link ?. In that case you should not use tftp but upload the openwrt firmware directly via the web interface

It currently is in OEM mode, tried that first but got an error

When still running OEM, the RE450 does not support tftp, you have to get on it via the serial interface to start tftp


Bildschirmfoto 2020-02-17 um 14.55.20

Also own a V3, and would like to have an alternative firmware, Openwrt boots on this device?

any update news??????

I confirm that V3 cannot be flashed through the usual way on the web ui.
Not sure what other options do we have.

It works for me, but you need to rebuild it and change all 2.0.0 to 3.0.0 in tplink-safeloader.c. Then it'll flash all the way. YMMV.

1 Like

Great work @PiGat!
I'm keen on trying it asap. Would you please point me to building instructions in the docs?
Also what system have you used for building?

You can use the build instructions on the main site, I've used the osboxes debian distro also mentioned there. Keep in mind: building takes a long time, so don't just sit there waiting, it'll take more than an hour for the first build.

PiGat, would you have any file around that you could share with us?

Not anymore, sorry, I needed space and had to remove the OpenWRT VM. If you follow the guide on the main page it's not that hard to build it yourself. Although some Linux knowledge is useful (I'm a total noob with it but have tried it a couple of times).

But you actually tested it on this device?

Yes, of course, on v3.

@PiGat, I'm looking at this file, and don't see '2.0.0' anywhere. Do you recall what line numbers you changed?

Look better :smiley:

:frowning: my mistake, I was looking in the wrong repo. Thanks for the assist.