Add support for TP-LINK AX23 V1

Specify through tftpd, right?

where in the git commit do you see tftp ?

Oops, I'm sorry, I just didn't quite understand the second point about HTTP recovery. Thought it refers to tftp.

I have bought this router to use it with openwrt, the factory image has a Luci or i must install it after?

Snapshots don't come with the webUI preinstalled, but you can add it to the image yourself, by using the online image builder.

So factory image is a snapshot
I will give it a try.

I don’t quite understand what to do, after installing via http recovery, the router indicators do not light up at all, I waited about 5 minutes, it doesn’t go to, after turning off and on the router, the firmware remained the same, with all my parameters as before http recovery

Did you flash the file via the menu Advanced -> System Tools -> Backup & Restore? If so, try to flash via the menu Advanced -> System Tools -> Firmware Update. That is 100% working for me in 3/3 cases thus far. You can rename the openwrt-ramips-mt7621-tplink_archer-ax23-v1-squashfs-factory.bin to just factory.bin, as I did, but this model might not have issues with long filenames.

I tried your methods, but they were unsuccessful, renaming the file, shortening it down to one character. The only thing I did not rename to factory.bin, I'll try again at home. But with any other file name, it gives me an error: Invalid file type.
And through HTTP recovery, the router does not seem to accept the file, the file itself is loaded when it reaches 100%, it seems to be reset, but nothing is on on the router, although judging by the videos that I watched, the power icon should blink, nothing burns me. In addition, the gateway is not written in the properties, although in the video it changes from to
I used factory image.

new user of openwrt because of this firmware.
my hardware: Archer AX23 v1.2 - firmware 1.0.5 Build 20220216 Rel 59311(4555)
no problems flashing from stock with firmware flash tplink_archer-ax23-v1-squashfs-factory.bin
now openwrt says:
Model TP-Link Archer AX23 v1
OpenWrt SNAPSHOT r22782-218ce40cd7 / LuCI Master git-23.118.79121-6fb185f
installed openvpn module but did not configured it yet.

hope the firmware gets expanded to v1.2 (so the real version will display on the status page as well)

the firmware boots in cca 35seconds (very fast comparing to stock), working reliably - did not encounter any problems for now.
I shutdown the unit before I go to sleep, so I can not commend on the long uptime - works through the whole day otherwise - from 6am to 8pm.

What version are you flashing? Flash at least version 22.03.5.

22.03.4 will not flash on all devices.

Some instructions on how to enter the recovery menu: (see method 2).

Hello. I have a v1.20(RU) model with 1.0.5 Build 20220412 Rel. 63342(5255) stock firmware and having the same issues as FATALI does - "Invalid file type" while trying to flash via WebUI and just nothing from recovery mode (firmware loads to 100%, then some red line blinks for a fraction of second and then nothing happens, recovery mode page just resets). It tried 22.03.04, 22.03.05 and snapshot versions of factory image with the same result. Probably some additional checks were added in later stock firmware versions or additional entries needed in tplink-safeloader?

first of all thank you for making this possible!
I have:

Firmware Version: 1.0.5 Build 20220729 Rel. 38157(4555)
Hardware Version: Archer AX1800 v1.20

I have downloaded: openwrt-22.03.5-ramips-mt7621-tplink_archer-ax23-v1-squashfs-factory.bin

When I go to System -> Firmware Update -> Local update -> New Firmware file -> Update
and I browse to the downloaded file above and Press the Update button I also get the Invalid file type.

Note: I have also tried renaming the "long" file name to openwrt.bin for the sake of testing out the theory of possibly failing due to the long file name.

Is there anything I can do to get to the bottom of this error ?

1 Like

@celcion Although the commit adding support does not specify whether it was for a US or EU version, the dev adding support lives in Europe so there might be a region check on the firmware. TP-Link often implements EU/US/RU/CN firmware varieties. You would need to inspect the headers of the Russion and European version of the same release e.g. to see if there are any differences.

@Unworried3946 You might be looking at a simlilar issue.

It might not be a region issue, it might also just be a release version check somewhere. This kind of stuff is implemented in the TP-Link safeloader code, and I see there have been AX23 v1 related commits as well.

1 Like

@Borromini thank you for the answer! I compared the EU and RU images, sadly it's not the same version (TP-Link has different versions for the different regions, go figure), but I guess I spotted something that possibly is the problem: Support List of the RU version contains an additional line that doesn't exist in EU version
{product_name:Archer AX23,product_ver:1.20,special_id:52550000}

There's no such line in tplink-safeloader.c either. I haven't tried compiling OpenWRT from the sources, but I guess I can give it a go. Thanks for the tip!
I'll report the results later.

1 Like

Yes, that special_id value often differs between those region differentiated firmware images.

If adding yours means a successful flash for you, make sure to send in a patch to have the ID included.


OK, I went a somewhat simpler way by patching and recompiling only tplink-safeloader and repack the image with it: Port to TP-Link RE200 - #124 by 999cgm
And it worked! I flashed it through recovery mode, but I guess it would work with the normal WebUI too.

So the line is the same as I mentioned:
{product_name:Archer AX23,product_ver:1.20,special_id:52550000}

I found an instruction about sending patches, so I will try to do it somewhat later. But for now @FATALI @Unworried3946 - you can try to patch tplink-safeloader.c manually with this line and follow the instructions I mentioned to patch your images and check if it'll work for you.

@Borromini thank you very much!


@Borromini thank you for pointing us in the right direction
@celcion thank you for paving the way for testing this. it seems I have yet another variation


@celcion Can I please ask you to share your image for the firmware of the RU version by email