AdBlock: Cannot load blocking lists

Hi there,

I installed and configured adblock using luci. It seems as if adblock does not load the blocklists: adblock-4.1.3[5457]: download of 'yoyo' failed, url:, rule: /^([[:alnum:]_-]{1,63}\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}, categories: -, rc: 1, log: /usr/bin/wget: unrecognized option: no-cache Usage: /usr/bin/wget [options] <URL> Options:   -4                              Use IPv4 only   -6                              Use IPv6 only   -O <file>       Redirect output to file (use "-" for stdout)     -P <dir>                        Set directory for output files  --quiet | -q                    Turn off status messages        --continue | -c                 Continue a partially-downloaded file    --user=<user>                    HTTP authentication username    --password=<password>           HTTP authentication password    --user-agent | -U <str>         Set HTTP user agent     --post-data=STRING              use the POST method; send STRING as the data     --post-file=FILE                use the POST method; send FILE as the data      --spider | -s                   Spider mode - only check file existence         --timeout=N | -T N              Set connect/request timeout to N seconds --proxy=on | -Y on              En
Sat Jan 22 09:02:32 2022 adblock-4.1.3[5457]: blocklist with overall 0 blocked domains loaded successfully (AVM FRITZ!Box 4040, OpenWrt 21.02.1 r16325-88151b8303)

When I enter the domains to be blocked manually into the list, the blocking works for that entered url.

What am I doing wrong?


opkg update && opkg install curl && uci set'curl'
 && uci commit && /etc/init.d/adblock restart
1 Like

Outstanding. Thanks a lot!

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.