Accessing my bridged modem web interface through openwrt router

my setup is as follow, VDSL through a telephone line, rj11 goes into my tp link VR600, which is being used as a modem in bridge mode, the VR600 is connected through one of it's lan ports to the wan port of a TP-Link ER605 v2,, running openwrt, everything works great, I can access luci on 192.168.1.1, & I've a dlink 2888a router being used as a dumb ap connected to my openwrt router, I gave it the ip of 192.168.1.2 which also works great, I can access it's web interface from any device connected wirelessly or to the openwrt router, what I can't access is the VR600 web interface, how to set that up, here're my interfaces in openwrt


& devices

https://openwrt.org/docs/guide-user/network/wan/access.modem.through.nat

1 Like

Assuming your modem's IP address is 192.168.100.1 and it is connected to the router's WAN interface.

  1. On the General Settings tab specify:
  • IPv4 address: 192.168.100.2

  • IPv4 netmask: 255.255.255.0

I don't understand is my modem ip different from the ip on which the web interface is available? or why is the first one 100.1 & second one 100.2

Your WAN presumably has a public IP so there is no route to the private ip of the modem
The instructions @slh pointed to should take care of that.

But it only works if the modem will be on another subnet then 192.168.1.1/24.

It looks like the default address of the TP-Link ER605 v2 is 192.168.0.1 and unless it has been changed that should be good and you should be able to use 192.168.0.2 as IP-address for the WAN

the TP-link ER605 is my main router with openwrt on it, it's address is 192.168.1.1, the VR600 is the one in bridge mode and I set it to use the address 192.168.0.1, turned off dhcp on it, and put it in bridge mode, then did all the steps mentioned "luci instructions", & assigned 192.168.0.2 to the modem interface per instructions, but it's not working, I still can't reach the VR600 on 192.168.0.1, nor ping it, what am I doing wrong

My bad the VR600 should have 192.168.1.1 as default:

So on the ER605 you have to make an extra interface with IPv4 address 192.168.1.2 with mask 255.255.255.0

yes I changed the default to 192.168.0.1, since I've my openwrt one on 192.168.1.1, & set the 'modem' interface to 192.168.0.2 but it's not working still

just figured it out, it was the last section on the linked article, since I'm ppoe "If the WAN L2 device doesn't match L3 device like in case of PPPoE, change the modem interface.", changed to eth0 in my case

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.
Thanks! :slight_smile:

1 Like

thank you, done

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.