802.11r Fast Transition

Comrades, good day!
After configuring 802.11 r Fast Transition, the client cannot connect to the access point. Can you tell me what's wrong? How do I fix it?
I did everything as indicated here: https://www.reddit.com/r/openwrt/comments/515oea/finally_got_80211r_roaming_working/

my file /etc/config/wireless:

config wifi-device 'radio0'
	option type 'mac80211'
	option path 'platform/soc/fe300000.mmcnr/mmc_host/mmc1/mmc1:0001/mmc1:0001:1'
	option hwmode '11g'
	option channel 'auto'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option key '12345678'
	option ssid 'Open'
	option encryption 'psk2'
	option network 'IN'

	option auth_cache '1'
	option disassoc_low_ack '1'
	option rsn_preauth '1'

	option ieee80211r '1'
	option pmk_r1_push '1'
	option mobility_domain 'e612'
	option nasid 'DCA6324AECF9'
	option r1_key_holder 'DCA6324AECF9'
	list r0kh 'DC:A6:32:4A:EC:F9,DCA6324AECF9,8a7fcc966ed0691ff2809e1f38c16996'
	list r1kh 'DC:A6:32:4A:EC:F9,DC:A6:32:4A:EC:F9,8a7fcc966ed0691ff2809e1f38c16996'

the access point is available, but when you try to connect to it, it asks for a password and after just connecting freezes, no notifications, no errors, just hangs stupidly and that's it... without 802.11 r Fast Transition, everything worked. I'm wondering if this configuration can be applied to a single access point. Thanks.

Installed

wpad-basic 2020-06-08-5a8b3662-2

Checked, deleted all parameters, and left only the enabled function of 802.11 r Fast Transition, the client can not connect :frowning:

Which version of openwrt & client device do you use? Try factory reset & install from scratch.

Raspberry Pi 4 Model B Rev 1.1
OpenWrt SNAPSHOT r13693-014d3f593a / LuCI Master git-20.185.49956-051c828
re-installed with no success

I think the broadcom chipset doesn't support 802.11r with the 3rd firmware. But I'm not sure, need someone else to confirm this.

Works fine for me. Any reason why you are going for an advanced configuration with all the additional options? My interface section looks a LOT simpler:

config wifi-iface 'wifinet3'
	option ssid 'REDACTED'
	option device 'radio1'
	option isolate '1'
	option ieee80211r '1'
	option ft_over_ds '1'
	option key 'REDACTED'
	option network 'untrusted'
	option mode 'ap'
	option ft_psk_generate_local '1'
	option encryption 'psk2+ccmp'

Also, what OpenWRT version are you running?

Edit: That reddit topic is OLD. You no longer need to configure r0kh, r1kh, nasid, mobility domain, r1_key_holder, etc. They are now intelligently automatically generated by hashing the SSID. As long as you are using the same SSID on both APs on which you have that enabled, it should work out of the box with the simple configuration I am using.

I am using the OpenWrt SNAPSHOT version r13693-014d3f593a

tell me, please, Do you have it running on Raspberry Pi 4?

I just configured this function on Reddit on the GWF-3S03 chipset Ralink RT5370 network adapters, everything worked.

But as I wrote above, it's not about my settings, even if I should put the checkbox on 802.11 r Fast Transition, save and restart, I can't even connect to the WiFi network, I'm stupidly not allowed. Maybe I need additional drivers that the Raspberry Pi 4 uses

Tried Your version on the GWF-3S03 Ralink RT5370 chipset network adapters - works. Thanks a lot. I think that the problem is in the drivers or the chipset of the native network adapter Raspberry Pi 4.As I figure it out, I will write.

1 Like

Glad to hear it's working now!

Could you take a look at my config?

I've got the problem that some devices, like windows, connect to the wifi, but others don't (Android phones).

This is my config file:

config wifi-iface 'wifinet1'
        option device 'radio1'
        option ssid 'REDACTED'
        option key 'REDACTED'
        option mode 'ap'
        option network 'lan'
        option encryption 'sae-mixed'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'


config wifi-iface 'wifinet2'
        option device 'radio0'
        option ssid 'REDACTED'
        option key 'REDACTED'
        option mode 'ap'
        option network 'lan'
        option encryption 'sae-mixed'
        option ieee80211r '1'
        option ft_over_ds '1'
        option ft_psk_generate_local '1'                             

I'm running OpenWrt 19.07.3 r11063-85e04e9f46
LuCI openwrt-19.07 branch (git-20.178.63701-ce35d08)
hostapd-openssl 2019-08-08-ca8c2bd2-4
wpad-basic 2019-08-08-ca8c2bd2-4

I have the same configuration on a WRT1900ACS and a WRT1900AC

To my knowledge 802.11w (and possibly r) is broken on mwlwifi, and 802.11w is prerequisite for wpa3.

So i just turned 802.11w to required instead of optional and I don't have any issues to connect to a device. Don't know if it works tho.

sae-mixed doesn't work properly with all devices. I tried playing around with it as well, but eventually turned it off since I also had devices that were unable to connect.

can you tell me what device you use? Which network adapter is used?

The router I am using is a DIR-860l

thank you :slightly_smiling_face:

I observed a peculiar issue with fast roaming on an old ipad (probably first version), so this is client specific anecdote:

  • when all APs enable fast roaming, iPad cannot connect to any of them
  • when one of APs doesn't have fast roaming iPad can now connect to ANY AP, with fast roaming either enabled or disabled

This is specific to that single old iPad, so.. go figure

If u have problems with 802.11r and ap losing connection this helped:

https://bugs.openwrt.org/index.php?do=details&task_id=3159

2 Likes