6 ghz router openwrt

Being a search challenged duffess, is there a 6 ghz router with openwrt installed or easily installed?
Are wendor recommendations allowed?

Currently there is none.

Oh shucky darn, well leaves more money for other projects.

It can be made, but requires some work. In the end you can end up with a very good device, though.

For example:

AsiaRF AW7916-NPD WiFi 6e mPCIe module
Banana Pi BPI-R64 main board
BPI-64 Acryllic case with antenna holes drilled
8 x IPEX pigtails, 8 x Antenna of choice

Getting OpenWrt on the device is as easy as copying an image to a microsd card.

There are other devices you can put that wifi module into, but the above is probably one of the easiest.


This looks really interesting to me! Do you have any performance stats you can share such as iperf tests or file transfer tests?

Note the AsiaRF link is broken, here's the new one: https://asiarf.com/product/wi-fi-6e-mini-pcie-module/ it'll be in stock in November, it seems.

Thanks for the link. Have you built a 6e device like the one @VA1DER described above? I'm interested in building one and would like to see some performance tests first but I can't seem to find any anywhere.

I bought myself a BPI-R64 and an AW7916-NPD, installed openwrt 23.05.02 on it but I can't seem to get the radio to work on any of the 6GHz channels. 5GHz works fine with no issues.

Can you share the version of openwrt you're using and which version of the mt7916 driver you're using please?

I think you need to use snapshot, stable release doesn't have the package being able to use 6GHz, not related to the driver.

I can choose 5GHz or 6GHz in openwrt but my phone doesn't see an SSID when 6GHz is selected:

There are posts in this thread from people who have managed to get openwrt working at 6GHz earlier this year. I just haven't been able to find the magic combination of settings myself.

I did try snapshot a few days after 23.05 was released but LUCI didn't work at that time. I'll try again with a different SD card, maybe it will work now.

I just installed today's snapshot:

Model: Bananapi BPi-R64
Platform: mediatek/mt7622
Version: SNAPSHOT (r24550-f909059b74)
Date: 2023-12-01 13:22:22

Still can't see a 6GHz network. I've confirmed my phone can connect to 6GHz networks by testing at a friend's house who has some TP-Link 6e access points.

/etc/config/wireless looks like:

config wifi-device 'radio2'
        option type 'mac80211'
        option phy 'wl1.1'
        option cell_density '0'
        option country 'GB'
        option htmode 'HE80'
        option band '6g'
        option channel '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'sae'
        option key 'passwordgoeshere'

The relevant part of dmesg looks like:

[    7.664968] mt7915e 0000:01:00.0: assign IRQ: got 148
[    7.670111] mt7915e 0000:01:00.0: enabling device (0000 -> 0002)
[    7.676262] mt7915e 0000:01:00.0: enabling bus mastering
[    7.764811] mt7622-wmac 18000000.wmac: N9 Firmware Version: _reserved_, Build Time: 20220630094834
[    7.774189] Bluetooth: hci0: Device setup in 327103 usecs
[    7.787414] mtk-pcie 1a143000.pcie: msi#0 address_hi 0x0 address_lo 0x44e750c0
[    7.858978] mt7915e 0000:01:00.0: HW/SW Version: 0x8a108a10, Build Time: 20230202144915a
[    7.858978]
[    7.953203] mt7915e 0000:01:00.0: WM Firmware Version: ____000000, Build Time: 20230202145005
[    8.011220] mt7915e 0000:01:00.0: WA Firmware Version: DEV_000000, Build Time: 20230202143332

I'm not sure what else to check.

Not all channels seems to work on the 6ghz band, I use 21.

I've tried channel 21 and still nothing. What version of openwrt are you using on what hardware?

Could you post the contents of /etc/config/wireless please?

I'm using a x86 box snapshot

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'pcie'
        option channel '21'
        option band '6g'
        option htmode 'HE80'
        option country 'CA'
        option cell_density '0'

config wifi-iface 'wifinet0'
        option device 'radio0'
        option mode 'ap'
        option ssid 'AP'
        option encryption 'sae'
        option key 'pass'
        option network 'lan'
        option bss_transition '1'
        option skip_inactivity_poll '1'
        option time_advertisement '2'

Did you ever get it to work? I'm using NanoPi R5C which uses is own fork so its a bit behind the current snapshot.

The iw utility in particular and also the iwinfo utility do not support 802.11ax properly. This is a problem because the wireless support scripts in openwrt use iw in particular.
So potential bugs/omissions that would need to be fixed... as far as I can see with my incomplete knowledge.

As for wifi6e support, the htmode and channel combinations are very important.

From this list, HE80, valid channel numbers are:
7, 23, 39, 55, 71 and 87 for all countries. Choosing anything in between seems to result in failure.
You must however have a country code set.

Note: In the example posted by @antoncycle channel 21 results in failure with the message "unable to determine frequency" in syslog, at least when I try. HE20 and channel 21 do seem to work for me though.

Try setting band=6g and channel=87 for example....

AFAIK My issue isn't an incorrect config but has something to do with driver/firmware as iw phy shows that all the 6ghz channels are disabled. I have country set correctly, tried a multitude of channels and htmodes aswell as various drivers. I'm using an AsiaRF card which I think is different than most people with the MT7916.

In every config I just get

Wed Jan 24 16:28:57 2024 daemon.warn hostapd: phy1-ap0: IEEE 802.11 Hardware does not support configured mode (2) (hw_mode in hostapd.conf)
Wed Jan 24 16:28:57 2024 daemon.err hostapd: Could not select hw_mode and channel. (-2)

It's important to note that I have no band select option in luci and i'm on kernel 6.1

Hi, my apologies for bumping an old thread.
I was planning on replicating this setup to mesh two such devices together on the 6GHz band. Upon inspecting the picture you shared however, I do not understand what you use 8 antennas for. I can see 4 sockets in front of the BPI-R64 connected to the 4 antennas facing the front of your case. But all pictures of the AWD7916-NPD cards I can find online show only 3 sockets, so I am confused what the 4 antennas on top of your case connect to. Can you please elaborate on your antenna layout and connections, @VA1DER?