4G stick not working (E3372-325)

Hi I'm unable to make my usb stick working

Router: ASUS RT-AX59U
Version: 23.05.03
Usb stick: Huawei E3372-325

I've tried to configure this stick as qmi/mbim/cdc/rndis/ncim but nothing has been succesful. The usb stick does not seem to be recognized


Mon May 27 13:35:15 2024 kern.info kernel: [  905.799461] usb 1-2: new high-speed USB device number 4 using xhci-mtk
Mon May 27 13:35:17 2024 kern.info kernel: [  907.984885] usb 1-2: USB disconnect, device number 4
Mon May 27 13:35:17 2024 kern.err kernel: [  907.990230] xhci-mtk 11200000.usb: drop_ep_quirk high-speed ep2in intr, mpkt:8, interval:4/1ms
Mon May 27 13:35:18 2024 kern.info kernel: [  908.946275] usb 1-2: new high-speed USB device number 5 using xhci-mtk

usbmode -l provides no output

cat /sys/kernel/debug/usb/devices

T:  Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  5 Spd=480  MxCh= 0
D:  Ver= 2.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=3566 ProdID=2001 Rev=ff.ff
S:  Manufacturer=Mobile
S:  Product=Mobile
S:  SerialNumber=123456789ABCD
C:* #Ifs= 1 Cfg#= 1 Atr=e0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)
E:  Ad=81(I) Atr=02(Bulk) MxPS= 512 Ivl=0ms
E:  Ad=01(O) Atr=02(Bulk) MxPS= 512 Ivl=125us

There's no ttyUSB*. the only tty* I have in /dev are ttyS*

The stick works on my macbook, and I've updated it to the latest version.

I've tried to connect a phone using usb-tethering but with no more success.

I'd love some help of debugging this situation!

Edit: usb tethering works with a smartphone using rndis, and with a 4g-wifi box (not usb stick) using huawei_cdc_ncm

I assume you've already searched the forum for 3566:2001 and located Huawei e3372h-325 now working - stuck in CDROM only mode with OpenWrt - #26 by Young0223 ?

Yes. I tried a few things from there. From what I understand there's no matching driver found for my stock. I'm guessing that's the reason usbmode -l gives no output.

Either way an additional detail : when trying rndis it get's recognized for a while before it reverts back to no driver