23.05 sysupgrade questions (wndr4300V2)

Can we sysupgrade from 22.03?

yes you can on rt3200 i has make yesterday but not good for me this 23.05 for the gaming actually

for me it bricked the router now trying to recover it again

you has try on rt3200 e8540 ? belkin

https://openwrt.org/toh/netgear/wndr4300_v2 my router

file used https://downloads.openwrt.org/releases/23.05-SNAPSHOT/targets/ath79/nand/openwrt-23.05-snapshot-r23001+3-38c150612c-ath79-nand-netgear_wndr4300-v2-squashfs-sysupgrade.bin

When you upgraded, did you tell it to keep your settings? If so, maybe that caused a problem. Try booting into failsafe mode and see if you can then SSH in.

1 Like

How to enter fail-safe mode on wndr4300V2? No instructions in wiki

Easier to resort to TFTP if you have no serial (sounds like you do not). Either way, this topic is not meant to piggyback on for any sort of questions people have related to the branch.

@moderators Can the support posts be split off please?

There are instructions on the generic failsafe page I linked you to.

It explains:

  1. What failsafe mode is.
  2. How to boot into failsafe.
  3. The required network settings for your computer, so that you can connect to the router while it's in failsafe mode.

Once failsafe is working, SSH in, view your router settings with the command uci show, see which ones you customized, and then copy & paste them into a text file for later reference. Finally, reset all settings to default (command: firstboot && reboot now), and then set your router back up from scratch. As always, you'll need to reinstall any packages you had added.

I did try TFTP, but it isn't working. I have a serial adapter, but it is currently busy powering an esp32.
I even tried nmrpflash tool but had no luck until now.

TFTP doesn't goes beyond this

I did a backup of setting before updating.


1 Like

Try a factory reset. That'll give you a clean slate with only 23.05 defaults.

If that works, do not restore the full 22.03 settings from the back up file. That would just cause you to brick again. Instead, extract the tar file on your computer and use it only as a reference, focusing specifically on the settings you customized.

As a general rule, I only preserve settings when installing minor updates from within the same series (e.g. 22.03.4 to 22.03.5).

1 Like

How will I know the reset has been successful?

The router will boot up normally, you'll be able to open its web configuration at, there will be no default password, and it will be just like it was the very first time you booted up OpenWrt on that router. Except this time you'll be running something from the 23.05 series. Also, WiFi will be off by default.

tried using the reset button but the same issue, power led is green and blinked slowly

You'll need to hook up serial then to see what's going wrong exactly.

from last year

Last year sounds like apples and oranges.

1 Like

Restore your device to Netgear OEM firmware using nmrpflash tool. You will have a clean base to start. Than flash a factory image of 23.05.


I assume you say that because we've been talking about 23.05? Nmrpflash is a debricking program for flashing Netgear OEM firmware.

The OpenWrt wiki's WNDR4300 v2 article says it's similar to the WNDR4500 v3, and shares the same debricking instructions, just with a different Netgear firmware file. It also links to the generic OpenWrt debricking page.

Anyway, goodnight everyone.