23.05 sysupgrade questions (wndr4300V2)

Well, naturally it won't work if you use a wrong IP address ( instead of the correct



TFTP using my fav. method, ethernet to USB adapter worked wonders.
Started router router normally, power Led was blinking orange.
used setting from https://kb.netgear.com/000059634/How-do-I-upload-firmware-to-my-NETGEAR-router-using-TFTP-from-the-Microsoft-Windows-Command-Prompt

  • IP address:
  • Subnet mask:
  • Default gateway:
  • DNS (this system being Windows 11)

loaded WNDR4300v2-V1.0.0.58.img firmware image. waited few mins and router restarted itself into official Netgear firmware.

Now need to flash 23.05 via TFTP, I am additcted.


flashed via GUI method to 23.05 and bricked again. same green light blinking used

openwrt-23.05-snapshot-r23001+3-38c150612c-ath79-nand-netgear_wndr4300-v2-squashfs-factory.img file

Are you able to use Serial and see the boot logs?

if yes, is it okay to post those logs?

I could, but my serial adapter is busy powering an esp32. I was thinking of making a serial port out of an esp32; I do have a few of those spares.

It is possible that you have kernel partition size issue, or partition layout issue. I had such problem with the 3700v4 which is a close model.

  • try to monitor the boot with serial
  • flash a stable 22.03 and perform an upgrade to 23.05.

Currently back to 22.03. if it is any of the above issues, how to solve it? On esphome, instead of OTA we just flash via USB/serial, but how to fix it on OpenWrt?

I did try Snapshot which was successfully installed.



Logs are the "Boss" in troubleshooting!
Other trial-and-error approaches could work but they are luck-dependent approaches too.

1 Like

Apparently there is some kind of 8MB limit to flash file, when using sysupgrade. 4300v2 sysupgrade file are under 8MB, you should be able to perform an upgrade from 22.03. Don't keep settings.


but netgear files are almost 14MB

Yes, but they are netgear files for netgear devices :wink: There is a lot of devices in the same case.
OpenWrt tries to fit into the OEM partition layout.

Not according to device commit

I was talking about the WNDR 3700v4.

tried sysupgrade ended up with green blinking power led

netgear_wndr4300-v2-squashfs-sysupgrade.bin 44d2c1b5d2e218631ce62ebdffe80c99930e6072fe8b7f75029a1c9a43b3c68c 6120.3 KB Wed May 24 02:08:21 2023

When I set Ip manually, I ended with the network name from the previous setting. I can ping the router at but can't do SSH or telnet or access GUI.

Boot logs (and other tracing logs) are essential!

1 Like

Now it boot loops, after flashing openwrt. whichever method I try to flash nmrp, tftp and GUI it boot loops after restarting from GUI or through the power button.
I have tried Open 21, 22 and 23.
Initial stats.

will try to get them as soon as I free my serial adapter.

Check the host address

solved boot loop issue using this method. I used WInscp for offline install.

@frollic, any rationale for this behaviour? Previously, it was working fine via the GUI method. Not this time.

1 Like

Good to know. I'll give a try on the 3700v4 when I can. Thanks for solving.