21.02-rc3 on WRT3200ACM wireless 5GHz not working

This is a WRT3200ACM running 21.02-rc3 on a fresh clean install. The only non-standard thing I'm doing is that I have IPv6 disabled with sysctl (net.ipv6.conf.all.disable_ipv6=1
and net.ipv6.conf.default.disable_ipv6=1).

2.4GHz works normally but the 5GHz band just hangs up for some reason. It will transfer a bunch of packets then lock up solid with no traffic flowing for 5 minutes or so until it resets. Then another block of data will flow and then it seizes again. There are no errors in the kernel log. Sometimes if data is flowing continuous at a slow pace the connection will remain working but then if it sits for 5-10 minutes with no traffic it will start freezing again when big traffic starts.

Doing a tcpdump on a wireless client shows the bunch of packets then all of a sudden a handful of TCP Retransmission packets (no answer) over the course of 10 seconds. Then 20-50 seconds later another retransmission, then 20-50 seconds later it goes in to DHCP Request/Discover (no answer), then after another 20-50 seconds a bunch of unanswered ARP requests (this goes on for about 100+ seconds), finally a packet or two will go through, then connection reset packets, then finally data will start flowing again until it locks up and the sequence repeats. Sometimes the connection will stay dead for 10+ minutes. When the 5GHz band goes dead sometimes it goes dead for all connected clients and sometimes not. It will be really weird too like ssh won't connect (just syn packets with no response) but a telnet to the ssh port WILL work. It makes no sense.

I've tried flipping every switch under the wireless controls. Previously I had issues with 802.11w but that is disabled now. I tried all the bandwidth limits, etc. I'm using WPA2/PSK (AES) only.

Also, randomly sometimes hairpin_mode and multicast_to_unicast will get turned off which completely kills all wireless-to-wireless traffic until I at least turn hairpin mode back on. I have no idea what is turning it off, it seems totally random. This is a separate issue from the one above.

These issues were present on 21.02-rc2 as well. I went back to 19.07 and everything was fine (even running the newer mwlwifi firmware from 21.02). Then with the RC3 release I decided to try 21.02 again and it's still broken. My 19.07 and 21.02 configs are basically identical AFAIK.

1 Like

Search the forum, there's plenty of issues with the mwlwifi firmware in the 21.02 branch that is apparently newer than the 19.07 one. From what I gathered master might have fixes for that, but some people said switching to the 19.07 mwlwifi firmware on 21.02 fixed their issues.


By way of a quick test see post

I should have been more clear. I have tried both the 19.07 (0x09030206) and 20.02 (0x0903020c) firmware. Both firmware work fine on 19.07 and both firmware are broken on 21.02.

I don't think it's the firmware blob that is a problem. Something else is going on in 21.02. I suppose there is a possibility that some state is saved between the firmwares and rebooting is not enough to reset it (maybe need a hard power-off reset).

Hmm, I wonder if I could try swapping kernels between 19.07/20.02 installs.

I doubt that the kernel plays a part here, but there are 5.10.x images to be had, there is a community build to be found, and there are images off the link on my avatar. Perhaps take a kick at 21.x-SNAPSHOT to see if that changes anything, there has been some additional commits.

I just built and tried latest SNAPSHOT, r17188-90db922f88. Still broken.

It's pretty easy for me to recreate. All I have to do is ssh to a wifi client that is on 5GHz (in this case a RiPI) then run tcpdump -n -i wlan0 which will generate a ton of traffic because the ssh traffic will feed itself. Then most of the time (not 100%) after approximately 100-200 packets the connection will freeze solid. In the unlikely case that the connection doesn't freeze then it will continue to work until the wifi sits relatively idle for 10-20 minutes (ARP expiration?), then if I try the ssh/tcpdump again it will usually freeze up.

Maybe I should try swapping out the hostapd and/or wpa_supplicant between 19.07 and 21.02. I'm not sure if the configuration is compatible?

1 Like

Could try the testing kernel, mac80211 driver as another candidate, maybe enabling tracing might provide some info.

Just tried building again from master now that -RC4 is out. I was hoping maybe the kernel bumps would help but still no change, still broken, still very easy to recreate the issue.

I haven't had time to try using an older kernel or mac80211. The problem is that my whole Internet is down when I work on this which causes problems for some critical services.

21.02.0-rc4 has no relevance to master. The codebase has deviated already in Jan/Feb 2021. So, building from master "after rc4 has been released" is rather pointless.

Thanks for the tip. I had looked at the changelogs and they look similar to me but maybe there are huge differences. I'll try again with the pre-made RC4 release.

I don't notice any difference. Still broken the same in RC4.

ssh user@client
tcpdump -n -i wlan0
...some packets...
...total freeze...

Flip back to 19.07. Everything working fine.