[21.02] FRITZ!Repeater 3000 VLANs

Hi,

The FRITZ!Repeater 3000 has two LAN ports and I want to configure the network as follows:

  • LAN 1 should be used only for accessing the box over e.g. the IP 192.168.100.2. LAN 1 is connected to a switch port configured as "ACCESS". This works.
  • LAN 2 is connected to a switch port configured as TRUNK. The VLAN 110 is e.g. provided through the switch port. Radio 1 should be set up as an access point and bridged it with VLAN 110... I cannot get it working.

My network configuration:

# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd9f:732d:22af::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.100.2'
        option gateway '192.168.100.1'
        list dns '8.8.8.8'
        option delegate '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 4 5'
        option vid '1'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option vid '110'
        option description 'VLAN110'
        option ports '0t 5t'

config device
        option name 'eth0.110'
        option type '8021q'
        option ifname 'eth0'
        option vid '110'

config interface 'VLAN110'
        option proto 'none'
        option device 'eth0.110'
        option delegate '0'
        option type 'bridge'

and my wireless configuration:

# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option channel '100'
        option hwmode '11a'
        option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/soc/a000000.wifi'
        option htmode 'HT40'
        option channel '1'
        option cell_density '0'
        option country 'DE'

config wifi-device 'radio2'
        option type 'mac80211'
        option channel '36'
        option hwmode '11a'
        option path 'platform/soc/a800000.wifi'
        option htmode 'VHT80'
        option disabled '1'

config wifi-iface 'default_radio2'
        option device 'radio2'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

config wifi-iface 'wifinet3'
        option device 'radio1'
        option mode 'ap'
        option encryption 'psk2+ccmp'
        option hidden '1'
        option isolate '1'
        option key 'MyKey'
        option ieee80211w '2'
        option wmm '0'
        option wpa_disable_eapol_key_retries '1'
        option network 'VLAN110'
        option ssid 'OpenWrt'

Could someone help here please?

@GqSteve

hmm

option ports '0 4 5'

if i am correct, port5 is LAN2 ?
and you want only tagged trafic on LAN2, so you need to left out port 5 from vlan1

Right, port 5 is LAN 2 on this box.

I tried this as you can see in the screenshot, but it didn't work.

@GqSteve
ok, last idea
try to tag Vlan1 on CPU port
at least, all devices i have require tagging on CPU port for every vlan

@NPeca75
Before I try this...what actually confuses me is the following thread:

"Unfortunately" the syntax is based on 19.07...which is different from 21.02 (https://openwrt.org/releases/21.02/notes-21.02.0#new_uci_syntax)....

One thing is...to get VLANs working in the Fritz!Repeater, but I want to bridge e.g. VLAN110 with radio 1:

Do you have something running close to this?

@GqSteve
Wait ... it is IPQ40xx ?

Hello,

I use LAN1 as trunk without problems.
VLAN20 I used as manamgent vlan.

AVM FRITZ!Repeater 3000 with OpenWrt 21.02.0, r16279-5cc0535800

/etc/config/network

config interface 'loopback'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'
	option device 'lo'

config globals 'globals'
	option ula_prefix 'fd79:8335:d906::/48'

config interface 'lan'
	option type 'bridge'
	option proto 'dhcp'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '0t'
	option vid '1'
	option description 'OLD'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option vid '2'
	option ports '0t'
	option description 'OLD'

config switch_vlan
	option device 'switch0'
	option vlan '20'
	option vid '20'
	option ports '0t 4t 5'

config switch_vlan
	option device 'switch0'
	option vlan '21'
	option vid '21'
	option ports '0t 4t'

config switch_vlan
	option device 'switch0'
	option vlan '22'
	option vid '22'
	option ports '0t 4t'

config switch_vlan
	option device 'switch0'
	option vlan '23'
	option vid '23'
	option ports '0t 4t'

config interface 'vlan21'
	option proto 'none'
	option device 'br-vlan21'

config interface 'vlan22'
	option proto 'none'
	option device 'br-vlan22'

config interface 'vlan23'
	option device 'br-vlan23'
	option proto 'none'

config interface 'vlan20'
	option proto 'dhcp'
	option device 'br-vlan20'

config device
	option name 'br-vlan21'
	option type 'bridge'
	list ports 'eth0.21'

config device
	option name 'br-vlan22'
	option type 'bridge'
	list ports 'eth0.22'

config device
	option name 'br-vlan23'
	option type 'bridge'
	list ports 'eth0.23'

config device
	option name 'br-vlan20'
	option type 'bridge'
	list ports 'eth0.20'

/etc/config/wireless

config wifi-device 'radio0'
	option type 'mac80211'
	option hwmode '11a'
	option path 'soc/40000000.pci/pci0000:00/0000:00:00.0/0000:01:00.0'
	option country 'DE'
	option channel '100'
	option htmode 'VHT80'
	option cell_density '0'

config wifi-iface 'default_radio0'
	option device 'radio0'
	option mode 'ap'
	option ssid 'WLAN-X'
	option key 'PASS'
	option network 'vlan20'
	option encryption 'sae-mixed'
	option ieee80211w '2'
	option ifname 'wlan5g-upper-1'

config wifi-device 'radio1'
	option type 'mac80211'
	option channel '11'
	option hwmode '11g'
	option path 'platform/soc/a000000.wifi'
	option htmode 'HT20'
	option country 'DE'
	option cell_density '0'

config wifi-device 'radio2'
	option type 'mac80211'
	option hwmode '11a'
	option path 'platform/soc/a800000.wifi'
	option htmode 'VHT80'
	option country 'DE'
	option channel '52'
	option cell_density '0'

config wifi-iface 'default_radio2'
	option device 'radio2'
	option mode 'ap'
	option ssid 'WLAN-X-Guest'
	option ieee80211w '1'
	option key 'PASS'
	option isolate '1'
	option encryption 'sae-mixed'
	option ifname 'wlan5g-lower-1'
	option network 'vlan23'

config wifi-iface 'wifinet2'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WLAN-X-2.4GHz'
	option encryption 'sae-mixed'
	option key 'PASS'
	option ieee80211w '1'
	option network 'vlan20'
	option ifname 'wlan2g-1'

config wifi-iface 'wifinet3'
	option device 'radio1'
	option mode 'ap'
	option ssid 'WLAN-X-TEST'
	option encryption 'psk2'
	option key 'PASS'
	option network 'vlan21'
	option disabled '1'

switch on avm3000

This is how the port (LAN1) looks like on my switch (EdgeRouter-X) where the AVM3000 (Port LAN1) is connected.

@NPeca75
Yes.. https://downloads.openwrt.org/releases/21.02.1/targets/ipq40xx/generic/

@christian1982
Thank you for sharing this! :+1:

It worked for me, too. I have been trying to setup the box with LuCi...and I had to reinstall 21.02 (twice...) from scratch...it worked simply from CLI :slight_smile:

I have a couple of questions regarding your setup:

  • LAN 2 is not connected. Why do you have to define it as "untagged" for VLAN20?
  • There are three radios in the Fritz!Repeater 3000. Is it possible to setup more than one AP per radio? I see that you have wifinet2 & wifinet3 configured on radio1. I thought that only 1 access point is possible per radio...

LAN 2 is not connected. Why do you have to define it as "untagged" for VLAN20?

simply ignore, a remnant of previous tests.
If the trunk does not work, you can still access the manamgent of the AP.

There are three radios in the Fritz!Repeater 3000. Is it possible to setup more than one AP per radio? I see that you have wifinet2 & wifinet3 configured on radio1. I thought that only 1 access point is possible per radio...

the AVM 3000 has three radios

  • 5 GHz (1,733 MBit/s), channel from 100
  • 5 GHz (866 MBit/s), channel 36 to 64
  • 2.4 GHz (400 MBit/s)

For each radio you can set up multiple SSIDs (Multi SSID), each SSID can be assigned a separate VLAN.

if I understand it correctly you can create 16 SSIDs per radio.
However, you should use as little SSID as possible to save airtime.

root@ap-lan:~# iw list |grep managed
		 * managed
		 * #{ managed } <= 16, #{ AP, mesh point } <= 16, #{ IBSS } <= 1,
		 * managed
		 * #{ managed } <= 16, #{ AP, mesh point } <= 16, #{ IBSS } <= 1,
		 * managed
		 * #{ managed } <= 16, #{ AP, mesh point } <= 16, #{ IBSS } <= 1,
1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.