[23.05.0-rc3] FRITZ!Repeater 3000 VLANs

Hello.

There is already an older article about this topic: [21.02] FRITZ!Repeater 3000 VLANs

But as the switch design has changed to DSA (?) i have issues to get it working on the latest 23.05 (needed rc3 for the new flash chip) in the same config as described in the older article.
i want lan1 with dhcp as managment and lan2 tagged with 3 VLANs for 3 different wireless SSID.
lan1 is working with a bridge and dhcp as expected. but lan2 only gives untagged output. Any ideas how to get the tagged output working? i made 1 bridge-vlan with 3 vlan interfaces (lan2.10, 20 and 30) which i assigned to the SSID. in the bridge i activated vlan and set lan2 to T. the vlan interfaces to U. But the output on lan2 is untagged. i want it tagged.
Thx.

Martin

It's way more effective if we're able to look at your /etc/config/network instead of having to reassemble it from your post.

Hello.

This is my /etc/config/network
Thx.

config device
	option name 'br-lan'
	option type 'bridge'
	list ports 'lan1'

config interface 'lan'
	option device 'br-lan'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'br-vlan'
	list ports 'lan2'
	option bridge_empty '1'

config bridge-vlan
	option device 'br-vlan'
	option vlan '10'
	list ports 'lan2:t'

config bridge-vlan
	option device 'br-vlan'
	option vlan '20'
	list ports 'lan2:t'

config bridge-vlan
	option device 'br-vlan'
	option vlan '30'
	list ports 'lan2:t'

config interface 'vlan10'
	option proto 'none'
	option device 'br-vlan.10'

config interface 'vlan20'
	option proto 'none'
	option device 'br-vlan.20'

config interface 'vlan30'
	option proto 'none'
	option device 'br-vlan.30'

Martin

Hi,

did you find a solution? I'm also struggling with the config.

Thanks,
meiser

This should contain all your LAN ports and AFAIK the 'bridge empty' option should go. You then use the config bridge-vlan stanza to define the actual VLANs. While not mandatory, it does help to name your VLANs to tell them apart more easily. E.g.:

E.g.:

config bridge-vlan 'lan_vlan'
	option device 'br-lan'
	option vlan '10'
	list ports 'lan2:t'

config bridge-vlan 'iot_vlan'
	option device 'br-vlan'
	option vlan '20'
	list ports 'lan2:t'

[...]

config interface 'lan'
	option proto 'none'
	option device 'br-vlan.10'

config interface 'iot'
	option proto 'none'
	option device 'br-vlan.20'