21.02.0-rc1 Opkg: incompatible with the architectures configured

I have a mips_24kc arch router on 21.02.0-rc1

Using opkg I tried to install openvpn-openssl_2.5.2-1_mips_24kc.ipk

I am getting this error

Unknown package 'openvpn-openssl'.
Collected errors:
 * pkg_hash_fetch_best_installation_candidate: Packages for openvpn-openssl found, but incompatible with the architectures configured
 * opkg_install_cmd: Cannot install package openvpn-openssl.

I tried to get the older package from 19.07.7 repo but that didnt work either

If a mod or admin or anyone can help, is this information usually enough or the exact router model is needed?

Please let me know what other information can help with this issue

I really need urgent help

If you have downloaded this file from somewhere manually, you probably grabbed the wrong file. Is there a reason you're not using official repo?


There might be an actual bug:


# [21.02] opkg fails to install manually downloaded packages


It was from the official repo for [21.02.0-rc1 ]

Besides, I successfully installed other ones from the same repo

Maybe it is an issue with this specific package
@stangri @hnyman

I got this today on the snapshot imagebuilder for Linksys WRT3200ACM when adding luci as a package. It found luci-mod-status and rpcd-mod-iwinfo but they are “incompatible with arcitecture”.

Tried without luci and it compiled without errors.

Tried again with luci with the same error again.

openwrt-imagebuilder-mvebu-cortexa9.Linux-x86_64.tar.xz 4b948cbcc0e53e57e5c4189b29cf8eb77f2a3b06c460d7a662fc18db4fc8d351
59106.1 KB
Sun May 2 05:27:42 2021

You are mixing things a bit. Your observation is from master snapshots, not from 21.02.

You are possibly seeing the error today because iwinfo was updated earlier today. And you need to have the phase1 buildbot kernels & target packages in sync with the general packages from the phase2 packages buildbot, which needs the new SDK from the phase1. Likely luci still expects an older iwinfo stuff, while your imagebuilder already has the new version. You need to wait until phase2 packages have been built.

The iwinfo ABI version changed, rendering packages incompatible

The current error message from opkg is too obscure, and packages several different errors under the same message :frowning:

1 Like

Any chance we can make this error message more specific?


Sure, patching opkg suitably.

There is early disussion about the issue on the dev mailing list.
See onward from https://lists.openwrt.org/pipermail/openwrt-devel/2021-May/034916.html

There are several different issues that nd end up with this:

  • actual kernel version incompatibility
  • temporary images/packages buildbot mis-sync after package ABI version bumps (like iwinfo now in master)
  • missing package lists due to "opkg update" not done
  • etc...

Apparently too many of those get now clumped to "incompatible architecture".


yes i have a same problem with rt3200 belkin


Hi all - I think i'm having a related problem. I'm also running 21.02-rc1

I'm getting the incompatible architecture error:

Details for package kmod-usb-storage

  • Version: 5.4.111-1
  • Size: ~23.3 KB installed
  • Dependencies:
    • kernel Version incompatible
    • kmod-scsi-core Installed
    • kmod-usb-core Installed
      • kmod-nls-base Installed

Kernel support for USB Mass Storage devices

  • The installed version of package kernel is not compatible, require 5.4.111-1-af78d96e… while 5.4.111-1-1749bfdc… is installed.

Is this an error on my end, or an error with the package config somewhere? The kernel requirements are near identical 5.4.111-1 ?