1convert wan to lan 2wwan connection drops 3slower wifi speed/good wired ALFA R36 WR6202-1U

i tried lots of setup option concerning the switch topology to convert the r36 wan to lan so i can use 2 wired connections since i use it as an extender with wireless wan.

The alfa r36 has the board of wr6202-1u (mips32 24ke rt3050F) not the w502u if there actually are differences that are notable i hesitate. the w502u images also work on my device.

Currently use LEDE Reboot 17.01.0 r3205-59508e3 stable release.
the additional packages i installed are minimum for basic functionality:
*kmod-nls-base
*kmod-rtl8187
*kmod-usb2
*kmod-usb-core
*kmod-dusb-dwc2

as the rtl8187 (alfa awus036H) is functioning as a wwan

1)the goal im trying to achieve is firstly convert my my wan port into a lan port so the device ends up having 2 functional lan ports.
2)stop wireless wan from dropping which only gets fixed with a reboot (not inid.d/network restart)
3)tried everything to make wifi fast every possible setting including many beacon intervals on both client and access point (since its an extender)

literally everything possible from the config. what is weird is im not in a crowded area whatsoever whenever i do manage to get it working quite decent through wireless it has a certain delay to reach almost near peak connection while still fluctuating which isnt a lot btw

from the wwan i have about 4/5 mbit on a wired connection even in ht40 wmm on various channels including 13 since its legal in my area wlan fluctuates 1 mbit 2 mbit 3 max

currently i removed almost every option in wireless settings since it did not matter much
i like to note that the client 8187 uses a 2.4Ghz parabolic grid 24dbi and the access point a 9dbi omni, the router also has a decent heatsink as an extra so does the rtl8187 chip because they run constant sometimes with higher temperatures.

I would sincerely appreciate any possible help or suggestions on possible improvements on either 1 of the 3 issues i am dealing with since i have spent countless hours in playing around with every possibility im also interested in what people deal with while having the same device

the current network setup is:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'XXXX:XXXX:XXXX::/XX'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.2.1'
option netmask '255.255.255.0'
option ip6assign '60'
option delegate '0'
option macaddr 'XX:XX:XX:XX:XX:XX'
option isolate '1'
option _orig_ifname 'eth0.1 eth0.2 wlan0'
option _orig_bridge 'true'
option stp '1'
option ifname 'eth0.1 eth0.2'

config device 'lan_dev'
option name 'eth0.1 eth0.2'
option macaddr 'XX:XX:XX:XX:XX:XX'

config switch
option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan
option device 'switch0'
option vlan '1'
option ports '1 6t'

config switch_vlan
option device 'switch0'
option vlan '2'
option ports '0 6t'

config interface 'wwan'
option proto 'dhcp'
option delegate '0'
option hostname 'XXX'

the current wireless settings are:

config wifi-device 'radio0'
option type 'mac80211'
option hwmode '11g'
option path 'platform/10180000.wmac'
option htmode 'HT40'
option country 'GR'
option frag '2346'
option rts '2347'
option noscan '1'
option greenfield '1'
option channel '13'
option beacon_int '125'
option bgscan '0'
option powersave '0'
option skip_inactivity_poll '0'
option compression '1'
option txpower '20'
option distance '100'

config wifi-iface 'default_radio0'
option device 'radio0'
option mode 'ap'
option ssid 'XXX'
option hidden '1'
option encryption 'psk2+ccmp'
option key 'XXX'
option disassoc_low_ack '0'
option wpa_group_rekey '600'
option isolate '1'
option network 'lan'
option rsn_preauth '1'

config wifi-device 'radio1'
option type 'mac80211'
option hwmode '11g'
option path 'platform/101c0000.otg/usb1/1-1/1-1:1.0'
option channel '1'
option txpower '12'
option country 'GR'
option distance '100'
option frag '2346'
option rts '2347'
option turbo '1'
option bgscan '0'
option powersave '0'
option skip_inactivity_poll '0'
option compression '1'
option doth '1'
option frameburst '1'
option bursting '1'
option noscan '1'
option beacon_int '75'

config wifi-iface
option network 'wwan'
option ssid 'XXX'
option device 'radio1'
option mode 'sta'
option bssid 'XXX'
option key 'XXX'
option encryption 'psk+ccmp'
option macaddr 'XXX'
option disassoc_low_ack '0'
option rsn_preauth '1'
option wpa_group_rekey '600'

some additional info to the above, forgot to mention that the drops in wifi arent drops from the local wlan neither any drop physically.
both wlan and wwan stay connected after having applied my settings, the drops are not anymore time related however with continuous usage if it is intense the internet connection drops while both wwan and wlan stay connected.
over wifi i also have the issue of a certain delay before the peak of speed is reached and after fluctuates, something which is not present on a wired connection which works perfect despite of it functioning as a wifi extender

i also have tried it with several awus036h with same result so it isnt a hardware malfunction.
also with the awus036nhr v2 (8188RU) and the awus036nhv csv (8188EU) but overal regardless of lack of N support the 8187 seems to be the most robust.

real drops i only had with openwrt chaos calmer but not on lede anymore.

furthermore i like to note that the original lan is fully functioning it is just the converted wan to lan port which remains undetected by any device and does not provide dhcp.

since every device has its own topology i tried following the correct guide for the r36 however wan is still not functioning as lan.

next to all the last issue im having is when one device starts using significant bandwith other devices sometimes dont operate anymore, tried installing and configuring QoS but without any significant effect.

i believe this description captured all of my lasting issues that i haven't been able to fix.

maybe this is the reason it isnt working while it should ( wan to lan port ) https://patchwork.ozlabs.org/patch/561991/ anyone?

Can you get the awus036hnv to work with openwrt?
What driver did you use?
I can't get mine to work

user just posted here: 8188eu drivers

Please don't hijack posts.

Hello,

I hope this isn't 'hijacking' a post. I have an 8188RU chip on USB and can't fathom which driver package and version to use with it.

Did the OP get his 8188RU working?

Many thanks.