19.07 build for Archer C6 v2

Hi. Is the DoH support that you show in Step1 coming to generic 19.07? That is, the built-in capability, as opposed to needing to add it as described in procedures elsewhere? Or is this something just with your build?

No, this package is not build by default. This package is a community package developed by aarond10. Although it is included into openwrt package repository, you can build openwrt from source, download & enable this package by:
./scripts/feeds update -a
./scripts/feeds install -a
make menuconfig
then enable DNS-Over-HTTPS from it.

If you have a existing openwrt installed into your router, you can install it from Luci-Package manager.

1 Like

Hi all,

I tried to install it through the tftp/gui methods, but both brick the router. Any hints how I could help debugging that behaviour?


Did you used a switch between the pc running tftp server and the router that you are flashing?

Hi Rupam,

thank you for asking, yes, I did. The transfer goes well (no errors in the tftp log file). I seems like it doesn't come up after flashing (only power led + network led on). No successful DHCP traffic on the network.

Did you able to fix it or it is completely broken?
I have raw backed up stock firmware backed up from the flash chip. If it is broken you can always directly flash it using a flash programmer like CH341A or using an Arduino.

I am able to unbrick it with an original firmware over TFTP. Meanwhilst I compiled openwrt myself (default config and your config), still not able to flash it onto the Router (same result, doesn't boot up after flashing). What's the best way to figure out what's happening?

What hardware version do you have?
This firmware for only EU/RU versions of 2.0-2.6 hardware versions...

It says Archer C6(EU) Ver: 2.0 on the back...

Sorry my bad, ya it is 2.0-2.6. Then it should work.
It takes 1-2 minutes time to first boot up after flashing.

Thank you for the hint, I waited multiple times for longer than that.

Is there a serial tty on the thing or anything to get any messages out from the flashing process? I noticed when flashing the original firmware that the wps light stays on for the process, while with openwrt it goes off quickly.

I opened up the that router, this router doesn't have any serial comm header or marked port on it's circuit board, all though the SoC is capable of serial communication.
I used solar winds free tftp server software to flash it.


there is three markings/solder points: TP_GND, TP_3.3V, TP_UART_IN close to the onboard antenna, but none gives the typical ~3V for TX. I also checked surrounding points, but also to no avail. Any ideas how to find it ? There is a 8 pin chip next to it not sure what is does.

I used tftpd64.

1 Like

That chip is SPI EEPROM (8MB).

True, there is some data going over the pins, but nothing an FTDI would be able to translate (there are however, spikes on the oscilloscope). I wonder if the UART_OUT-Pin is under the metal cover... that unfortunately looks like it's soldered onto the PCB.

1 Like

RFTM surely helps, in fact everything was working well, didn't notice that luci has to be installed manually for snapshot builds and is not accessible from the wan port. I am still wondering where the UART_OUT-Port ist, though.

1 Like

Did you tested by changing the UART baud rate to different one...

Awesome firmware. Works like a charm on my Archer C6. DNS over HTTPS working fine too. I only have question regarding pkg updates. I understand this build is from snapshot and probably snapshots doesn't have stable pkg repository. But can I change repo url to: http://downloads.openwrt.org/snapshots/targets/ath79/generic/packages/ and install non kernel related stuff from there?

1 Like

Apart from the caveats you already mentioned, it should work.

1 Like

Yes you can install non karnel related packages, I installed luci-adblock and luci-ddns.

Few days back I wanted to update package cache and it's not working and shows signature verification failed thus the update failed. Then I commented # option check_signature in opkg.conf and I also changed every http links to https in opkg/distfeeds.conf. Now package update works fine.

1 Like