19.07.2 upgrade, no https any more

hi community,
I upgraded TP-Link router WDR4300 from 19.07.1 to 19.07.2.
I had before access via https using luci-ssl.
Now I lost the access via Luci it present the Luci page but with no https.
when I enter the password, it did not accept.
But I can login via ssh. looks like it has all settings in following file.
/etc/config# cat uhttpd
.. and there are no luci-ssl in installed packages.

What shall i do now? did someone experience that?
shall I somehow reinstall luci-ssl from cli interface?
or shall first fix access via pure http?

thanks for help, greg.

The "sysupgrade" procedure does not upgrade packages installed by the user, you need to install them yourself after the upgrade.


Use this one before and after the upgrade.

hi, thank you very much trendy and eduperez.
i installed luci-ssl via opkg package manager.
and luci https access works now as before.
i was wondering if self-signed certificate is stored somewhere and it will be used for new installed luci-ssl, without generating new one.
but looks like it takes the old certificate from previous settings.

for the future with additional packages and openwrt upgrade.
shall i remove them before?

kind regards,

The certificates are by default in /etc/uhttpd.key and .crt
You can migrate them or create new, it doesn't really matter.

1 Like

If your problem is solved, please consider marking this topic as [Solved]. See How to mark a topic as [Solved] for a short how-to.

1 Like

No need to remove anything, as "sysupgrade" wipes the device, then install the new version and recovers config files.

1 Like

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.