101 (edited by angelos 2013-04-30 20:05:14)

Re: WBMR-HP-G300H ... willing to help

Cool. smile

If someone could have a look in the topic I opened a few days ago and maybe have a solution (even temporary), I would appreciate it. Here it is..

WBMR-HP-G300H and problems with Huawei 3G modems (E173 & E3131)

As things are at the moment, the USB port is useless.
3G sticks and WiFi adapters don't work as they should and the router freezes or reboots randomly, when a USB device is used.

I have read a few articles on the internet and it seems to be a kernel bug that affects kernels > 3.2
Can someone confirm this?

I would also like to ask developers if they could release an official trunk build for the WBMR with a kernel that is not affected by this issue (whenever this may happen or if it's already fixed), so we can migrate there easily, at least until the next major release is available...

Re: WBMR-HP-G300H ... willing to help

I haven't used a modem or wifi adapter on the USB port but I've used a hard drive fine.

Is anyone else having problems with DSL dropping out every few days or so? I'm using annex A firmware.

I just upgraded to 12.09 from rc1, will see if there's been any improvement.

103

Re: WBMR-HP-G300H ... willing to help

My harddrive works fine on this router with 12.09.

Also I'm on Annex A and there are no drops. Sorry to hear. Never used a USB modem or wifi adapter too.

Re: WBMR-HP-G300H ... willing to help

wb wrote:

Also I'm on Annex A and there are no drops. Sorry to hear. Never used a USB modem or wifi adapter too.

Thanks. Are you able to post your config (removing any user/pass of course)?

105

Re: WBMR-HP-G300H ... willing to help

Well this is pretty much everything I ever configured:

http://i43.tinypic.com/35a3kh4.jpg

Also I set my connection to Annex A in one file I don't remember. But I guess you already did that since your connection is up and running.

Re: WBMR-HP-G300H ... willing to help

Ah OK, I've been using PPPoE, wonder if that's the issue...also I don't use the GUI so don't know how those settings directly translate in /etc/config/network

Has been up since I moved to the final release, just over three days...if it continues to drop out again I'll try PPPoA.

Re: WBMR-HP-G300H ... willing to help

Does anyone have problem with the switch and wifi on trunk builds lately?

Switch seems broken (you need to edit the /etc/config/network file from eth0 to switch0)
Wifi doesn't work at all.

108

Re: WBMR-HP-G300H ... willing to help

peps1iko wrote:

Does anyone have problem with the switch and wifi on trunk builds lately?

Switch seems broken (you need to edit the /etc/config/network file from eth0 to switch0)
Wifi doesn't work at all.

Switch has not been working for me for a long time, had to add that switch0 everytime by hand.

I noticed that wifi is not working after you mentioned it, Only my smartphone has wifi so I don't use it so often.

Also I have constant wan drops, internet just stops working but there is nothing on system log that the dsl line has been gone silent/down. Earlier there were always some sort of logs about those events. wan status still says its connected so i don't know whats going on.

Re: WBMR-HP-G300H ... willing to help

Jaska wrote:

Also I have constant wan drops, internet just stops working but there is nothing on system log that the dsl line has been gone silent/down. Earlier there were always some sort of logs about those events. wan status still says its connected so i don't know whats going on.

You can enable the "debug" option in /etc/ppp/options so you read the syslog messages...

110

Re: WBMR-HP-G300H ... willing to help

angelos wrote:
Jaska wrote:

Also I have constant wan drops, internet just stops working but there is nothing on system log that the dsl line has been gone silent/down. Earlier there were always some sort of logs about those events. wan status still says its connected so i don't know whats going on.

You can enable the "debug" option in /etc/ppp/options so you read the syslog messages...

My ISP does not use ppp, It's always on "dhcp client"

After upgrading to latest trunk now it shows the old messages
Sat Jul  6 19:14:55 2013 authpriv.error root: Found no matching interface for DSL notification (DOWN)
Sat Jul  6 19:14:55 2013 auth.err kernel: [ 2851.140000] leave showtime
Sat Jul  6 19:15:43 2013 auth.emerg kernel: [ 2898.824000] [DSL_BSP_Showtime 894]: Datarate US intl = 1021250, fast = 0
Sat Jul  6 19:15:43 2013 auth.err kernel: [ 2898.828000] enter showtime, cell rate: 0 - 2408, 1 - 2408, xdata addr: 0x82e00000
Sat Jul  6 19:15:44 2013 authpriv.error root: Found no matching interface for DSL notification (UP)

Re: WBMR-HP-G300H ... willing to help

Jaska wrote:
peps1iko wrote:

Does anyone have problem with the switch and wifi on trunk builds lately?

Switch seems broken (you need to edit the /etc/config/network file from eth0 to switch0)
Wifi doesn't work at all.

Switch has not been working for me for a long time, had to add that switch0 everytime by hand.

I noticed that wifi is not working after you mentioned it, Only my smartphone has wifi so I don't use it so often.

Also I have constant wan drops, internet just stops working but there is nothing on system log that the dsl line has been gone silent/down. Earlier there were always some sort of logs about those events. wan status still says its connected so i don't know whats going on.

Guys, good news. After struggeling for some time I have the switch running even VLAN works on final Attitude Adjustment. Here is what I have in my /etc/rc.local

swconfig dev eth0 set reset 1
swconfig dev eth0 set enable_vlan '1'
swconfig dev eth0 vlan 0 set ports '0t 1'
swconfig dev eth0 vlan 1 set ports '0t 3 4 5'
swconfig dev eth0 vlan 2 set ports '0t 2'
swconfig dev eth0 set apply
swconfig dev eth0 set enable_vlan '1'
swconfig dev eth0 set apply
swconfig dev eth0 set apply

eth0.0 is not used, eth0.1 is my LAN connected to the bridge, eth0.2 is my WAN uplink port (port 2 in the config, labeled as port 4 on the router). The physical DSL port is not used in my setup.
I have a similar config in /etc/config/network but just to make LuCI understand my setup and let me configure my interfaces. /etc/rc.local overwrites the settings on startup. Of course, once LuCI does config and reloads /etc/config/network, this is gone and I have to rerun /etc/rc.local or even reboot.

This works quite well but still not 100% stable. As you can see, I had to use "set apply" several times, don't know why but it increased stability. But still, once I reboot the router the WAN link doesn't come up any more. PPP link is not established, maybe the device that is connected to the WAN port doesn't provide an IP address... still working on it.

By the way, WLAN is also working fine for me...

Cheers
macmeck

Re: WBMR-HP-G300H ... willing to help

Oh, did someone get this movie engine hardware switch to do something useful? I tried the hotplug buttons but only received events from the AOSS button on the front. The movie engine switch would be much more fun to play with...

113 (edited by pyed 2013-08-06 04:27:30)

Re: WBMR-HP-G300H ... willing to help

As I'm using 12.09.1, opkg by default will try to fetch packages from a URL that doesn't exist which is

 http://downloads.openwrt.org/attitude_adjustment/12.09.1/lantiq/ar9/packages 

the problem here is the 12.09.1, if you checked "http://downloads.openwrt.org/attitude_adjustment/" there's no such folder with this version so if you try "opkg update" you'll get

root@Main:~# opkg update
Downloading http://downloads.openwrt.org/attitude_adjustment/12.09.1/lantiq/ar9/packages/Packages.gz.
wget: server returned error: HTTP/1.1 404 Not Found
Collected errors:
 * opkg_download: Failed to download http://downloads.openwrt.org/attitude_adjustment/12.09.1/lantiq/ar9/packages/Packages.gz, wget returned 1.

so you have to change /etc/opkg.conf to this

src/gz attitude_adjustment http://downloads.openwrt.org/attitude_adjustment/12.09/lantiq/ar9/packages
dest root /
dest ram /tmp
lists_dir ext /var/opkg-lists
option overlay_root /overlay

the same can be achieved from LuCI System --> Software --> Configuration

OpenWRT / Buffalo WBMR-HP-G300H

114 (edited by pyed 2013-08-06 04:27:27)

Re: WBMR-HP-G300H ... willing to help

have anyone experienced problems after applying " Wired stations cannot ping each other " fix ?

I'm running on Attitude Adjustment 12.09.1, compiled it my self with packages i need, everything works great except for the known issue where LAN is isolated from each other, so I applied the fix in the wiki

swconfig dev eth0 vlan 1 set ports "0 1 2 3 4 5"
swconfig dev eth0 set apply

now the problem is gone so i edited /etc/config/network and added these lines to make this fix permeant

config switch
    option name    'eth0'
    option reset    '1'

config switch_vlan
    option vlan    '1'
    option device    'eth0'
    option ports    '0 1 2 3 4 5'

after rebooting, it won't give out IPs to the LAN clients, only clients connected via Wireless will get IPs, LAN clients will get self-assigned IPs. I tried rebooting multiple times without any luck, the only fix is to delete the fix lines from /etc/config/network and reboot.

anyone happened to face such problem ?

OpenWRT / Buffalo WBMR-HP-G300H

115

Re: WBMR-HP-G300H ... willing to help

Did you try without option reset?

Re: WBMR-HP-G300H ... willing to help

Hi pyed,

you should explicitly set enable_vlan to 0, then it worked for me. I will update the wiki.

config switch
        option name 'eth0'
        option enable_vlan '0'
        option reset '1'

config switch_vlan
        option vlan '1'
        option device 'eth0'
        option ports '0 1 2 3 4 5'

Apart from that, the version 12.09.1 is a version you created or is it some kind of official branch or tag? Never heard of.
Updating opkg.conf seems to be the correct way. You could also insert this path directly to the image you create. After make menuconfig go to "Image Configuration", "Version configuration options", there you can specify the defaults if I'm not mistaken.

Cheers
macmeck

117 (edited by pyed 2013-08-06 12:18:00)

Re: WBMR-HP-G300H ... willing to help

@macMeck thank you, your lines did the trick

about 12.09.1, I'm totally flying by the seat of my pants big_smile, three days ago I knew nothing about Openwrt but the name. I was DD-wrt user for years tho.

I compiled it my self, I thought that this extra '1' is some sort of important patch they added to AA, all I did is setting up my compiling environment and cloning AA using SVN + updating feeds and installing them all + make menuconfig + make
and here's the configuration : http://pastebin.com/uxiaV35c

root@Main:~# cat /proc/version
Linux version 3.3.8 (pyed@debian) (gcc version 4.6.3 20120201 (prerelease) (Linaro GCC 4.6-2012.02) ) #1 Mon Aug 5 23:54:29 AST 2013

and LuCI is showing the following:

Firmware Version     OpenWrt Attitude Adjustment 12.09.1 / LuCI 0.11 Branch (0.11+svn9875)

anyway everything is working just fine now thanks to you macMeck

Edit: I googled it and it exist, but I think there's a few people out there compiling AA from source to notice this issue, check out this +month ticket:  https://dev.openwrt.org/ticket/13804

OpenWRT / Buffalo WBMR-HP-G300H

118 (edited by pyed 2013-08-11 03:10:42)

Re: WBMR-HP-G300H ... willing to help

anyone facing problems when trying to extroot using USB

here's whats going on, I've 64GB USB stick with the following partitions
          6 Gb to be mounted as /overlay
          1 Gb as swap
          the remaining will be mounted to /mnt

I was reading the wiki all day, and did the pivot overlay steps, the problem is there is something preventing the USB to be mounted to these directories at boot, after the boot there will be nothing mounted, if I un-pluged the USB stick and plugged it back in, everything will work and I'll get the following output from df -h

root@Main:~# df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                   26.9M      1.0M     25.9M   4% /
/dev/root                 3.3M      3.3M         0 100% /rom
tmpfs                    30.3M    104.0K     30.2M   0% /tmp
tmpfs                   512.0K         0    512.0K   0% /dev
/dev/mtdblock5            5.3G    209.4M      4.9G   4% /overlay
overlayfs:/overlay       26.9M      1.0M     25.9M   4% /
/dev/sdb1                53.2G     18.9G     31.6G  37% /mnt
/dev/sdb3                 5.3G    209.4M      4.9G   4% /overlay

but after any reboot, these won't be mount and i've to unplug and plug the usb stick back in, and everything will get mounted again

in the wiki, the fstab troubleshooting section, there was similar problem, and the solution was to add 'sleep 15' to the start function in /etc/init.d/fstab, I tried that and didn't work. 

here's my /etc/config/fstab

config mount
    option target    /overlay
    option uuid        2fba6abe-c5de-4b47-a8e1-30e654a68e38
    option fstype    ext4
    option options    rw,sync
    option enabled    1
    option enabled_fsck 0

config mount
    option target    /mnt
    option uuid        0faa8e57-d2d4-46b3-abb6-4ea56041c8df
    option fstype    ext4
    option options    rw,sync
    option enabled    1
    option enabled_fsck 0

config swap
    option uuid        96d9fadd-3147-4c90-b995-2ebf8fb91899
    option enabled    1

i'm on Attitude Adjustment

Edit: formatting my USB stick to ext2 solved my problem !

OpenWRT / Buffalo WBMR-HP-G300H

Re: WBMR-HP-G300H ... willing to help

On the wiki page http://wiki.openwrt.org/toh/buffalo/wbmr-hp-g300h#wired.stations.cannot.ping.each.other someone reported that VLANs should be working in attitude adjustment from something around r37559. Unfortunately, I cannot confirm that.

Can anyone else report success on this neverending story?

120

Re: WBMR-HP-G300H ... willing to help

macMeck wrote:

On the wiki page http://wiki.openwrt.org/toh/buffalo/wbmr-hp-g300h#wired.stations.cannot.ping.each.other someone reported that VLANs should be working in attitude adjustment from something around r37559. Unfortunately, I cannot confirm that.

Can anyone else report success on this neverending story?

I'm on r37630 now and i had to apply the fix.

OpenWRT / Buffalo WBMR-HP-G300H

Re: WBMR-HP-G300H ... willing to help

pyed wrote:

I'm on r37630 now and i had to apply the fix.

You used the fix to explicitly not use VLANs, right? Question is if someone made it to use VLANs and applied different IP addresses to the ports of the switch... and got it running stable.

122 (edited by debwalker 2013-08-09 14:52:50)

Re: WBMR-HP-G300H ... willing to help

It looks like there are some new improvements in the switch configuration.

On using a newer attitude adjustment build (r37559 on 28/07/2013) it "seems" the switch works for me properly.  I am able to create VLANS on the switch and all appears working according the configuration and no debrick / resets are needed because of the switch misbehaving. I got a response from one of the wiki maintainers in the form of email confirming improvements to the configuration but without working seperate VLANS on the switch. Also I was maybe a bit zelous in putting this into the wiki. Sorry for that, I changed it to a quick link to this post in the meantime. If I find any improvements I'll put it here first.

What is working for me so far is that swconfig shows the settings I set and I am able to create more VLANS without needing to debrick or reset the device. I can do all this with luci and can confirm the changes with 'swconfig dev eth0 show'  and I see no errors anywhere in dmesg or on restarting the network with '/etc/init.d/network/restart' like I could see before.  Wasn't able to confirm if the switch actually works yet and will post back after testing tommorow. If anyone has any success with the new build please put your method and results here smile.

What I noticed is the 'cpu' port is untagged per default configuration and I've noticed it's more commonly tagged on other routers, so I'm wondering what the actual standard setup should be here in theory if anyone knows. I'll try to test some configurations tommorow too or confirm if anyone elses config works for me.

Another issue I had before when trying to have seperate interfaces for both LAN ports and WIFI both with seperate zones is I would lose WAN access if I tried to put the WIFI into it's own firewall zone. That problem is gone now for me, not sure if anyone noticed it or if it was a switch issue.

A slightly more recent attitude adjustment build worked the same after an upgrade too.

Re: WBMR-HP-G300H ... willing to help

Testing inconclusive today because for some reason I can't get a wired connection in any way I try. I think it's down to the stupidity of ubuntu network manager as I've had issues with it before so I'll try again later on my debian setup and say what works or doesn't.

Re: WBMR-HP-G300H ... willing to help

debwalker wrote:

Testing inconclusive today because for some reason I can't get a wired connection in any way I try. I think it's down to the stupidity of ubuntu network manager as I've had issues with it before so I'll try again later on my debian setup and say what works or doesn't.

Or your VLAN setup just doesn't work ;-) I've seen this behavior before when I fiddled around with the VLAN config. I really hope that we get this running some day.

125

Re: WBMR-HP-G300H ... willing to help

I had this issue with WBMR for quite some time, even since DD-wrt days, when I wake my PC which is connected physically to the router, it will take about 10 seconds to get IP, in the other hand if I'm connected wirelessly, it will give me the IP way faster. this is happening on both OpenWRT and DD-wrt, I tried setting up static IP from PC and from the router and the issue still there.

Anyone facing the same issue ?

OpenWRT / Buffalo WBMR-HP-G300H