Re: Tp-link Tl-wr703n

that usb socket for 3g could be used to insert usb storage and save files on it (torrents) or it is only for 3g modems, cause i see many functionality like this one above

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

The USB is fully functional. On one of mine I have a USB stick with extroot on it.

828

Re: Tp-link Tl-wr703n

I have got a strange problem with VPN on OpenWRT on WDR4310 / 703n, this is the new post:
https://forum.openwrt.org/viewtopic.php?id=39084

anyone can help?

Re: Tp-link Tl-wr703n

Hello,
I have a TL-WR703N and I'm using a USB 3G modem as wan connection. The connection works fine on the WR703N itself, I can ping from the router and install packages with opkg and so on. But the connection is not working on a computer connected to the WR703N, it won't get any internet connection. If I plug an ethernet cable from my adsl modem to the ethernet port on the WR703N, the pc gets the internet connection from the adsl modem, while I would like it to use the 3G modem.

here is my /etc/config/network:

root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option type 'bridge'
        option ifname 'eth0'
        option proto 'static'
        option ipaddr '192.168.1.3'
        option netmask '255.255.255.0'

config interface 'wan'
        option proto '3g'
        option device '/dev/ttyUSB0'
        option service 'umts'
        option apn 'internet'
        option pincode '1234'

Re: Tp-link Tl-wr703n

Is that a firewall issue? Do you have Luci running on it? It is quicker to sanity check via that than cat-ing all the config files.

Re: Tp-link Tl-wr703n

robthebrew wrote:

Is that a firewall issue? Do you have Luci running on it? It is quicker to sanity check via that than cat-ing all the config files.

I have a similar but maybe simpler problem.  I want to set the 703n as a router.  With the eth0 as wan and wifi lan.  When I set it up, the notebook on the lan cannot access the internet.  I changed firewall "randomly" and eventually it worked.  My question is, what will be the right (standard?) setup for this to work?  Either sample firewall config file or Luci configuration, i.e., what should be enabled/accepted or rejected, would be fine.

832

Re: Tp-link Tl-wr703n

Remove the option ifname eth0 from the lan interface (or untick the eth0 checkbox from luci - best done via wifi), create a new interface called "wan", put eth0 into it and configure as needed (static, dhcp, pppoe, ...)

Re: Tp-link Tl-wr703n

jow wrote:

Remove the option ifname eth0 from the lan interface (or untick the eth0 checkbox from luci - best done via wifi), create a new interface called "wan", put eth0 into it and configure as needed (static, dhcp, pppoe, ...)

Actually, that was I first did and it didn't work immediately.  I mess around with firewall setting in luci then it works.  The current firewall setting are:
General setting: Input, Output, Forward are all "Accept"
Zones => forwarding: lan=>wan: Input: accept, output:accept, forward: reject, both Masquerading/MSS clamping unchecked.
                             wan=>lan:  Input: accept, output:accept, forward: reject, both Masquerading/MSS clamping checked.
Do these look like?
They were working yesterday but no longer today.  Is there anything I need to set up or change?

Re: Tp-link Tl-wr703n

janisalnis wrote:

It looks like firewall issue. Check this similar example where router connects to a wifi network and transfers internet connection to eth0:
https://www.dropbox.com/s/g2odecowjbpfb … 20eth0.txt
I had to remove line "... bridge". Configure two independent networks and enable firewall between them.
If it stops working after some day, please check if the files are still looking ok or may be need to reflash.

Thanks.  But I cannot find the file there.  Can you check the web address?

Re: Tp-link Tl-wr703n

janisalnis wrote:
twinclouds wrote:

Thanks.  But I cannot find the file there.  Can you check the web address?

Sorry it is here
https://www.dropbox.com/s/xm3t3sep4ev4b … 20eth0.txt

Thanks.
I eventually made it work but still don't know why.  I used the exact same set up before that didn't work.  As a result, I am not sure what is really the cause and the right configuration.  This is scary.

836 (edited by twinclouds 2012-09-06 20:55:45)

Re: Tp-link Tl-wr703n

I like 703n a lot.  The only issue I had was it has only one ethernet port.  If it is used as wan port then I cannot connect any other device to it besides using wifi.  Recently, I tried usb to ethernet adaptors.  Some of them didn't work but the last one worked.  It is Asix chip based and all you need to do is to install the kmod-usb-net-asix package and extend the bridge to cover it in addition to wifi.  I think now it has all(?) of the router functionality of wr-720 and and more.  Pretty happy about it.

837 (edited by fpopic 2012-09-10 22:10:00)

Re: Tp-link Tl-wr703n

my 2GB SanDisk FAT32 formated SD card (i tried with ext4 too) is not recognized in OpenWRT, only card reader is shown but 2GB of memory is not accessable

sd/mmc/rs-mmc usb 2.0 reader bought from ebay (http://goo.gl/8darL) it works in linux (ubuntu 12,04 and backtrack5r3)


I have installed:
block-mount
kmod-fs-vfat
kmod-mmc
kmod-usb-core
kmod-usb-storage
kmod-usb-storage-extras
kmod-usb2
kmod-scsi-generic
kmod-nls-utf8

kernel log:

[17844.250000] usb 1-1: new full-speed USB device number 2 using ehci-platform
[17844.410000] scsi0 : usb-storage 1-1:1.0
[17845.410000] scsi 0:0:0:0: Direct-Access     USB2.0   CARD-READER      1.01 PQ: 0 ANSI: 2
[17845.420000] sd 0:0:0:0: Attached scsi generic sg0 type 0
[17845.440000] sd 0:0:0:0: [sda] Attached SCSI removable disk


Firmware Version     OpenWrt Attitude Adjustment r33288 /LuCI Trunk (trunk+svn9190)
Kernel Version           3.3.8


I found troubleshooting at http://wiki.openwrt.org/doc/howto/usb.essentials
but I don't know where have I to add max_scsi_luns=8 bit cause my etc/modules.d/60-usb-storage file shows only this
"usb-storage" after editing :

"usb storage"


i found the problem was with file names

FAT: codepage cp437 not found

means that you need NLS codepage 437, and a message like

FAT: IO charset iso8859-1 not found

means that you need NLS ISO 8859-1.

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

838 (edited by fpopic 2012-09-10 08:59:28)

Re: Tp-link Tl-wr703n

i have 8mb flash on it with 2.5mb free
i changed formatting to ext4 and now everything works fine but with other usb stick (that reader just don't want to work)
and i always wanted to add umask=000 to ext4 which is important only for ext4 systems.


------------------------------------------------------------------------------------------------------------

until my 12v+5v power supply + usb to sata for my old 40gb arrives i want to free some space

i use transmission as bittorent  with it's transmission-web interface which is located at

/usr/share/transmission/web

i copied that folder and put it to my mounted usb stick (working) at

/mnt/storage/transmission/web

how can i tell transmission to use new interface place instead of the default which i will remove

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

839

Re: Tp-link Tl-wr703n

have you isntalled the

kmod-fs-vfat or something called?


I had to install


opkg update
opkg install kmod-usb2
opkg install kmod-usb-storage

and

opkg install kmod-fs-ext4 

for my filesystem formatted ext3 usb-stick.

840 (edited by fpopic 2012-09-12 09:27:12)

Re: Tp-link Tl-wr703n

yeah i installed everything of kmod for usb/mmc/storage/extras it's probably something with SCSI


can you help me about transmission ?

will that work ?

ln -s /usr/share/transmission/web /mnt/storage/transmission/web;


i want that transmission only works if the usb (/mnt/storage) is mounted (i put web directory to /mnt/storage/transmission/web) and removed the original one from /usr/....
because i want to prevent transmission-web if the external storage isn't mounted well cause i don't want to store torrent files on router's flash memory

any other suggestion ?


---------------------------------------------------------------------------------------------------------

Why can't i copy files from my PC to a network sharing folder on usb which is 1,8/2gb free

http://i50.tinypic.com/p4pi9.png



    chmod -R 777 /mnt
    chown -R nobody /mnt

http://4.bp.blogspot.com/-wauQcolD_kY/UE4eim-uE9I/AAAAAAAAAZ4/OfHctvQX2nA/s400/shared.png

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

fpopic you have ln the wrong way round:
ln -s /home/simon/demo /home/jules/mylink3   #Create mylink3 pointing to demo

rm  /usr/share/transmission/web
ln -s  /mnt/storage/transmission/web  /usr/share/transmission/web
now  /usr/share/transmission/web is the soft link to where you want.

Re: Tp-link Tl-wr703n

janisalnis, do you have luci? I haven't backed up yet ( yikes) but I think you can do it easily through luci

Re: Tp-link Tl-wr703n

ok thanks i will try

janisalnis : Luci -> System -> Backup / Flash Firmware

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

Oh, fpopic, you will get a read/write error if /mnt etc is not mounted, so you might want some error handling code wrapper.

845 (edited by fpopic 2012-09-13 15:28:25)

Re: Tp-link Tl-wr703n

i done your script for linking new folder for transmission web.
can i now remove      transmission-web     2.61-1 package from software tab or ?


----------------------------------------------------


hmm i think that's what i wanted cause i want that transmission doesn't work if drive is not mounted
something like that but to disable downloading/saving files when not mounted

wiki openwrt usb storage :
Disable writing when not mounted

You may create an empty file to indicate that the disk is not plugged in so that you don't put files directly onto NAND by doing

touch /mnt/usbstorage/USB_DISK_NOT_PRESENT
chmod 444 /mnt/usbstorage -R

This will prevent only processes not running as root from writing onto NAND. You can of course also use this file in your own scripts.

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

Re: Tp-link Tl-wr703n

No IMO, you still need the transmission executables. But you need to somehow cleanly exit with a (error) response when the file system is not mounted.
To be fair, I don't know transmission or it's commands, but there must be an error code given (to stdout or stderror?) when the filesystem is not there. If you can hook into that then you just say if (error) do (complain to whoever).

Re: Tp-link Tl-wr703n

Has anybody using a USB 3G modem connected to TL-WR703N noticed that the led on the 3G modem would be flickering? Not blinking like when it is not connected, but flickering really fast, many times per second? I guess that it is some power issue, but is it avoidable in some way? It happens both when the modem is connected directly, and with a usb hub. It is not flickering if I use a powered usb hub, but then I will loose the option to control power to the usb port from software (gpio8), and I really need that. I already soldered a 330uF capacitor on the power line in the hub, but it didn't help. Is there any danger with it, as everything anyway works fine? I feel that the lifetime of the modem maybe will be shorter if it's flickering.. I've tried with Huawei E230 and E160E.

Re: Tp-link Tl-wr703n

janisalnis wrote:

Luci backs up only settings like network, but not the modules installed.
If I want to make several identical routers then I would need to use dd. Something like
dd if=/dev/mtdblock0 > /tmp/0.bin
dd if=/dev/mtdblock1 > /tmp/1.bin
dd if=/dev/mtdblock2 > /tmp/2.bin
dd if=/dev/mtdblock3 > /tmp/3.bin
dd if=/dev/mtdblock4 > /tmp/4.bin
dd if=/dev/mtdblock5 > /tmp/5.bin
Then question is how to flash it back and which parts.

maybe this can help you to identify parts :
MTD

cat /proc/mtd

dev:    size   erasesize  name
mtd0: 00020000 00010000 "u-boot"
mtd1: 000d9fa8 00010000 "kernel"
mtd2: 002f6058 00010000 "rootfs"
mtd3: 000f0000 00010000 "rootfs_data"
mtd4: 00010000 00010000 "art"
mtd5: 003d0000 00010000 "firmware"

TP-Link TL-WR703N 8Mb/64Mb WWW.TL-WR703N.BLOGSPOT.COM (8Mb/64Mb/SMA/EXTRoom/USB-Hub/TTL)

849

Re: Tp-link Tl-wr703n

thank you twinclouds for help on mounting usb flash.
i did not know it can be mounted right on /

I have one more unit which has been converted to english mr3020 firmware .
I am looking for advice how to flash openwrt on it.
For conversion  followed this thread:
https://forum.openwrt.org/viewtopic.php?id=36596
Now I want to flash openwrt over this modded TP-LINK firmware but I am not sure whether author's "restore back firmware" creates any problems.
Unfortunately author does not respond.
In summary :
He posted a program which takes TP-Link firmware and modifies it for WR703n.
I am able to use his program one way only chinese->english.
When I use other way to make "revert" firmware it does not match his "revert" firmware.

What are my options to flash such converted wr703n ?
Should I be worried about bricking device ?

Anyone please ? :-)

Re: Tp-link Tl-wr703n

etan wrote:

thank you twinclouds for help on mounting usb flash.
i did not know it can be mounted right on /
.....

You are welcome.  I don't remember when I gave such suggestions, but I must did, however, if you said so smile