Re: Tp-Link td-w8970

I have recently flashed and tested the two precompiled images which are linked here:
1. http://ecco.selfip.net/trunk/lantiq/
2. https://drive.google.com/folderview?id= … sp=sharing

Everything worked as expected except my DSL (PPPoA) connection works only with the first image.
Although there is some additional bin image for the DSL driver in the Google-Drive folder, I'm not quite sure how to flash it or include it into my own build. I already compiled a working image from trunk, but with the same problem mentioned above.

So can anyone tell me please how to compile an image from latest sources with working ADSL?

thx in advance

27 (edited by openwrtuserx 2014-02-07 11:34:35)

Re: Tp-Link td-w8970

Finally I managed to solve this problem myself. I thought it would require a rather complex solution, but it wasn't that difficult in the end. I only had to include the DSL firmware image into the buildroot (/lib/firmware/vdsl.bin).

I didn't get that in the first place as I'm quite new to OpenWRT wink

Re: Tp-Link td-w8970

Hi All, can one of you tell me if the average ping time is the same with openwrt as the vendor firmware on this W8970.

Re: Tp-Link td-w8970

Hi all, hi lpm11

lpm11 wrote:

"Firstly - DO NOT upgrade to the 28.08.2013 (or newer) firmware on TP-Link website. It has modified u-boot, and applies a NEW UNKNOWN header - first byte is 0x03. We don't know how is it working. " - this is the problem. TP-Link introduced a new format of image files. It is diffrent than in other TP-Link firmwares, so that is the reason we can't do the correct image file, upgradable by http.

Is my understanding right, that it is basically possible to install OpenWrt via the web interface, as long the firmware is not upgraded to the version of 28.8.2013 or newer ? (mine is 0.6.0 2.1 v000c.0 Build 130415 Rel.34164n).

I tried to install the available openwrt images via the stock web interface with no success. (openwrt-lantiq-xrx200-TDW8970-sysupgrade.image, openwrt-lantiq-xrx200-TDW8970-sysupgrade_v39435.image and openwrt-lantiq-xrx200-TDW8970-sysupgrade_v39586_EXPERIMENTAL_usb3.image). With all of them I get the following error:

Error code: 4503
The uploaded file was not accepted by the device.

Am I missing something here or is serial access (soldering) and deploying the image via tftboot also necessary with the old firmware version?

If there are no compatible (http-installable) images available on the web, can anyone give me some short hints on how to build one on my own?

30 (edited by toni.perez.figols 2014-04-06 11:14:04)

Re: Tp-Link td-w8970

Well, it's safe to upgrade to OpenWRT or has comlts problems?

openwrtuserx, which is the process to install openwrt?

Re: Tp-Link td-w8970

Hi RyLoS,

Thanks for your compiled image.  it worked good for me.  One question, is the latest one contain the switch support?.

Re: Tp-Link td-w8970

Hi openwrtuserx;

How to add dsl module? And How to install firmware 2. https://drive.google.com/folderview?id= … p=sharing?

Re: Tp-Link td-w8970

Exist web image to install via web interface? Please can I help me?

Re: Tp-Link td-w8970

Hi, I have bought this modem to complete my network 1043nd, 740nd, 842n network. But mine came with 0.6.0 2.8 v000c.0 Build 130828 Rel.38099n firmware.

So is there a way to downgrade this firmware version or am i stuck with a non-openwrtable modem.

Re: Tp-Link td-w8970

good afternoon

you can upgrade to this firmware if you have the last upgrade of tplink?

0.6.0 Build 130828 2.8 v000c.0 Rel.38099n is my firmware and hard TD-W8970 v1 00000000

36 (edited by nebbia88 2014-05-10 13:56:24)

Re: Tp-Link td-w8970

at the moment you could only upgrade via TTL serial connection and uboot.

new tplink firmware header is unknown AFAIK

Re: Tp-Link td-w8970

thanks nebbia88   for replying

which is the correct procedure? and firmware?


regards

Re: Tp-Link td-w8970

did you read page 1 of this topic?

Re: Tp-Link td-w8970

I have problem witch ADSL synchronization on my W8970

root@OpenWrt:/etc/init.d# ./dsl_control lucistat
local dsl={}
dsl.chipset="Lantiq-VRx n"
dsl.line_state_num=0xff
dsl.line_state_detail="idle request"
dsl.line_state="DOWN"
dsl.data_rate_down=0
dsl.data_rate_up=0
dsl.data_rate_down_s="0 b"
dsl.data_rate_up_s="0 b"
dsl.line_attenuation_down=0.0
dsl.line_attenuation_up=0.0
dsl.noise_margin_down=0.0
dsl.noise_margin_up=0.0
dsl.line_uptime=0
return dsl 

WAN configuration:

config atm-bridge 'atm'
    option vpi '0'
    option vci '35'
    option payload 'bridged'
    option encaps 'vc'

config interface 'wan'
    option ifname 'nas0'
    option proto 'pppoa'
    option username 'internet'
    option password 'internet'
    option encaps 'vc'
    option vpi '0'
    option vci '35'
    option ipv6 '1'
    option macaddr 'a0:f3:c1:ff:9f:83'

config interface 'wan6'
    option ifname '@wan'
    option proto 'dhcpv6'

config vdsl 'dsl'
    option annex 'a'
    option firmware '/lib/firmware/vdsl.bin'
    option tone 'av'
    option xfer_mode 'ptm'

Any suggestions?

Re: Tp-Link td-w8970

lpm11 wrote:

Could you help me to connect UART to this modem? I have connected TX,RX,GND, diodes are lighting on USB TTL adapter, but nothing appears on console sad( The same in other modem shows everything. What's going on?

Hi there!

I managed to solder connection pins to the board and connect a CP2102 based usb2serial adapter. I'm trying to connect to the console after powering up the board (using "screen /dev/ttyUSB0 115200 8N1" or CuteCom). As mentioned by lpm11 also in my case nothing appears on the screen. The RX diode is blinking on the usb adapter while the device boots. When I send an input through the console, the TX diode is blinking, but again nothing to see. From the blinking diodes I conclude the connection should be right. What else can be wrong?

I don't have an opportunity currently to test the adapter with a different router, but it seems ok to me. Am I missing something? It's my first time, any hints would be very welcome. btw, I also had connected the 3,3V voltage pin in the beginning, hope I didn't fry anything but so far the route is still working ..

Re: Tp-Link td-w8970

I am using the TP-Link W8970 for an Airtel ADSL connection in India currently. It is working fine.

I am switching to a Tata Docomo connection which provides connecting via an ethernet cable. Is it possible to use PPPoE via the WAN port of the router? Is there a firmware which will enable me to achieve this?

Any help is greatly appreciated.

VS228

42 (edited by Jabberwocky 2014-06-22 01:18:51)

Re: Tp-Link td-w8970

OK, first at all, comppletly newbie to OPENWRT... smile

I screw up updating to TD-W8970_V1_140613, I was having freezing issues every day and support  tells me to try new firmware, again the same crap, still freezing once a day.
There is a way to test OPENWRT via serial console in my version?? I know that this mew version have someting unknow but is still posible use OPENWRT ???

If not I'll use a nice paperweights in my desk smile

Best regard

Re: Tp-Link td-w8970

if you flash from serial then your current firmware does not make any difference.

Re: Tp-Link td-w8970

Hello!

I have a

Firmware Version:0.6.0 2.5 v000d.0 Build 140320 Rel.67818n
Hardware Version:TD-W8970B v1 00000000

on my Desk. Is this the same hardware as this (http://wiki.openwrt.org/toh/tp-link/td-w8970) one?

In case it is I think I can only flash to OpenWrt with TTL serial, right?

Re: Tp-Link td-w8970

VS228 wrote:

I am using the TP-Link W8970 for an Airtel ADSL connection in India currently. It is working fine.

I am switching to a Tata Docomo connection which provides connecting via an ethernet cable. Is it possible to use PPPoE via the WAN port of the router? Is there a firmware which will enable me to achieve this?

Any help is greatly appreciated.

VS228

Afaik you only have to turn the device to another mode. Should not be the problem with the original firmware.

Re: Tp-Link td-w8970

Any progress?

Re: Tp-Link td-w8970

Hi there,

i'm using an w8970 Router, and I am very happy with your work on the OpenWRT-Firmware!
Now I have a question. Is there a Firmware or a driver to use the internal switch for routing?
I have read someting about it on an other website, but the link to the driver was down..
Has somebody experience with using the internal switch for routing/different vlans?
I would be happy about all info i can get!

regards Sigma

48 (edited by JinInRage 2014-08-24 03:35:57)

Re: Tp-Link td-w8970

Hey guys,

I got the same problem...
Nothing appears on the screen.But the connection is ok because I can stop booting but when I want to load the firmware by tftp nothing happens.I captured the network with wireshark... The router doesn't send any requests sad
I've got the W8970B with the first firmware TD-W8970B_V1_130918.What can I do ? I want OpenWRT sad(
Are the B-firmwares the problem ? If yes, can I install a non-B firmware ??

Regards Matt

EDIT: What about JTAG ?? Does anybody know if i can install OpenWRT over JTAG ?

Re: Tp-Link td-w8970

Hi JinInRage,
i don't know if i can help you, but i will try.

Is your TFTP-Server running on a windows system?
I had also problems with TFTP under windows... After I used a TFTP-server on a linux-system it has worked perfect for me...
Perhaps this is the solution you are searching for.

kind regrads

Re: Tp-Link td-w8970

Yes it's running on windows.
Ok I will try and hope it works...

Regards Matt