Zyxel NSA325 v2 installing (no usb, no ide, no egiga0)

I was not able to get the usb or network connection working with the default marvell uboot. So I ended up using putting the openwrt files on ide 0:1 writing u-boot.kwd with these commands

Marvell>>
ide reset
ide info
ide part 0
fatls ide 0:1

fatload ide 0:1 0x1000000 u-boot.kwb
nand erase 0x0 0x100000
nand write 0x1000000 0x00000 0x100000
reset


setenv mtdparts 'mtdparts=orion_nand:0x00c0000(uboot),0x80000(uboot_env),0x7ec0000(ubi)'
setenv bootcmd 'run setenv bootargs; ubi part ubi; ubi read 0x800000 kernel; bootm 0x800000'
saveenv
reset

setenv ethaddr xx:xx:xx:xx:xx:xx
saveenv

However after booting with the new uboot of openwrt I am getting the NSA325> prompt.
But usb is not working

NSA325> usb reset
resetting USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... EHCI timed out on TD - token=0x80008d80
EHCI timed out on TD - token=0x80008c80
EHCI timed out on TD - token=0x80008c80
EHCI timed out on TD - token=0x80008c80
 ERROR: NOT USB_CONFIG_DESC 50
EHCI timed out on TD - token=0x80008d80
EHCI timed out on TD - token=0x80008c80
EHCI timed out on TD - token=0x80008c80
2 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found

sata access is not available

NSA325> ide reset
Unknown command 'ide' - try 'help'
NSA325> scsi reset
Unknown command 'scsi' - try 'help'

And network connection freezes the nas device

NSA325> dhcp
BOOTP broadcast 1

What to do now?

I think it would have been better to burn both files at once without the reset. Maybe change this manual.

https://openwrt.org/toh/zyxel/nsa325

Did you resolve your issue ? it is better to use uboot from openwrt 18.06. The rest can be from snapshoot or 19.07

Yes, thought to try this solved it
uploading the previous version of u-boot.kwb via terminal / minicom

loady 0x1000000
nand erase 0x0 0x100000
nand write 0x1000000 0x00000 0x100000
reset

I was using the installation guide on the wiki for this device and ran into the same problem. This was the first time, I installed OpenWrt on a device. Using kwboot from this forum https://forum.doozan.com/index.php I was able to transfer a working u-boot.rwb and recover the device.I was using the u-boot from the doozan forum.

I added a note to the installation guide, so others don't run into the same problem.

After fixing this, my system still did not boot and complained about an error with "setenv" from this command:

setenv bootcmd 'run setenv bootargs; ubi part ubi; ubi read 0x800000 kernel; bootm 0x800000'

After removing 'run setenv bootargs;' I finally got it booting. As I'm new to the world of u-boot, I can only make guesses. But it seems the guide has an error here, but I've no idea what could have been the intention for this. Perhaps someone with more knowledge can fix this.

I'm trying to install OpenWrt to my Zyxel NSA325 v2 device. But as it said the usb is not working so I try to use the hard disks for loading uboot. On which partition format will the disk need to be on? I tried Fat32 but without any luck. Any suggestions? I'm still on the default device uboot, but I have downloaded the uboot of version 18 to be installed.

Usb to working as in broken, or not detected by uboot?

usb is not detected in uboot. Tried a couple of usb devices non of them worked. But now I have fomatted my disk to fat32 and now the uboot finds my device. Just flashed uboot. But can I now reset or is it better to set variables and flash openwrt without reset?

Follow the wiki page, but resetting shouldn't really make any difference.

Thanks. Just flashed Openwrt without any issue. First I loaded the uboot using ide. After the first reset did all sets all the variables like in the wiki and after that I flashed the Openwrt binaries using the usb device.

Hi, i have a question. I installed openwrt on the device immediately. I can get a maximum speed of 500 Mbps, with samba. How was the speed in the stock firmware of the device I have never tested. I wonder if this is the maximum power of this device? Or was it giving more speed in stock software?

On the official stock firmware I got a speed of 150 MBps with my disks. On OpenWrt I only get around 30MBps. I configured mdadm to raid1 over two disks and ext4 filesystem on the raid array.
I'm trying to find a solution for the slow speed but cannot find it yet.

@altuntepe how did you get so high samba speed? What is your configuration?

Do something like this, to see if the performance issue's with the disks/RAID, or Samba.

[frollic@atlantis] $ dd if=largefile.bin of=/dev/null bs=8k
655360+1 records in
655360+1 records out
5368709152 bytes (5.4 GB, 5.0 GiB) copied, 6.11677 s, 878 MB/s

Here is a benchmark of the stock firmware:
https://www.smallnetbuilder.com/archives/nas/nas-reviews/31906-zyxel-nsa325-2-bay-power-plus-media-server-reviewed?showall=&start=4
500Mbps doesn't seem bad, depends on what you were actually measuring

That is impossibe, as it's a bit above the theoretical max, 1Gbps.

Maybe it was indeed around 125MB/s.

I use a device with a Celeron 3865u processor as a router. With the hdd on the router, I can get 1 gigabit at samba speed. But in NSA325 I can get a maximum speed of 500 mbit. I haven't made any special settings. Standard setup, standard samba settings. I'm using smb1 as the only custom setting. I don't know if smb2 smb3 does not work on windows, or I couldn't run it.

Could it be that I couldn't get gigabit speed from the NSA325 because I was connected through the router? I am inexperienced in these matters too.



depends on how you were connected through the router.

Did you configure any raid setup on the NSA325? Or do you share the raw disk over samba?

That Celeron is not really comparable with the Armv5 chip in the ZyXEL. It is much more powerful, and it offloads minor responsibilities like sata and network to the chipset. The SoC in the ZyXEL has to do everything itself, and is maxing out on CPU. You can see that if you run 'top' om the ZyXEL during the copy. AFAIK the ZyXEL will never saturate the Gbit port. When I remember well it even doesn't with synthesized performance tests like
dd if=/dev/zero bs=16M | nc -l -p 5000

I don't know what you mean, I directly connected the Ethernet cable from NSA325 to the router. Connected with static IP. Is there any other way better tying method?

@jimmyd-be
I'm using a single disk, 6TB in size. I formatted it as ext4. In addition, I did not do anything else. There is a 500GB 2.5 inch disk on the router. In addition to the router, Transmission torrent client is installed and saves to this disk. I transfer it to the Zyxel device from there. I wish I could save it directly into the zyxel NSA325 but I don't know how to set it up. I don't want to install Transmission on NSA325 because I don't want to force more, just Samba.