Zyxel NBG6817 - eth0 and eth1 MAC addresses changes randomly

Hi,

I saw that with every restart of my OpenWRT router my windows laptop detects a new network and I have to select if it is a public or private one. Now I found the issue...

The MAC addresses of the devices changes randomly. Any suggestions what is the best practice to have stable MACs? I am not sure if it is a OpenWRT bug or what is best practice to have a fixed MAC for every device...or bridges? From my point of view it is not helpful if this happens after every reboot.

My setup:
ZyXEL NBG6817
OpenWrt 21.02.3 r16554 (tested also 21.03.0)



config interface 'loopback'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'
        option device 'lo'

config globals 'globals'
        option ula_prefix 'fd11:b2f0:a80f::/48'

config interface 'lan'
        option proto 'static'
        option netmask '255.255.255.0'
        option ip6assign '60'
        option ipaddr '192.168.177.1'
        option device 'br-lan'

config interface 'wan'
        option proto 'dhcp'
        option broadcast '1'
        option delegate '0'
        option device 'eth0.2'

config interface 'wan6'
        option proto 'dhcpv6'
        option reqprefix 'auto'
        option reqaddress 'try'
        option device 'eth0.2'
        option auto '0'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option vid '1'
        option ports '2 3 4 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0t 5'
        option vid '2'

config interface 'VPN'
        option device 'tap_vpn'
        option proto 'none'

config route
        option netmask '255.255.255.0'
        option target '192.168.178.0'
        option interface 'lan'
        option gateway '192.168.177.6'

config interface 'IoT'
        option proto 'static'
        option ipaddr '192.168.175.1'
        option netmask '255.255.255.0'
        option device 'br-iot'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth1.1'
        list ports 'tap_vpn'

config switch_vlan
        option device 'switch0'
        option vlan '3'
        option ports '1 6t'
        option vid '3'

config route
        option interface 'lan'
        option target '192.168.180.0'
        option netmask '255.255.255.0'
        option gateway '192.168.177.6'

config interface 'ELLERAU'
        option device 'vpn_ellerau'
        option proto 'dhcp'

config device
        option type 'bridge'
        option name 'br-iot'
        list ports 'eth1.3'

config interface 'GUEST'
        option proto 'static'
        option ipaddr '192.168.176.1'
        option netmask '255.255.255.0'
        option device 'br-guest'

config device
        option type 'bridge'
        option name 'br-guest'
        option bridge_empty '1'

Still found some posts but not a final solution...

Should be solved... How to get fixed mac for LAN with DIR-860L - #8 by Enig123