Zyxel NBG6617 still broken

Hello folks,

I apologize in advance for creating a new topic but I wasn't able to respond to the existing closed thread [[SOLVED] ZyXEL NBG6617 - TFTP flash wont take] regarding NBG6617 install. @chunkeey already referenced a commit that should fix the image build but when I attempted today I was still unsuccessful (tried both TFTP and web upload from both mentioned Zyxel's firmware versions). As the build log page is currently unavailable (most likely due to LEDE megrer) and I currently have no time to re-setup my build environment can I ask someone ( @Notfast112 or David Bauer) to send their working ones please?


It works in ZyXEL web gui and with tftp

Then you can upgrade using latest snapshot (remember no luci - so install it youself after upgrade)

Fails with ImageBuilder, can't find ipq-wifi-zyxel_nbg6617 package.

make image PROFILE=zyxel_nbg6617

Output of command:

 * opkg_install_cmd: Cannot install package ipq-wifi-zyxel_nbg6617.
Makefile:149: recipe for target 'package_install' failed
make[2]: *** [package_install] Error 255
Makefile:108: recipe for target '_call_image' failed
make[1]: *** [_call_image] Error 2
Makefile:192: recipe for target 'image' failed
make: *** [image] Error 2

what command is on buildbot, that it succeeded to build image?

Great, thanks @Notfash112 ! Worked on first attempt with no problem! Hoping to get the build fixed soon so it'll be easier to access all the kernel modules from snapshot. Will mark this one solved once the build gets fixed well.

Notfast112 :wink:
Perfect you got it going

Hello. I would like to ask, what is the recommended way of flashing OpenWrt on NBG6617 as of today?

1 Like

Well, the factory.bin images should work since.

So, for current master/snapshot builds, you should be able to download the latest factory.bin file from the downloads.openwrt.org site and flash it through the router's stock firmware webinterface or tftp recovery.

Thank you, will try.

hello, trying to install luci on zyxel6617 last snapshot on. i do opkg update && opkg install luci-ssl-openssl, and i get the error missing dependencies liblua5.1.5 so i install liblua, i try to reinstall luci and i get the same error. how install luci please?

You only have ~24 hours to install most packages needed for a snapshot. Upgrade your snapshot and then install the packages to solve your issue.

1 Like

thanks i resolved doing --force-depends,but now i have other problems, is wds working on 5ghz? this zyxel6617 is a bit harder for me.

1 Like

Does anyone know when we can expect this device to become an official target in the build tree and have long term package feed support?

You may want to ask in the developer email list.

Since it's in snapshot, it likely won't be until version 19.

I have 1 month old snapshot and I am experiencing random freezes where device suddenly stops responding even to ping. It can happen once every few days or 3 times an hour, I see no pattern.

I tried leaving logread -f open over ssh but I see nothing suspicious there up to the time it freezes.

I am now trying a dfferent power supply to see if that helps.

Next step I will try upgrading to latest snapshot.

Does anyone know how else I could try to troubleshoot this?

Does anyone have a snapshot image that works stable with this device?

I been using a very old one (this old file)

No problem - is has just been working for over one year.

Just updatede to day to lasted snapshort - I hope it works with out problems.