Zte zxhn h369a


I got ZTE ZXHN H369A, there is no much information about it on Openwrt or other sources except some information on Tech Info Depot, You can check this link for basic information, but it does not have info about CPU, WLAN / Eth Chips, RAM, Flash, etc.

So, I opened the case and her below the additional information I have so far:

CPU: Broadcom BCM63138 VKFSBG
RAM: 512MB - NANYA DDR3L 1625 NT5CC256M16DP-DI 616589WDEF 3 TW (Memory Word = 16)
Flash: 512MB - Micron NAND 29F4G08ABADA WP
Bootloader: CFE (I guess)

There is Serial pins already so no soldering is needed.
Such serial pins can be found behind the USB port, the one close to the two green PSTN ports.

I connected the serial to the laptop, but only the following was shown:


I do not know why there is no more boot logs shown, is it because of bootloader security feature or something else??!!

Here below the fotos I took for the router.

Uh, another Broadcom-based device...
According to this (i don't know if this page is up-to-date) , this SoC ist still not supported in OpenWrt.
And considering the lack of open source drivers for Broadcom chips, i don't know if it's a good idea to spend too much time with devices like these...

Well, that's just my humble opinion.

I know the issue with Broadcom,

My main issue at the moment is: why I do not get boot-loader logs? what is the problem? Any Idea?

No, sorry no idea from my side.

If i remember right, i think i've seen something like this some years ago on a Broadcom-based set-top-box.
My guess is, they just disabled the normal boot messages or send them straight to /dev/nul.

Just found this one.
It seems, that's the typical Broadcom boot log
I was missing the part where there were additional boot messages on other devices, an none on this one...
Either a "security" measure (to secure their intellectual property?) or just "You do not need to know this".

That is also my guess, especially the same problem happens on ZXHN H368N router I have.

In the beginning; I thought it was a serial-TTL cable issue, but when I changed the cable, the problem still there. So it is not a cable issue. I guess they made something with boot-loader security.

The boot-loader is CFE (I think) not U-Boot!

EDIT (1):
Now I am sure it is CFE boot-loader. What I did is I turned off the router then pressed Reset button at start-up for 6 seconds. the router has very tiny webserver in this case (micro_httpd), with telnet to the router on port 80 I got the following

it is clear that it is CFE based bootloader router.

also, when the router is in this mode, you can try on web-browser but it asked for username and password which are unknown. I tried many combinations of username/password but in vain :frowning: