ZTE ZXHN H298A - Hyperoptic Branded

Hi,

I got this ZTE ZXHN H298A router through Hyperoptic. This router is quite peculiar in the way that the OS is completely locked down by Hyperoptic. However the same router is being used by other providers like rostel (russia). I came across the full firmware at 4pda. (happy to share link, unsure about policies as posting first time).

I tried lots of different ways but couldn't get the stock or other firmware on it, so I decided to open the router up and figured out the serial port using my multimeter and checking voltages etc. I plugged in my UART adapter and got the boot sequence and 3 different modes i.e. boot mode (aka bootloader mode), test mode and normal mode.

I have attached all the logs and also the images of the board.

I was wondering if this can be supported by any openwrt release or if anyone has access to alternate firmware.
As you might observe from the logs, I tried all usual login creds but none of those worked.

In bootloader mode, the router lets you start a mini web server, (i have attached screenshot) and using that firmware can be uploaded.

Any help will be greatly appreciated.

I have uploaded all the images via. imgur: https://imgur.com/a/ePDOlyO

Logs attached as well via. pastebin:
Bootloader mode - https://pastebin.com/pCPt7W3X

I am unable to post the normal mode and test mode as a new user, I will add it as a comment if I can.

Thanks, any help is appreciated.

Normal Mode - https://pastebin.com/38ZXeTJH
Test Mode - https://pastebin.com/BMppR7rQ

Here is the 4PDA forum: - https://4pda.ru/forum/index.php?showtopic=893490&st=20