Zerotier will not connect

I have been trying to setup an zerotier tunnel on one of my OpenWrt test devices (Archer C6 V3 running 23.05.0) but to no avail. I have followed the guides here and here. When create the tunnel, enter my NetworkID, enable the tunnel, commit and restart nothing happens. Running zerotier-cli info I get:

zerotier-cli: missing port and zerotier-one.port not found in /var/lib/zerotier-one

Also checking with ip a the zt interface is not listed. I downgraded to 22.03.0 and still get the same issue. Also, tried to setup zerotier in a 3200acm and a dlink853 (both on 23.05.0) but again run into the same issue. I also tried to manually start the tunnel with zerotier-one -d and then zerotier-cli join "NetworkID" which naturally makes zerotier-cli info say ONLINE but there is still no connection to ZT and the zt interface is not showing up.

I appreciate any thoughts.

Zerotier is usually rather bust-proof. After configuring the network number and restarting Zerotier, if the router is online you should see the new client in the list of member nodes on your Zerotier Central network page. There will be a red line on the left side since it is not authorized until you check the box next to the red line. (a few seconds after that, the line should turn green) I don't know how much a client will do locally until it has been authorized by checking the box.

Hi @mk24. Thank you for your input. The problem I am facing is that after configuring the network number and restarting ZeroTier, the router never shows up as a device on the ZeroTier Central page for me to authorize it.

Maybe it's from trying to start more than one instance of the zerotier program? Make sure your /etc/config/zerotier contains only one instance, with enabled 1, network number(s), and a secret. (One instance can connect to multiple networks and will spawn multiple interfaces.)

1 Like