ZBT WG3526 Wrong Ram Size and WIFI issue


I have ZBT WG3526 router with 16M Flash dan 512 M RAM. Now, I am using the Rooter GoldenOrb (base on OpenWRT 21.02) firmware. Since OpenWRT 18 which split the firmware to 16M and 32M, the RAM Size is reduce to 128M. When I was using the LEDE 17 firmware the RAM size was 512M
How to recover to correct RAM size. Thanks!

Also How is the state of Wifi in this device? I cannot get it to work? Is mt76 driver still broken for WG3526?

This router should have radio0 (MT7603) and radio1(MT7613). It only get one and it is not working correctly (very low transmit power).

If you're using R00ter, ask the R00ter people?


Thanks for the reply!

Well, I have tried several version of OpenWRT firmware before from:

And Last I tried the Rooter GoldenOrb which is based on openwrt 21.02 hoping for a better result. All have the same issue with detecting the RAM size 128M. For what ever reason the LEDE 17 detect it as 512M.

Anyway, I Opened the zbt box, And I discover that the RAM chip is from Micron D9PXV

and from the specs, It is said to be 256M DDR3L

I am not sure if this chip is causing the incorrect RAM size.

I have no clue with the chip is being used for WIFI cause it is glued to the heatsink

I hope someone in the OpenWRT forum could help me to recommend the ideal Opewrt firmware version for this ZBT WG3526.

The users at ROOter forum are not as many as the OpenWRT forum, and most of the time they are suggesting to ask in OpenWRT forum if the issue is related to OpenWRT.

Actually that's a 512 MiB RAM chip since it is 256M x 16 bits-- each of the 256M locations is 2 bytes.

Early OpenWrt DTS kernels had the RAM size coded into DTS, but now I think it uses what the bootloader reports. So you might want to hook up serial and see what the bootloader is doing.

You can find the wifi chip model by looking at the PCI ID numbers in the boot log.

1 Like

Thanks for your reply.

I am going to get the USB to serial dongle to check on bootloader report.

I am using the lspci command to check on the device, here is what I get.

It is said the chip is MT7662E. Isn't it WG3526 use two chip MT7603E and MT7612E?


I got the bootloader report from serial connection. The report is a confusing regarding the RAM size

RAM : 512 MB

Board Info
Detected Memory = 320 MiB

Giving linux memsize in MB, 512

Memory: 120656K/131072K

I don't know if this is a hardware, bootloader bug or OpenWRT firmware problem? Anybody has a similar issue?

Where did this pandora box uboot come from? Zbt wouldn’t be using something supported by gmail.

I’d suggest the custom uboot isn’t sending valid size