ZBT WE826-32M - need help to configure cellular modem (displays "no internet access" when connected)

ZBT WE826-32M on Openwrt always displays "no internet access" when connected with cable or wireless. I have updated its firmware to the current version but the problem still persist. Please i need help. Also, I learnt that some of these routers can not be used in my country Ghana. Please how true is that?

I assume you're referring to the clients, not the router itself ?

It's untrue, it might however be illegal, but that's another story.

2 Likes

Yes, some people have it here but can not get internet access with it.

Please connect to your OpenWrt device using ssh and copy the output of the following commands and post it here using the "Preformatted text </> " button:
grafik
Remember to redact passwords, MAC addresses and any public IP addresses you may have:

ubus call system board
cat /etc/config/network
cat /etc/config/wireless
cat /etc/config/dhcp
cat /etc/config/firewall
`root@OpenWrt:~# ubus call system board
{
        "kernel": "5.15.137",
        "hostname": "OpenWrt",
        "system": "MediaTek MT7620A ver:2 eco:6",
        "model": "Zbtlink ZBT-WE826 (32M)",
        "board_name": "zbtlink,zbt-we826-32m",
        "rootfs_type": "squashfs",
        "release": {
                "distribution": "OpenWrt",
                "version": "23.05.2",
                "revision": "r23630-842932a63d",
                "target": "ramips/mt7620",
                "description": "OpenWrt 23.05.2 r23630-842932a63d"
        }
}
root@OpenWrt:~# cat /etc/config/network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd11:9127:1d77::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '78:a3:51:05:ea:d5'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '0 1 2 3 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '4 6t'

root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10180000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option country 'GH'
        option cell_density '0'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

root@OpenWrt:~# cat /etc/config/dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option cachesize '1000'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'
        option filter_aaaa '0'
        option filter_a '0'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

type or paste code here

Everything here looks fine. We haven’t seen the firewall file, though. Please post that.

And let’s also see the output of the following (also tested from the router):

ping 8.8.8.8
ping openwrt.org

root@OpenWrt:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
root@OpenWrt:~# ping openwrt.org

And the firewall?

What technology of Internet connection do you plan to use? The configuration you posted is suitable for connecting to an Ethernet based service such as a cable modem. If you have the T version and intend to use an internal LTE modem, this needs to be set up differently.

Since what you have posted is basically a default configuration, there's no harm in resetting to default configuration and starting the configuration over (enter your country code, set up wifi AP, etc). This should always be done when upgrading across major versions such as from 22.X.X to 23.X.X. I'm not sure if this chip platform has been converted from swconfig to DSA. DSA requires a quite different network configuration.

1 Like

Please how do I find the firewall file?

I prefer to use wireless but currently, i am using cable connection. I will change it now.

But... you don't need to do this if you're performing a reset to defaults... I know that the default firewall configuration will be correct.

to be clear, this is a cable modem connection (i.e. coax cable into a cable modem > ethernet into your router)?

Have you restarted your cable modem? That is often necessary if you have changed your router -- it clears the previously 'learned' MAC address and allows it to learn a new one. Most cable modem services (at least in the USA) will only issue an IP address to the device with the MAC address it has learned.

1 Like

I dont often use the cable connection but because i have now hotspot to my PC, I can not connect another wireless again(in order not to lose connection now) that is why i am forced to use cable to access the router. There is a PCI modem in the router which i not sure whether it has been detected, if it works, i will do away with the cable connection. so help me configure it that way.

So yes, you must use an ethernet cable to connect to OpenWrt when it is in the default state since wifi is disabled. But that was not the question we were looking for...

Let's start here:

  • what is your physical connection to the internet?
    • Is it a cable modem?
    • DSL?
    • fiber optic?
    • cellular?
    • wifi (such as in a school, hotel, etc.)?

We need to know the technology and connection method necessary for your router to obtain an internet connection.

Thank you. I will do so,
I don't know much in IT so I couldn't get those terms(from swconfig to DSA).

cellular network

Since you're using a cellular network, do you have the "T" version as asked by @mk24?

I am sorry, i don't know what T version is.

There are two 32M versions - B0 and T. Check the information panel/sticker on the device (usually on the bottom).

Also see this:

  • WE-826-B green leds, a plastic case, bgn/an/ac
  • WE-826-T blue leds, metal case, and a populated serial header, and a user accessible sim slot, bgn only.

Yes, that is what I am using