YouHua WR1200JS original firmware / MT7621AT offload bug

Hi folks,

Model: YouHua WR1200JS

I have been struggling with this WiFi issue for awhile. As far as I am aware, there has been a software/hardware offload openwrt bug with the MT7621AT chipset for awhile now causing WiFi throughput issues. Wired, I can achive Max 600/25 which is right on spec for my Internet connection. Wifi I max at 240/25. Configs:


config wifi-device 'radio0'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option cell_density '0'

config wifi-device 'radio1'
        option type 'mac80211'
        option path '1e140000.pcie/pci0000:00/0000:00:01.0/0000:02:00.0'
        option band '5g'
        option htmode 'VHT80'
        option cell_density '0'
        option channel '48'
        option wmm '1'
        option country 'US'

config wifi-iface 'default_radio1'
        option device 'radio1'
        option network 'lan'
        option mode 'ap'
        option ssid 'Wifi SSID'
        option key 'password'
        option encryption 'psk2+ccmp'
        option wmm '1'

firewall offload is enabled

config defaults
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option synflood_protect '1'
        option flow_offloading '1'
#       option flow_offloading_hw '1'

I found the original frmware that shipped with the router in post #150.

I combined the firmware with rar software on my ubuntu machine, rebooted, held down "wireless" button for 15 sec, and booted into "breed mode" to push the original firmware.

It defaults to I tried to ssh in, but I wasn't able to figure out the login/password. No browser access either. If anyone that has this unit has solved the "offload" wifi speed issue, or knows the default user/pw of the original chinese firmware I'd like to test the original firmware to see if the wifi offload issue is still present.

Many firmware:

Tried those too, no change.

Ip for breed is

I know how to use breed. The issue is the software offload bug with the openwrt firmware on the MT7621AT hardware, that cause slow WiFi speeds. I'm trying to solve that issue.

well if you look around, i do not have your device, but you will find a way to compile a firmware with mt7603 and mt7612 mtk wirekess drivers, and also with ethernet mediatek proprietary hardware nat.if you ll do that make sure you do not enable hardware offload. all is done you need just compile

can explain this software offload bug story
how to use openwrt box
a small diagram please

MT7621 only takes care of wired offload if you have hardware offload enabled that is.
And you've said wired is fine.
So there's no "MT7621 offload bug" reported here.

Wireless hw offload is not avalible on OpenWrt . But it work for Padavan allowing WAN-> WiFi 5Ghz 350-400Mbit
I have padavan YH-WR1200JS_3.4.3.9-099_20181012-1050 from . Just PM me if You want it .