Xiaomi WiFi Router 3G

No. I still had to change the compiler version.

Good product , it is similar to http://www.wallystech.com/product/html/?84.html

I was too fast in my optimistic. Problem still exist. I will try 4.14 today.

So I have 4.14 (gcc 6.3) and I think that is even worse now. Maybe some patches needed?

thanks worked successfully!

So, can anyone confirm that it works?

I see the problem is with big files (hundreds of MB and above, but not always). Small one its copied with no problem (or I do it on too low amount of).

Still can't compile 4.14. My last atempted finished with "Uncompressing Kernel Image ... LZMA ERROR 1" during boot process. I see that kernel1.bin was more then 2MB in that case. Is it too big?

according to the partitions its 4 mb so it isn't too big.

cat /proc/mtd
dev:    size   erasesize  name
mtd0: 00080000 00020000 "Bootloader"
mtd1: 00040000 00020000 "Config"
mtd2: 00040000 00020000 "Bdata"
mtd3: 00040000 00020000 "Factory"
mtd4: 00040000 00020000 "crash"
mtd5: 00040000 00020000 "crash_syslog"
mtd6: 00040000 00020000 "reserved0"
mtd7: 00400000 00020000 "kernel_stock"
mtd8: 00400000 00020000 "kernel" -> 4194304 byte -> 4096 kbyte -> 4 mb
mtd9: 07580000 00020000 "ubi"

The same with k4.14. It may be too big. Could you verify this?
Flash the lzma error image, interrupt the u-boot, enter command prompt and issue following commands:
nand read 0x88000000 offset_on_flash read_size
bootm 0x88000000

I had a bricked mi router 3,no serial, no leds ,no usb, no ethernet.
I am trying to bring it back.
After hours of google searching i manage to make the router running Breed bootloader from an spi flash chip that i soldered to the pcb.
But now i don't know what to do.
Any try to flash a firmware from Breed was without success.
I think that i have to find a way to flash the bootloader to internal nand using Breed and remove the spi flash chip.
Do you have any idea?

Did anyone had any success changing the bootloader so far for this route ?

Unfortunetly "Aditional compiling options: -O3" makes kernel1.bin exceeds 2MB and (for me) lzma error during boot.

And after trying all method I found on net to fix corruption bug - by change to kernel 4.4 only works (up to now). Just copied 5GB of big video files without failure. Hope that they fix 4.14/4.9 soon.

Hi guys! After flashing latest version of openwrt for m3g lost wifi configs, no wifi configs in luci. Please tell me how switch on wifi on my roter? Scrennshot luci - http://prntscr.com/iosnvq

So did you try that manual boot method?

What is manual method?? I was trying to patch Config-4.9 in target/Rampis

Updated build.. latest master GCC 7.3 kernel 4.14 and irq balancing script

I need the kernel0.bin file that is on the wiki, but his link is broken.
I'm trying to get back to the original firmware via serial, but I can not.
Could someone provide the kernel0.bin file for me?


I have also updated the link in the wiki and in my earlier post.

Dear all, i tested Breed as bootloader for faster switching between Images.
But my Problem is, i'am unable to get a workig LEDE.

Like described earlier i merged kernel and rootfs but after flashing i run into trouble.

root@OpenWrt:~# opkg install luci
Installing luci (git-18.068.60872-bf04031-1) to root...
Collected errors:

  • verify_pkg_installable: Only have 0kb available on filesystem /overlay, pkg luci needs 1
  • opkg_install_cmd: Cannot install package luci.

what i'am doing wrong ?

How can i go back to original Bootloader ?
I have a complete mtd backup from before my first Prometheus test.



You guys, how is the update procedure with the Xiaomi Router. I had a wndr3800 before and with that i saved my config files, wiped the whole thing and flashed the image in failsafe mode with tftp. Copied back the config and done.

Dont know with this one...reading about some bricks makes me worried. Is it save and the same with just using the internal update feature in luci? Is it as clean as the tftp methode or does it even matter?

  1. Flashing stock firmware in Firmware1 and Firmware2 (Breed).

  2. From the stock firmware, flashing kernel1 + rootfs0

    mtd write lede-ramips-mt7621-mir3g-squashfs-kernel1.bin kernel1
    mtd write lede-ramips-mt7621-mir3g-squashfs-rootfs0.bin rootfs0
    nvram set flag_try_sys1_failed=1
    nvram commit

Flashing LEDE of Padavan..

for /f %%i in ("openwrt-ramips-mt7621-mir3g-squashfs-kernel1.bin") do ( set /a size = 4194304 - %%~zi >nul )
fsutil file createnew dummy2.bin %size% >nul
copy /y /b openwrt-ramips-mt7621-mir3g-squashfs-kernel1.bin + /b dummy2.bin + /b openwrt-ramips-mt7621-mir3g-squashfs-rootfs0.bin firmware.bin >nul
del dummy2.bin

mtd_write write /tmp/firmware.bin Firmware_Stub