Xiaomi WiFi Router 3G

Thank you!

I have one question:
How can I block certain devices from accessing the internet?
I have a xiaomi gateway and I want to block the internet access for it.

Thank you!

I think it is really straightforward.openWRT/LEDE wiki, i'd use the mac address src.

This System is currently extreme unstable. Tested a lot also including the Stock driver from Nossiac feed.

mt76 driver disconnects clients sporadically, not only ios devices.
mt76 authentication problems for unknown reason (wrong password is shown)
IP connectivity lost also if wifi still is connected.

Stock driver from feed: Hung state while loading 5ghz driver.

Looking forward into future, but currently ...........



And after testing for a while latest commits - usb hdd support is better but not stable. Files c.a. 10 GB or parallel transfer from two hosts (through afp) still generate bugs.

Hey guys did you noticed that the txpower of the 2,4ghz wifi device couldn't be set? It stay always 0 at least that is reported by iwinfo wlan0 info i tried to set manually by iw dev wlan0 set txpower 2000. And nothing has changed (still zero).

Is it solved by this commit? https://git.openwrt.org/?p=openwrt/openwrt.git;a=commit;h=608c84b96ea6b4501b9f64d3f9103a6ec8e7a144

no still same reports 0

Do you know if there is any plan to include support of this router to a stable version of LEDE / OpenWRT?

there is no implemented power reporting in opensource mt7603 driver

Hi folks. I need some help with debricking this router. TL;DR is that the LED does not show any life signs and the UART is quiet. Steps so far:

  1. the router was running LEDE normally
  2. attempted to sysupgrade but messed that up (uploaded a wrong file)
  3. router went into a boot loop
  4. disassembled it, connected to UART, entered the u-boot command line
  5. ran tftpboot and uploaded openwrt-ramips-mt7621-mir3g-initramfs-kernel.bin
  6. it said ## Booting image at 80200000 ... and the console freezed
  7. tried rebooting, but no life signs since that

I assume I damaged the bootloader somehow. @dissent1 do you have any advice?

OK, nevermind. Some weird stuff is going on, after a couple of reboots I disconnected the 1st UART pad and everything started up. Turns out using tftpboot/boot to start a Linux image is wrong (did not find why though), it's easier to just press 1 in the initial u-boot menu.

Hi guys,
I want to use this router as secondary router using a lan to lan configuration because I want the devices connected to the xiaomi in the same ip range of the primary router and I want
leave the primary router(rt-ac68u) to perform all operations (routing, ip assigment,dhcp,firewall...)
So,can I turn the wan port to become a lan port ?
Thanks in advance


The ssh web is not working: https://d.miwifi.com/rom/ssh

It redirect to http://d.miwifi.com/rom/ssh?userId=XXXXXXXXXX but it doesn't load and download nothing.

Is there any way to flash LEDE without the sshd bin?

Best regards.

Replace http with https, every time when it's redirecting.

1 Like

You can refer to: https://openwrt.org/docs/guide-user/network/vlan/switch
Good luck.


I replace with https and it works!

Kind regards.

Hi thanks for your work on that image. I have one problem: Port Forwarding not working at all. when disable firewall i can access my router from wan. Tried same config like I have on TP-Link with older version of Openwrt and not working. I set up only port forwarding via LUCI and i think it must working without setting up new firewall rules. am i correct?

here is my config:

config redirect
	option target 'DNAT'
	option src 'wan'
	option dest 'lan'
	option proto 'tcp udp'
	option src_dport '80'
	option dest_ip ''
	option dest_port '80'
	option name 'test'

Thanks for help :slight_smile:

Hi there we have made a mistake on the firewall uci-default. It creates a rule which is not working and everything after that not parsed. To solve this simply delete this rule (9092-Forward). I've built a new image with gcc7.3 and o3 optimization it is a little bit faster transmission download around 7-8 mb/s. I will upload that to my gdrive and if you interested in then i'll share it with you.

Or you can simply run this from 9092 runcommand or ssh and it will recopy the original firewall config and add other except the faulty one...

cp /rom/etc/config/firewall /etc/config/firewall
echo "$(cat /rom/etc/uci-defaults/firewall-config|tail -n85)" > /tmp/firewall-config
chmod +x /tmp/firewall-config
rm /tmp/firewall-config
1 Like

Thanks for fast reply, and everything working now. New image will be on Gdrive link you posted before?

@nossiac - Is it possible to get modules built for 4.14.27? Thanks in advance!