Xiaomi WiFi Router 3G

I bricked my device by flashing latest nightly (kernel panic)
[ 5.572120] ubi0: background thread "ubi_bgt0d" started, PID 375
[ 5.572142] hctosys: unable to open rtc device (rtc0)
[ 5.583645] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[ 5.591121] Please append a correct "root=" boot option; here are the available partitions:
[ 5.599461] 1f00 512 mtdblock0 [ 5.603448] (driver?)
[ 5.605821] 1f01 256 mtdblock1 [ 5.609805] (driver?)
[ 5.612154] 1f02 256 mtdblock2 [ 5.616153] (driver?)
[ 5.618505] 1f03 256 mtdblock3 [ 5.622486] (driver?)
[ 5.624834] 1f04 256 mtdblock4 [ 5.628835] (driver?)
[ 5.631187] 1f05 256 mtdblock5 [ 5.635169] (driver?)
[ 5.637537] 1f06 256 mtdblock6 [ 5.641521] (driver?)
[ 5.643869] 1f07 4096 mtdblock7 [ 5.647869] (driver?)
[ 5.650221] 1f08 4096 mtdblock8 [ 5.654202] (driver?)
[ 5.656574] 1f09 120320 mtdblock9 [ 5.660557] (driver?)
[ 5.662907] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[ 5.673411] Rebooting in 1 seconds..

i have serial console access. how do i flash a previous version??

In uboot console:
setenv flag_try_sys2_failed 1

And use stock USB recovery routine to flash stock image. After that flash lede again.

thanks I found stock dev image(miwifi_r3g_firmware_c2175_2.25.122.bin)? how do i flash it?.. sorry for many questions

You should read the whole thread. There is several suggested ways to do it.
post 365 seems to be the most simple and complete answer. Personally I used the more difficult approach with first flashing factory firmware, then obtaining root access and last flashing LEDE again using the information here ramips: improve Xiaomi Mi Router 3G support

Thanks post 365 did not work.. but flashing factory firmware did..

In order to make it easier for users to find relevant information about installation of LEDE/OpenWrt on this device, I created https://wiki.openwrt.org/toh/xiaomi/mir3g

Please review the following sections and add/modify as appropriate.


done... updated recovering from brick section

My tveheadend server is crashing often. What can be the reason for that?

Fri Dec 22 20:40:57 2017 kern.info kernel: [449672.589194] do_page_fault(): sending SIGSEGV to htsp_write_sche for invalid write access to 00000000
Fri Dec 22 20:40:57 2017 kern.info kernel: [449672.598461] epc = 77638ad4 in libc.so[77610000+93000]
Fri Dec 22 20:40:57 2017 kern.info kernel: [449672.603615] ra  = 004282a4 in tvheadend[400000+5bc000]

Wifi 5Ghz is stable but 2.4Ghz has very bad range.The same range like the 5Ghz wireless.

Maybe yours is faulty, I have an excellent 2.4 GHz range

Hello, can someone help me please?

I just wanted to flash my second Xiaomi Mi 3G router according to the above instructions. It also works so far with the installation of the Developer firmware and SSH access via Putty. After I have flashed the LEDE Firmware on the commands and then run the reboot, the router flashes red at intervals of 1 second. I have repeated this procedure several times. I'm always back to the original Developer firmware and have tried again, each with the same result!
I also tested different snapshots of the past few days.



Problem solved!
With the snapshot from this afternoon(OpenWrt SNAPSHOT r5615-5bbd493 /), the installation has now worked without problems. It seems like the versions of the past days were broken ... but I'm not sure maybe the USB stick was to blame ...

Hmm... I think it is more a incompatibility or a faulty iPhone 7. This is my second Xiaomi I setup and both had problems with my iPhone 7 but not only with the iPhone 7.
I encountered the same problem I have at 2.4Ghz also in 5Ghz. When the reception get a little bit worse my phone stays connected but no data is transfered anymore, than I get near to the router, the reception goes to very good but no data can be transfered anymore for minutes... I have "option disassoc_low_ack 0" activated now but happend before too.

Edit:Had (KRACK) countermeasures enabled, now disabled and it seems fixed ... looking the next hours/days.

Edit2: No not fixed. Went into a place with bad connection, no data was tranferred anymore but my phone stays connected, now returned near to the router, router shows the phone as connected with signal -71db and does not get any better and no data can be transfered for like 2 minutes. Than signal returns to -51db and wifi works.

Has anyone experienced a problem with Transmission and a HDD: a torrent is 100% downloaded, but if you check the torrent, it is 97-99%? I checked torrents downloaded with a November build, there is no such problem.

This is a problem with kernel 4.9. If you go back to 4.4 everything is fine. I recently reported the issue but will probably have no traction since kernel 4.14 is coming.

Thanks to @nossiac now we have also MediaTek wireless driver for mt7603 and mt7612 :smiley:

I'm trying to compile...

1 Like

If that is based on officiall drivers and works properly in LEDE that would be awesome.
That way MT7610 and MT7615 which are currently not supported by mt76 can be added since a lot of devices uses them.
Also MT7628 is really bad with mt76

Guy even has @mediatek.com email adress

yes, from mediatek, but unfortunately, I'm not the driver maintainer...
the code arch is quite out-of-date, trying to convince them to keep it up to date.
and the module is not fully tested, might be buggy.

1 Like

Thanks,It is a step forward for chips that are not yet supported by mt76 or MT7628 which is terrible with mt76.
I will test it on 840N v5,that is only one with MT7628 I have.

1 Like

@nossiac I disable mt76 driver using menuconfig and compiled r5389-358df5e but I have this error

[ 10.809885] kmodloader: failed to mmap /lib/modules/4.9.72/mt7603.ko
[ 10.816348] kmodloader: failed to mmap /lib/modules/4.9.72/mt7612.ko
[ 10.835085] kmodloader: failed to mmap /lib/modules/4.9.72/mt7603.ko
[ 10.841509] kmodloader: failed to mmap /lib/modules/4.9.72/mt7612.ko


What am I doing wrong?

the module was built with linux-4.4.107 (latest snapshot from stable branch lede-17.01). should not work with your kernel.

the trunk version will be supported later. I'm trying to make an automation tool for that.

1 Like

Sorry :man_facepalming:
Many thanks