Xiaomi R4A (v3.0.27) cannot debrick?

Sure, you have right! But I don't have any idea without connect it via serial console. Have you any guidance how to make it, what additional devices needed to it? Thank you for any advice in advance!

I did use TinyPXE, need Windows PC, refer to:

Maybe Xiaomi factory tools also work.

Unfortunaltely any of methods above not worked for me. (tinyxpe, miwifi tool, dnsmasq as tftp all falled back to bricked state - I think any of used firmwares were wrong) I tried to keep in failsafe mode the good working router - but after 6 sec it booting forward in normal way. Is it possible to enforce keeping failsafe mode any way? (I tried with reset button pressing via boot)

Then you have to find the right way by yourself, and UART-to-USB tools is must, even Flash chip programmer/reader.

Because of your flash IC is EON, maybe you need a right factory image to do the unbrick. The normal images downloaded from internet, maybe not work with the chip, likes openwrt.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.