Xiaomi R4A (v3.0.27) cannot debrick?

Hi all, I got 2 Xiaomi Gigabit Edition routers and tried to flash them. After the ffirst bricked, tried many times to debrick with various methods and many images but all was unsuccesful. I think I havn't found the correct firmware for it.

At the second I tried with the other router but I havn't flashed yet but read the 'uname' and 'lsmod' information from it (using acecilia/OpenWRTInvasion guidance) and saw the following:

# uname -a
Linux XiaoQiang 3.10.14 #1 MiWiFi-R4A-3.0.27 SMP Mon Apr 12 09:07:54 UTC 2021 mips GNU/Linux
# the "/api/xqsystem/check_rom_update" output

Has anybody an idea how to debrick it and flash and install openwrt or it is impossible to this version.

removed this。

Hi, thanks your link. But I can use acecilia/OpenWRTInvasion's method and can connect to the router via ssh or telnet. And of course can write to the MTD unfortunately :). Will call the Xiaomi service asking for correct test.bin, maybe it helps.

Maybe acecilia/OpenWRTInvasion tools cannot use for debrick, did you try Uart + TFTP or Xiaomi factory methode?

Sorry for misunderstading but I used acecilia/OpenWRTInvasion tool only on an untouched factory router and read system info via ssh.

I tried on another Xiaomi router previously which has bricked and hasn't debricked since. Tried many methods to debrick it, it works, asks the test.bin via tftp but all the downloadable firmwares are wrong so far.

What is the p/n of your 4A flash chip? How did you brick your routers, wrong openwrt fw?.

I haven't disassembled it yet so I don't know the correct versionof the flash chip. Is it possible to make a request via software?

Yes, I bricked the router obviously a wrong firmware at first. It was the latest version from https://openwrt.org/inbox/toh/xiaomi/xiaomi_mi_router_4a_gigabit_edition site.

Then, if you would not return the router back to seller, you have to open the case:

  1. check the flash IC, Eon EN25QX128A cannot use the official openwrt FW.
  2. connect out the serial port, and try to use TFTP software to debrick it.

If I understand well, it can't debrick normal way pressing reset button and powering on way? As far as I see the tftp works just firmware is not correct, see the following log line:
"dnsmasq-tftp: sent /tftpboot/test.bin to"

And the led light blinking purple very fast and nothing else happened. The router kept in bricked state.

I asked the official Xiaomi service helpdesk for correct firmware but they didn't help me unfortunately.

if you setup all tftp tools right, easy to debrick it in normal way.

But if something wrong, you cannot "see" it, so connect serial wires as a monitoring windows....

Thanks for advice, I don't have needed equipments for trying serial console access. I tried to examine the still working router and saw the following (accessing it via OpenWRTInvasion)

Very interesting, it contains a file named openwrt_release :slight_smile:

Look at these lines:

root@XiaoQiang:~# cat /etc/uboot_version
root@XiaoQiang:~# cat /etc/openwrt_release
DISTRIB_RELEASE="Attitude Adjustment"
DISTRIB_DESCRIPTION="OpenWrt Attitude Adjustment 12.09.1"

you still not confirm your flash IC p/n:

Thanks for your linked files, I tried them but it wasn't successful to debrick the router unfortunately. After it I opened the case of the router and made a photo. Please take a look at the picture, it seems for me it is an Eon chip on the board.

Have you any instructions how to connect to the router via serial console? But I am afraid of that it is a newer model which hasn' got support from xiaomi yet.

EON chip, currently only above my code could be used to flash, OpenWrt official code will brick it.

Then you have to try serial connect + TFTP server or bootloader + TFTP server.

Thanks for the link, I donwloaded it, will try. Would you send me a bootloader image also to try to debrick it via tftp? Does it work with dnsmasq also or needed to use miwifirepair tool? (the second method needed Windows and I don't have it)

The bootloader is still there in the device, after you connected serial port, you will see and operate with the bootloader.

We do have both Linux and Windows PC.

Thanks, will try flash wwith your images sent before. May it use without debrick via tftp? Or needed to revert the original working operating system then flash it with yours?

For the not bricked good device, you could flash it as normal, using the acecilia/OpenWRTInvasion + Linux and using my code into the OS1.

Hi, flashing the router with your image successfuly done. Thank you! You make my day! :slight_smile:

Then, any new firmware to upgrade, you have to know the image must be patched for EON chip, otherwise it'll brick your router.

So you have to fix your debrick process asap.