Xiaomi r3p pro died after update

Hi everyone,

followed the instructions on this page and everything went well until the restart, after that I no longer have access to wireless and cable as well.

I tried to put a new pen with the file but I disconnect it and reconnect it securely with the reset button but the orange light does not flash and remains always on.

Someone can help me?


Did you manage to connect to UART and see what is the problem?

I can’t connect or even by ssh :weary: can you help me?

But I don’t have a serial cable to connect with UART.

If you are not able to make the device boot somehow with the reset button, then connecting to UART is the only way.

Thanks, I will purchase this dongle https://www.amazon.com/gp/aw/c/ref=mw_dp_buy_crt it’s work with this router?

You've linked to the shopping cart page, not a specific item.

1 Like


1 Like

Thanks and after purchase thuis product what do I have to do?


Connect it to the UART pins of the router as described here.
Once you get console to the device follow the debricking instructions in the link of my previous post.

1 Like

Hi trendy,

The wiki need some updates as some steps are missing.
I can build the content, just wanna know someone can after added it there, tried to register but never received the email back.

Did you check in the spam folder? Generally wiki is open to anyone to add or update.

Yes, I did it, will try once again.