Xiaomi R3P no WIFI with latest stable 19.07.0 after upgrade

Dear all,

after realising that the fresh stable has been released i immediately flashed it as sysupgrade over my well running snapshot build. After reboot i realized again the WIFI problem which i encountered with older snapshot builds. In the past this problem yould be fixed by removing the async-probe from mt7615e.

Now with the stable again my WIFI is not working and there is no mt7615e inside /etc/modules.d

Can anybody please give me a hint to get the stable running including WIFI ?!

Thanks in advance


Do you have the mt7615e package installed?

# opkg list-installed|grep mt7165

I didn't check as i expected that a stable for the router should have everything available to run WLAN.
In order to check i would need to flash again the stable. Are you sure with your command?

# opkg list-installed|grep mt7165

I'm missing the mt7615e in the folder!

I'm pretty sure. Do an

# opkg update
# opkg install kmod-mt7615e

And open a bug report about the missing package here.

It's not working, as i expected. After entering the command "opkg install mt7615" i got following error.

Unknown package 'mt7615e'.
Collected errors:
 * opkg_install_cmd: Cannot install package mt7615e.

By the way after upgrading to the stable no WIFI. I've to go now back to the snapshot.

You did run an update before right, like I suggested?

as i was not sure whether i made the opkg update before i tried it again.
same result

First lines show the end of opkg update.

Updated list of available packages in /var/opkg-lists/openwrt_telephony
Downloading http://downloads.openwrt.org/releases/19.07.0/packages/mipsel_24kc/telephony/Packages.sig
Signature check passed.

Followed by the proposed command

root@OpenWrt_Main_AccessPoint:~# opkg install mt7615e
Unknown package 'mt7615e'.
Collected errors:
 * opkg_install_cmd: Cannot install package mt7615e.

Can you paste the output of cat /etc/opkg/distfeeds.conf?

Please use the code tags for better readability (it shows as </> on top of your editing window).

The package is kmod-mt7615e.

Yep. :man_facepalming:

Here is the output

root@OpenWrt_Main_AccessPoint:~# cat /etc/opkg/distfeeds.conf
src/gz openwrt_core http://downloads.openwrt.org/releases/19.07.0/targets/ramips/mt7621/packages
src/gz openwrt_kmods http://downloads.openwrt.org/releases/19.07.0/targets/ramips/mt7621/kmods/4.14.162-1-2e88863ccdd594fb8e842df3c25842ee
src/gz openwrt_base http://downloads.openwrt.org/releases/19.07.0/packages/mipsel_24kc/base
src/gz openwrt_luci http://downloads.openwrt.org/releases/19.07.0/packages/mipsel_24kc/luci
src/gz openwrt_packages http://downloads.openwrt.org/releases/19.07.0/packages/mipsel_24kc/packages
src/gz openwrt_routing http://downloads.openwrt.org/releases/19.07.0/packages/mipsel_24kc/routing
src/gz openwrt_telephony http://downloads.openwrt.org/releases/19.07.0/packages/mipsel_24kc/telephony

Thanks. @Pepe pointed out my error, you'd need kmod-mt7615e, not just mt7615e, sorry. Can you give it another shot?

holy shit ... now it's working
After installing kmod-mt7615e and rebooting the router, both WLAN's are active and running.

By the way i still would expect that stable version should contain this, otherwise it makes no sense.

Thanks to you both Borromi & Pepe

You're absolutely right, but at the time support got added, the FOSS drivers did not support the MT7615E radio yet. I will send in a patch so 19.07.1 gets built with mt7615e support included for this device.

If you are going to do it, then it's fine, because I was just writing that I will do it. :slight_smile:

Sorry I overlooked that. Go ahead. First come, first served :slight_smile:

If you wish, I don't mind. :wink:

For completeness, it was sent to the mailing list:
http://lists.infradead.org/pipermail/openwrt-devel/2020-January/021165.html and hopefully it will be included in the OpenWrt 19.07.1 release.


This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.