I've been successfully running a LEDE snapshot from around 2018 on this router, and recently decided to update it to a more recent version. So I did a sysupgrade -n -F
to 21.02.3. With my ISP all I have to do to is to provide a correct MAC address to the device connecting to the internet, and that's what I had set up back in 2018 and can still do in network-manager if I connect ISP's ethernet cable to a PC directly. But in 21.02.3 this no longer works! I've added the MAC first to wan, then to eth0, then to both with no effect.
Here's network config;
root@OpenWrt:~# cat /etc/config/network
config interface 'loopback'
option device 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option packet_steering '1'
option ula_prefix 'fdd7:7a87:ca83::/48'
config device
option name 'br-lan'
option type 'bridge'
list ports 'lan1'
list ports 'lan2'
config interface 'lan'
option device 'br-lan'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wan'
option device 'wan'
option proto 'dhcp'
config interface 'wan6'
option device 'wan'
option proto 'dhcpv6'
config device
option name 'wan'
option macaddr '00:xx:xx:xx:xx:9F'
config device
option name 'eth0'
option macaddr '00:xx:xx:xx:xx:9F'
and ip a
:
root@OpenWrt:~# ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1504 qdisc fq_codel state UP qlen 1000
link/ether 00:xx:xx:xx:xx:9f brd ff:ff:ff:ff:ff:ff
inet6 fe80::222:15ff:fe0f:ba9f/64 scope link
valid_lft forever preferred_lft forever
3: wan@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
link/ether 00:xx:xx:xx:xx:9f brd ff:ff:ff:ff:ff:ff
inet6 fe80::222:15ff:fe0f:ba9f/64 scope link
valid_lft forever preferred_lft forever
4: lan2@eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue master br-lan state LOWERLAYERDOWN qlen 1000
link/ether 78:11:dc:4b:f0:c8 brd ff:ff:ff:ff:ff:ff
5: lan1@eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue master br-lan state UP qlen 1000
link/ether 78:11:dc:4b:f0:c8 brd ff:ff:ff:ff:ff:ff
6: wlan0: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
link/ether 78:11:dc:4b:f0:c9 brd ff:ff:ff:ff:ff:ff
7: wlan1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN qlen 1000
link/ether 78:11:dc:4b:f0:ca brd ff:ff:ff:ff:ff:ff
8: br-lan: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
link/ether 78:11:dc:4b:f0:c8 brd ff:ff:ff:ff:ff:ff
inet 192.168.1.1/24 brd 192.168.1.255 scope global br-lan
valid_lft forever preferred_lft forever
inet6 fdd7:7a87:ca83::1/60 scope global noprefixroute
valid_lft forever preferred_lft forever
inet6 fe80::7a11:dcff:fe4b:f0c8/64 scope link
valid_lft forever preferred_lft forever
and ip a
from a laptop with a direct connection:
$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp0s31f6: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
link/ether 00:xx:xx:xx:xx:9f brd ff:ff:ff:ff:ff:ff permaddr c8:5b:76:3d:61:22
inet 37.232.xxx.xx/18 brd 37.232.xxx.xxx scope global dynamic noprefixroute enp0s31f6
valid_lft 7177sec preferred_lft 7177sec
inet6 fe80::eac8:556:4f1:b38f/64 scope link noprefixroute
valid_lft forever preferred_lft forever
3: wlp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether 86:5f:cf:8f:3c:f5 brd ff:ff:ff:ff:ff:ff permaddr e4:a4:71:d9:22:4a
4: docker0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default
link/ether 02:42:ae:d3:c7:1a brd ff:ff:ff:ff:ff:ff
inet 172.17.0.1/16 brd 172.17.255.255 scope global docker0
valid_lft forever preferred_lft forever
Am I missing something obvious here? Or did some things about this setup have changed since 2018?