Xiaomi Mi Router AC2100 21.02 random reboots

I have installed OpenWRT 21.02 on my Xiaomi Mi Router AC2100 a week ago and I've had it reboot 2 times for no reason so far.
Most of my network activity includes browsing, Youtube and mining ETH in a pool.
Has anyone had similar issues?
Please tell me which configurations I should include for troubleshooting.

1 Like

I have observed the same issue - my D-Link DWR-921 reboot randomly few times since I upgraded it to 21.02.0. Configuration wasn't change.


Clear configuration and configure everything from zero.

Currently stable for 12 days now after I manually restarted it. Must have been some kind of fluke, I don't know.

I have this router (rev C3), and I had few reboots. I will go back to 19.xx because I work using internet from this router. How is your uptime?

I have 2 devices. TPLink Archer C50 and Xiaomi Mini. Both 21.02. I had notice some problems but neves stopped to look into. But today i realized BOTH devices had booted twice. In a few hours. I will keep watching it.

Do someone got anything new?

I had just upgraded to OpenWrt 21.02.1. Fresh install. Config from scratch. Same behaviour.

Since it reboot, i got no log. I took a look on /var/log but no file is there. Did the path changed? How can i track the reboot problem?

I quit for today. BOTH have same behaviour. I want to throught both devices on the wall. I have 4 (dumb) Acess Points in my house. All worked fine for a long time. 2 are very old, running custom 18.06.8. The others were at 21.02, now on the newest (OpenWrt 21.02.1 r16325-88151b8303 / LuCI openwrt-21.02 branch git-21.295.67054-13df80d)

TP-Link Archer C50 v1 and Xiaomi MiWiFi Mini
Both MediaTek MT7620A

As i told,i tried to upgrade not keeping config and made a (lot of) reset. Tried to change almost nothing. Only SSID and Wifi Security. Also stopped odhcpd, dnsmasq and firewall and changed Lan IP. No luck. Both reboots ramdonly. Sometimes in 2 hours, other, in 2 minutes.

Since both hardwares got the problem, should it be a bug? Log only show messages after reboot, so i cannot find what happens when it reboots.