Xiaomi Mi Router 4A (MIR4A) 100M No 5Ghz

Hi, after bricking and de-bricking couple of times, I've flashed firmware for Xiaomi Mi Router 4C first then force upgraded without keeping configurations for Router 4A (MIR4A) 100M

Label says SKU: DVB4230GL and Model: R4AC

All labels are in english.

But de-bricking was acieved by chinese rom, layout is same as 4c but currently using firmware for MIR4A.

Currently there's no 5ghz radio under wireless

Tried updating packages under software and rebooting to no avail

Any help is appreciated. I have serial access too.

Output for

uci export network; uci export wireless; \
uci export dhcp; uci export firewall; \
wifi status ; iwinfo ; iw list

package network

config interface 'loopback'
        option device 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fd44:4310:5945::/48'

config device
        option name 'br-lan'
        option type 'bridge'
        list ports 'eth0.1'

config interface 'lan'
        option device 'br-lan'
        option proto 'static'
        option ipaddr '192.168.1.1'
        option netmask '255.255.255.0'
        option ip6assign '60'

config device
        option name 'eth0.2'
        option macaddr '<MAC_ADDR>'

config interface 'wan'
        option device 'eth0.2'
        option proto 'dhcp'

config interface 'wan6'
        option device 'eth0.2'
        option proto 'dhcpv6'

config switch
        option name 'switch0'
        option reset '1'
        option enable_vlan '1'

config switch_vlan
        option device 'switch0'
        option vlan '1'
        option ports '4 2 6t'

config switch_vlan
        option device 'switch0'
        option vlan '2'
        option ports '0 6t'

package wireless

config wifi-device 'radio0'
        option type 'mac80211'
        option path 'platform/10300000.wmac'
        option channel '1'
        option band '2g'
        option htmode 'HT20'
        option disabled '1'

config wifi-iface 'default_radio0'
        option device 'radio0'
        option network 'lan'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'

package dhcp

config dnsmasq
        option domainneeded '1'
        option boguspriv '1'
        option filterwin2k '0'
        option localise_queries '1'
        option rebind_protection '1'
        option rebind_localhost '1'
        option local '/lan/'
        option domain 'lan'
        option expandhosts '1'
        option nonegcache '0'
        option authoritative '1'
        option readethers '1'
        option leasefile '/tmp/dhcp.leases'
        option resolvfile '/tmp/resolv.conf.d/resolv.conf.auto'
        option nonwildcard '1'
        option localservice '1'
        option ednspacket_max '1232'

config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        option dhcpv4 'server'
        option dhcpv6 'server'
        option ra 'server'
        option ra_slaac '1'
        list ra_flags 'managed-config'
        list ra_flags 'other-config'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

config odhcpd 'odhcpd'
        option maindhcp '0'
        option leasefile '/tmp/hosts/odhcpd'
        option leasetrigger '/usr/sbin/odhcpd-update'
        option loglevel '4'

package firewall

config defaults
        option syn_flood '1'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'REJECT'

config zone
        option name 'lan'
        list network 'lan'
        option input 'ACCEPT'
        option output 'ACCEPT'
        option forward 'ACCEPT'

config zone
        option name 'wan'
        list network 'wan'
        list network 'wan6'
        option input 'REJECT'
        option output 'ACCEPT'
        option forward 'REJECT'
        option masq '1'
        option mtu_fix '1'

config forwarding
        option src 'lan'
        option dest 'wan'

config rule
        option name 'Allow-DHCP-Renew'
        option src 'wan'
        option proto 'udp'
        option dest_port '68'
        option target 'ACCEPT'
        option family 'ipv4'

config rule
        option name 'Allow-Ping'
        option src 'wan'
        option proto 'icmp'
        option icmp_type 'echo-request'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-IGMP'
        option src 'wan'
        option proto 'igmp'
        option family 'ipv4'
        option target 'ACCEPT'

config rule
        option name 'Allow-DHCPv6'
        option src 'wan'
        option proto 'udp'
        option dest_port '546'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-MLD'
        option src 'wan'
        option proto 'icmp'
        option src_ip 'fe80::/10'
        list icmp_type '130/0'
        list icmp_type '131/0'
        list icmp_type '132/0'
        list icmp_type '143/0'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Input'
        option src 'wan'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        list icmp_type 'router-solicitation'
        list icmp_type 'neighbour-solicitation'
        list icmp_type 'router-advertisement'
        list icmp_type 'neighbour-advertisement'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-ICMPv6-Forward'
        option src 'wan'
        option dest '*'
        option proto 'icmp'
        list icmp_type 'echo-request'
        list icmp_type 'echo-reply'
        list icmp_type 'destination-unreachable'
        list icmp_type 'packet-too-big'
        list icmp_type 'time-exceeded'
        list icmp_type 'bad-header'
        list icmp_type 'unknown-header-type'
        option limit '1000/sec'
        option family 'ipv6'
        option target 'ACCEPT'

config rule
        option name 'Allow-IPSec-ESP'
        option src 'wan'
        option dest 'lan'
        option proto 'esp'
        option target 'ACCEPT'

config rule
        option name 'Allow-ISAKMP'
        option src 'wan'
        option dest 'lan'
        option dest_port '500'
        option proto 'udp'
        option target 'ACCEPT'

{
        "radio0": {
                "up": false,
                "pending": false,
                "autostart": true,
                "disabled": true,
                "retry_setup_failed": false,
                "config": {
                        "path": "platform/10300000.wmac",
                        "channel": "1",
                        "band": "2g",
                        "htmode": "HT20",
                        "disabled": true
                },
                "interfaces": [
                        {
                                "section": "default_radio0",
                                "config": {
                                        "mode": "ap",
                                        "ssid": "OpenWrt",
                                        "encryption": "none",
                                        "network": [
                                                "lan"
                                        ],
                                        "mode": "ap"
                                },
                                "vlans": [

                                ],
                                "stations": [

                                ]
                        }
                ]
        }
}
wlan0     ESSID: unknown
          Access Point: <MAC_ADDR>
          Mode: Client  Channel: unknown (unknown)  HT Mode: NOHT
          Center Channel 1: unknown 2: unknown
          Tx-Power: 24 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11b/g/n
          Hardware: 14C3:7628 14C3:0004 [MediaTek MT76x8]
          TX power offset: none
          Frequency offset: none
          Supports VAPs: yes  PHY name: phy0

Wiphy phy0
        wiphy index: 0
        max # scan SSIDs: 4
        max scan IEs length: 2257 bytes
        max # sched scan SSIDs: 0
        max # match sets: 0
        Retry short limit: 7
        Retry long limit: 4
        Coverage class: 0 (up to 0m)
        Device supports AP-side u-APSD.
        Device supports T-DLS.
        Available Antennas: TX 0x3 RX 0x3
        Configured Antennas: TX 0x3 RX 0x3
        Supported interface modes:
                 * IBSS
                 * managed
                 * AP
                 * AP/VLAN
                 * monitor
                 * mesh point
                 * P2P-client
                 * P2P-GO
        Band 1:
                Capabilities: 0x1fe
                        HT20/HT40
                        SM Power Save disabled
                        RX Greenfield
                        RX HT20 SGI
                        RX HT40 SGI
                        TX STBC
                        RX STBC 1-stream
                        Max AMSDU length: 3839 bytes
                        No DSSS/CCK HT40
                Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
                Minimum RX AMPDU time spacing: No restriction (0x00)
                HT TX/RX MCS rate indexes supported: 0-15
                Frequencies:
                        * 2412 MHz [1] (20.0 dBm)
                        * 2417 MHz [2] (20.0 dBm)
                        * 2422 MHz [3] (20.0 dBm)
                        * 2427 MHz [4] (20.0 dBm)
                        * 2432 MHz [5] (20.0 dBm)
                        * 2437 MHz [6] (20.0 dBm)
                        * 2442 MHz [7] (20.0 dBm)
                        * 2447 MHz [8] (20.0 dBm)
                        * 2452 MHz [9] (20.0 dBm)
                        * 2457 MHz [10] (20.0 dBm)
                        * 2462 MHz [11] (20.0 dBm)
                        * 2467 MHz [12] (20.0 dBm) (no IR)
                        * 2472 MHz [13] (20.0 dBm) (no IR)
                        * 2484 MHz [14] (20.0 dBm) (no IR)
        valid interface combinations:
                 * #{ IBSS } <= 1, #{ managed, AP, mesh point, P2P-client, P2P-GO } <= 4,
                   total <= 4, #channels <= 1, STA/AP BI must match
        HT Capability overrides:
                 * MCS: ff ff ff ff ff ff ff ff ff ff
                 * maximum A-MSDU length
                 * supported channel width
                 * short GI for 40 MHz
                 * max A-MPDU length exponent
                 * min MPDU start spacing
        max # scan plans: 1
        max scan plan interval: -1
        max scan plan iterations: 0
        Supported extended features:
                * [ RRM ]: RRM
                * [ FILS_STA ]: STA FILS (Fast Initial Link Setup)
                * [ CQM_RSSI_LIST ]: multiple CQM_RSSI_THOLD records
                * [ CONTROL_PORT_OVER_NL80211 ]: control port over nl80211
                * [ TXQS ]: FQ-CoDel-enabled intermediate TXQs
                * [ AIRTIME_FAIRNESS ]: airtime fairness scheduling
                * [ AQL ]: Airtime Queue Limits (AQL)
                * [ SCAN_RANDOM_SN ]: use random sequence numbers in scans
                * [ SCAN_MIN_PREQ_CONTENT ]: use probe request with only rate IEs in scans
                * [ CONTROL_PORT_NO_PREAUTH ]: disable pre-auth over nl80211 control port support
                * [ DEL_IBSS_STA ]: deletion of IBSS station support
                * [ SCAN_FREQ_KHZ ]: scan on kHz frequency support
                * [ CONTROL_PORT_OVER_NL80211_TX_STATUS ]: tx status for nl80211 control port support

Tried writing configurations for devices under platform to no avail. I would have believed that the device simply does not have 5ghz if it weren't for the fact stock firmware was using 5ghz

If anyone has any ideas, I'd really appreciate it, because I'm clueless about what can be done.

MT7628 is built-in 2.4G wifi chip, if the router has 5G wifi, it must use an external 5G wifi chip (MT7612...), please check.

Thank you for your reply @RadioOperator

The 5Ghz Wi-Fi chipset of this device is an MT7613BEN.

then check the log file, if kernel detected the wifi chip.

I've already done that, it simply does not show up. That's why I am here :slight_smile:

Kernel log

[    0.000000] Linux version 5.10.176 (builder@buildhost) (mipsel-openwrt-linux-musl-gcc (OpenWrt GCC 11.2.0 r20134-5f15225c1e) 11.2.0, GNU ld (GNU Binutils) 2.37) #0 Thu Apr 27 20:28:15 2023
[    0.000000] Board has DDR2
[    0.000000] Analog PMU set to hw control
[    0.000000] Digital PMU set to hw control
[    0.000000] SoC Type: MediaTek MT7628AN ver:1 eco:2
[    0.000000] printk: bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 00019655 (MIPS 24KEc)
[    0.000000] MIPS: machine is Xiaomi Mi Router 4A (100M Edition)
[    0.000000] Initrd not found or empty - disabling initrd
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, PIPT, no aliases, linesize 32 bytes
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000003ffffff]
[    0.000000] On node 0 totalpages: 16384
[    0.000000]   Normal zone: 144 pages used for memmap
[    0.000000]   Normal zone: 0 pages reserved
[    0.000000]   Normal zone: 16384 pages, LIFO batch:3
[    0.000000] pcpu-alloc: s0 r0 d32768 u32768 alloc=1*32768
[    0.000000] pcpu-alloc: [0] 0 
[    0.000000] Built 1 zonelists, mobility grouping on.  Total pages: 16240
[    0.000000] Kernel command line: console=ttyS0,115200 rootfstype=squashfs,jffs2
[    0.000000] Dentry cache hash table entries: 8192 (order: 3, 32768 bytes, linear)
[    0.000000] Inode-cache hash table entries: 4096 (order: 2, 16384 bytes, linear)
[    0.000000] Writing ErrCtl register=00043d90
[    0.000000] Readback ErrCtl register=00043d90
[    0.000000] mem auto-init: stack:off, heap alloc:off, heap free:off
[    0.000000] Memory: 56352K/65536K available (5702K kernel code, 619K rwdata, 696K rodata, 1228K init, 210K bss, 9184K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS: 256
[    0.000000] intc: using register map from devicetree
[    0.000000] CPU Clock: 575MHz
[    0.000000] timer_probe: no matching timers found
[    0.000000] clocksource: MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6647862422 ns
[    0.000010] sched_clock: 32 bits at 287MHz, resolution 3ns, wraps every 7469508094ns
[    0.007655] Calibrating delay loop... 380.92 BogoMIPS (lpj=1904640)
[    0.073536] pid_max: default: 32768 minimum: 301
[    0.078178] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.085200] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.095099] dyndbg: Ignore empty _ddebug table in a CONFIG_DYNAMIC_DEBUG_CORE build
[    0.106472] clocksource: jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.115987] futex hash table entries: 256 (order: -1, 3072 bytes, linear)
[    0.122629] pinctrl core: initialized pinctrl subsystem
[    0.132777] NET: Registered protocol family 16
[    0.138005] thermal_sys: Registered thermal governor 'step_wise'
[    0.247768] mt7620-pci 10140000.pcie: Port 0 N_FTS = 1b105000
[    0.408224] PCI host bridge /pcie@10140000 ranges:
[    0.412803]  MEM 0x0000000020000000..0x000000002fffffff
[    0.417835]   IO 0x0000000010160000..0x000000001016ffff
[    0.473830] PCI host bridge to bus 0000:00
[    0.477751] pci_bus 0000:00: root bus resource [mem 0x20000000-0x2fffffff]
[    0.484437] pci_bus 0000:00: root bus resource [io  0x10160000-0x1016ffff]
[    0.491017] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.497596] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.505269] pci 0000:00:00.0: [14c3:0801] type 01 class 0x060400
[    0.511036] pci 0000:00:00.0: reg 0x10: [mem 0x00000000-0x7fffffff]
[    0.517060] pci 0000:00:00.0: reg 0x14: [mem 0x00000000-0x0000ffff]
[    0.523186] pci 0000:00:00.0: supports D1
[    0.526991] pci 0000:00:00.0: PME# supported from D0 D1 D3hot
[    0.534190] pci 0000:00:00.0: bridge configuration invalid ([bus 00-00]), reconfiguring
[    0.542093] pci 0000:01:00.0: [14c3:7663] type 00 class 0x000280
[    0.547906] pci 0000:01:00.0: reg 0x10: [mem 0x00000000-0x000fffff 64bit pref]
[    0.554840] pci 0000:01:00.0: reg 0x18: [mem 0x00000000-0x00003fff 64bit pref]
[    0.561820] pci 0000:01:00.0: reg 0x20: [mem 0x00000000-0x00000fff 64bit pref]
[    0.568886] pci 0000:01:00.0: supports D1 D2
[    0.572952] pci 0000:01:00.0: PME# supported from D0 D1 D2 D3hot D3cold
[    0.579367] pci 0000:01:00.0: 2.000 Gb/s available PCIe bandwidth, limited by 2.5 GT/s PCIe x1 link at 0000:00:00.0 (capable of 4.000 Gb/s with 5.0 GT/s PCIe x1 link)
[    0.595223] pci_bus 0000:01: busn_res: [bus 01-ff] end is updated to 01
[    0.601563] pci_bus 0000:00: busn_res: [bus 00-ff] end is updated to 01
[    0.608015] pci 0000:00:00.0: BAR 0: no space for [mem size 0x80000000]
[    0.614341] pci 0000:00:00.0: BAR 0: failed to assign [mem size 0x80000000]
[    0.621075] pci 0000:00:00.0: BAR 9: assigned [mem 0x20000000-0x201fffff pref]
[    0.628035] pci 0000:00:00.0: BAR 1: assigned [mem 0x20200000-0x2020ffff]
[    0.634605] pci 0000:01:00.0: BAR 0: assigned [mem 0x20000000-0x200fffff 64bit pref]
[    0.642079] pci 0000:01:00.0: BAR 2: assigned [mem 0x20100000-0x20103fff 64bit pref]
[    0.649565] pci 0000:01:00.0: BAR 4: assigned [mem 0x20104000-0x20104fff 64bit pref]
[    0.657029] pci 0000:00:00.0: PCI bridge to [bus 01]
[    0.661815] pci 0000:00:00.0:   bridge window [mem 0x20000000-0x201fffff pref]
[    0.676139] clocksource: Switched to clocksource MIPS
[    0.682537] NET: Registered protocol family 2
[    0.687045] IP idents hash table entries: 2048 (order: 2, 16384 bytes, linear)
[    0.694892] tcp_listen_portaddr_hash hash table entries: 512 (order: 0, 4096 bytes, linear)
[    0.703057] TCP established hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.710433] TCP bind hash table entries: 1024 (order: 0, 4096 bytes, linear)
[    0.717223] TCP: Hash tables configured (established 1024 bind 1024)
[    0.723518] UDP hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.729844] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes, linear)
[    0.736896] NET: Registered protocol family 1
[    0.741126] PCI: CLS 0 bytes, default 32
[    0.752726] workingset: timestamp_bits=14 max_order=14 bucket_order=0
[    0.764253] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.769923] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.781588] Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)
[    0.791325] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.797058] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.802621] mt7621_gpio 10000600.gpio: registering 32 gpios
[    0.808365] Serial: 8250/16550 driver, 16 ports, IRQ sharing enabled
[    0.817554] printk: console [ttyS0] disabled
[    0.821721] 10000c00.uartlite: ttyS0 at MMIO 0x10000c00 (irq = 28, base_baud = 2500000) is a 16550A
[    0.830506] printk: console [ttyS0] enabled
[    0.838906] printk: bootconsole [early0] disabled
[    0.849951] spi-mt7621 10000b00.spi: sys_freq: 191666666
[    0.874764] spi-nor spi0.0: gd25q128 (16384 Kbytes)
[    0.879889] 7 fixed-partitions partitions found on MTD device spi0.0
[    0.886423] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
[    0.893857] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
[    0.901857] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
[    0.909374] OF: Bad cell count for /palmbus@10000000/spi@b00/flash@0/partitions
[    0.917049] Creating 7 MTD partitions on "spi0.0":
[    0.921920] 0x000000000000-0x000000020000 : "bootloader"
[    0.931070] 0x000000020000-0x000000030000 : "config"
[    0.937474] 0x000000030000-0x000000040000 : "factory"
[    0.945645] 0x000000040000-0x000000050000 : "crash"
[    0.952039] 0x000000050000-0x000000060000 : "cfg_bak"
[    0.960265] 0x000000060000-0x000000160000 : "overlay"
[    0.966731] 0x000000160000-0x000001000000 : "firmware"
[    0.975070] 2 uimage-fw partitions found on MTD device firmware
[    0.981180] Creating 2 MTD partitions on "firmware":
[    0.986251] 0x000000000000-0x00000021b4ba : "kernel"
[    0.991282] mtd: partition "kernel" doesn't end on an erase/write block -- force read-only
[    1.001925] 0x00000021b4ba-0x000000ea0000 : "rootfs"
[    1.007051] mtd: partition "rootfs" doesn't start on an erase/write block boundary -- force read-only
[    1.017596] mtd: setting mtd8 (rootfs) as root device
[    1.023803] 1 squashfs-split partitions found on MTD device rootfs
[    1.030170] 0x0000005b0000-0x000000ea0000 : "rootfs_data"
[    1.094714] rt3050-esw 10110000.esw: mediatek esw at 0xb0110000, irq 25 initialized
[    1.103451] mtk_soc_eth 10100000.ethernet eth0: mediatek frame engine at 0xb0100000, irq 5
[    1.113836] NET: Registered protocol family 10
[    1.124519] Segment Routing with IPv6
[    1.128480] NET: Registered protocol family 17
[    1.133101] bridge: filtering via arp/ip/ip6tables is no longer available by default. Update your scripts to load br_netfilter if you need this.
[    1.146287] 8021q: 802.1Q VLAN Support v1.8
[    1.164998] VFS: Mounted root (squashfs filesystem) readonly on device 31:8.
[    1.179231] Freeing unused kernel memory: 1228K
[    1.183827] This architecture does not have kernel memory protection.
[    1.190398] Run /sbin/init as init process
[    1.194544]   with arguments:
[    1.194550]     /sbin/init
[    1.194554]   with environment:
[    1.194559]     HOME=/
[    1.194564]     TERM=linux
[    2.274470] init: Console is alive
[    2.278640] init: - watchdog -
[    3.517818] kmodloader: loading kernel modules from /etc/modules-boot.d/*
[    3.687190] kmodloader: done loading kernel modules from /etc/modules-boot.d/*
[    3.705192] init: - preinit -
[    5.302844] rt3050-esw 10110000.esw: port 4 link up
[    5.915401] random: jshn: uninitialized urandom read (4 bytes read)
[    6.183864] random: jshn: uninitialized urandom read (4 bytes read)
[    6.382499] random: jshn: uninitialized urandom read (4 bytes read)
[    7.114651] rt3050-esw 10110000.esw: port 4 link down
[    7.404705] random: procd: uninitialized urandom read (4 bytes read)
[   11.322588] rt3050-esw 10110000.esw: port 4 link up
[   11.327623] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   11.334669] IPv6: ADDRCONF(NETDEV_CHANGE): eth0.1: link becomes ready
[   11.878955] jffs2: notice: (415) jffs2_build_xattr_subsystem: complete building xattr subsystem, 19 of xdatum (16 unchecked, 3 orphan) and 25 of xref (3 dead, 0 orphan) found.
[   11.898783] mount_root: switching to jffs2 overlay
[   11.912857] overlayfs: upper fs does not support tmpfile.
[   11.927022] urandom-seed: Seeding with /etc/urandom.seed
[   12.140621] procd: - early -
[   12.144006] procd: - watchdog -
[   12.970351] procd: - watchdog -
[   12.975468] procd: - ubus -
[   13.116937] random: ubusd: uninitialized urandom read (4 bytes read)
[   13.128436] random: ubusd: uninitialized urandom read (4 bytes read)
[   13.145883] random: ubusd: uninitialized urandom read (4 bytes read)
[   13.165226] procd: - init -
[   14.230138] random: jshn: uninitialized urandom read (4 bytes read)
[   14.249214] random: ubusd: uninitialized urandom read (4 bytes read)
[   14.256251] random: ubus: uninitialized urandom read (4 bytes read)
[   15.173837] kmodloader: loading kernel modules from /etc/modules.d/*
[   15.748485] urngd: v1.0.2 started.
[   15.788400] Loading modules backported from Linux version v5.15.92-0-ge515b9902f5f
[   15.796099] Backport generated by backports.git v5.15.92-1-0-gdfe0f60c
[   15.979738] mt76_wmac 10300000.wmac: ASIC revision: 76280001
[   16.149755] random: crng init done
[   16.153221] random: 22 urandom warning(s) missed due to ratelimiting
[   17.201422] mt76_wmac 10300000.wmac: Firmware Version: 20151201
[   17.207485] mt76_wmac 10300000.wmac: Build Time: 20151201183641
[   17.226147] mt76_wmac 10300000.wmac: firmware init done
[   17.397172] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   17.612520] PPP generic driver version 2.4.2
[   17.627440] NET: Registered protocol family 24
[   17.802154] kmodloader: done loading kernel modules from /etc/modules.d/*
[   30.804720] rt3050-esw 10110000.esw: port 4 link down
[   35.012663] rt3050-esw 10110000.esw: port 4 link up
[   40.904678] br-lan: port 1(eth0.1) entered blocking state
[   40.910441] br-lan: port 1(eth0.1) entered disabled state
[   40.916365] device eth0.1 entered promiscuous mode
[   40.921237] device eth0 entered promiscuous mode
[   40.952054] br-lan: port 1(eth0.1) entered blocking state
[   40.957620] br-lan: port 1(eth0.1) entered forwarding state
[   41.926657] IPv6: ADDRCONF(NETDEV_CHANGE): br-lan: link becomes ready

Maybe the current official openwrt firmware still not support your R4AC model, you have to modify the dts files for the new model and build a special firmware. You could refer to other xiaomi dts files.

That's what I thought initially but device page for TP-Link Archer C6 v3 says

So it must be supported, right? Or is it like Adding a new device so docs there can be applied to mt76 driver here?

If not, do you mind linking docs about what should I be doing?

I did not know the details.
The mt76 wifi driver already in the system.
So check the xiaomi 4A gigabit dts file, maybe you mod the current dts file, just copy the wifi0 part and paste out a new wifi1 ?

It looks like new Xiaomi Mi Router 4A 100M version where wifi chip mt7612 was replaced by wifi chip mt7663. The same situation is for Xiaomi Mi Router 4A Gigabit edition version 2. Just compare xiaomi_mi-router-4a-gigabit and xiaomi_mi-router-4a-gigabit-v2 device firmware descriptions.
So you can add new device or just for test install correct driver:

opkg update
opkg install kmod-mt7615e kmod-mt7663-firmware-ap
1 Like

Thanks a lot, mate, it fixed the problem

Also thank you @RadioOperator, for your time and replies.

This topic was automatically closed 10 days after the last reply. New replies are no longer allowed.